Cannot set up InnoDB support in MySQL due to "pthread_create returned 11" error


#1

Hello,

i cannot set up InnoDB support in MySQL due to "pthread_create returned 11" error . i would like to ask for help and advice here :eek:
This is done on an OpenVZ VPS, Ubuntu 10.04 & CentOS

I have downloaded
http://dev.mysql.com/get/Downloads/MySQL-5.6/mysql-server_5.6.20-1ubuntu12.04_i386.deb-bundle.tar

Which has an InnoDB support out-of-the-box. Then, i've tried three different package managers in 3 different distributives (you helped me in swapping between them) in order to install mysql-server-5.6. And only last effort succeeded. Mysql worked with InnoDB support, but only with --skip-grant-tables key. Then i tried to delete database with "rm /var/mysql/db" and mysql_install_database it again. After all operations a stable "pthread_create returned 11" error take place.

Different combinations of different distributives and mysql versions (5.5/5.6) have the same behaivour..
Last case I had just tried to update Ubuntu and it failed for me =(.

I need only following commands to be executed correctly(ubuntu 10.04, lts):

apt-get install update-manager-core
do-release-upgrade
wget http://dev.mysql.com/get/Downloads/MySQL-5.6/mysql-server_5.6.20-1ubuntu14.04_i386.deb-bundle.tar
tar -xvf mysql-server_5.6.20-1ubuntu14.04_i386.deb-bundle.tar
apt-get install <unpacked file name>.deb

As a result, mysql database server 5.6 should be deployed on Ubuntu 14.04. doing "mysql -uroot" we can check a value in "show engines;" output. InnoDB support should be YES in it. Also, innoDB support can be checked many other ways.


#2

I am no expert here. A search reveals that the pthread create error can occur if you do not have enough memory (or other reasons). How much RAM do you have?

I have Ubuntu as a test server running on VirtualBox. I had to force the dist upgrade as it would not upgrade to 14.04. I found some instructions you can follow to force the upgrade.

http://www.cyberciti.biz/faq/howto-upgrade-to-ubuntu-14-04-from-ubuntu-13-10-or-12-04/

I don't know how well MySQL 5.6 would work on an older Ubuntu like 10.04 LTS, or if it would work. The last time I checked the MySQL version supported in the Ubuntu repo was 5.5 (for Ubuntu 14.04). Looking at the MySQL .deb package downloads, I do not see 10.04 listed for MySQL 5.6.

http://dev.mysql.com/downloads/mysql/

Force your distribution to upgrade to a newer Ubuntu then try again. I guess it is a good idea to install the MySQL client package as well. Report back if you are successful or not.


#3