Cannot send email to mail only. Help!

I. i just found out that all domains in my new server can send email to anywhere, except to, if sending email to its always rejected like below message using outlook express

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:
retry time not reached for any host after a long failure period

------ This is a copy of the message, including all the headers. ------

Return-path: <>
Received: from [my computer ip] (helo=computername)
by with esmtpa (Exim 4.69)
(envelope-from <>)
id 1PIM1j-0005w0-Ls
for; Tue, 16 Nov 2010 08:56:52 -0500
Message-ID: <000f01cb8596$17fc9950$6501a8c0@computername>
From: “” <>
To: <>
Subject: test1
Date: Tue, 16 Nov 2010 20:56:35 +0700
MIME-Version: 1.0
Content-Type: multipart/alternative;
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180

This is a multi-part message in MIME format.

Content-Type: text/plain;
Content-Transfer-Encoding: quoted-printable


Content-Type: text/html;
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC “-//W3C//DTD HTML 4.0 Transitional//EN”>
<META http-equiv=3DContent-Type content=3D"text/html; =
<META content=3D"MSHTML 6.00.2900.2180" name=3DGENERATOR>
<BODY bgColor=3D#ffffff><FONT size=3D1>
<DIV><FONT face=3DArial size=3D2></FONT> </DIV></BODY></HTML>


II. what should we do, i already search this problem in google , and i guess its could be because the rdns

quoted from resource :

Publish reverse DNS (PTR) records for your sending IPs. If there is no reverse DNS entry for your IP address, or if it looks like a dynamically-assigned IP instead of a static mail server, Yahoo! is more likely to downgrade its sending reputation.

The rDNS already setup

Here is the name server, i only use 1 dedicated ip, it is for, the other domains are shared : (main shared IP) (shared IP for root) (nameserver (nameserver (dedicated to

The hostname are, there is no dns zone for before, i already tried add that dns zone too before but still cant send email to, do you think maybe this is the problem, need to rdns too?

III. below are working example sending email to from, and from other domain

still not working sending email to, it is no problem when still using previous server, previous server are not using rdns at all

from <>
date Wed, Nov 17, 2010 at 4:43 AM
subject test1


  • example 2, from, using web script, the mailed-by information are from (no dns zone for this, i already tried add dns zone for this and set ip but still cannot send email to

from username <>
date Wed, Nov 17, 2010 at 4:30 AM
subject test2


from username <>
date Tue, Nov 16, 2010 at 8:56 PM
subject test3


Update guys, i am still fight to solve this bad luck because moving to new server

i just moving to this new server and the ip address few days ago, when still using previous server i dont get this problem, so the problem maybe is in this server/the ips, my hosting company cant help but they can do if i say need remove/change some reverse dns

already try some effort below but still didnt solved it

I’d recommend changing the RDNS for to the server’s host name to prevent problems with potential mail servers.

M*** Lee
Technical Analyst
cPanel, Inc

  • And some friends tell me this :

rDNS must match the email server host name

I already contact yahoo Postmaster team from this form, tell i already reviewed they [URL=“”]best practice and other explanation/details in the form 48 hours a go, then i already get reply back (but maybe just auto reply), and i replied the message again asking is it my ip address already whitelist or not since i am still cant send email to

Please help guys share your knowledge and experience, are you agree with 2 person above (cpanel staf and a friend)

Here is again the rDNS already setup by my hosting company

Here is the name server, i only use 1 dedicated ip, it is for, the other domains are shared : (main shared IP) (shared IP for root) (nameserver (nameserver (dedicated to

The hostname in whm are, need to rdns too?
if yes from what ips above? change from rdns to hostname
or change hostname in whm from to

i see in the hostname are, not, is it still ok or need to change above?