Cannot find .htaccess file anywhere


I have been given access to the FTP of a website. The URLs of this website have been rewritten. But I cannot find the .htaccess file anywhere in the code.
What could be the reason?

As he has done just about everything he can to enable him to see it there if it were there, there’s a very good chance that the file is actually not there and needs to instead be put there. If you get my drift. :slight_smile:

Click on the General FTP Sites and right click on the white area then click on New->Ftp and in the pop up box you can add the ftp information and connect it. And in the same dialog box you can find all those aforesaid.

.htaccess will not be in the server by default it is created later for rewritten purposes.

My server does not have a .htaccess file by default - does yours ?

Sure, that’s fair enough. I was just going on this original comment:

Figured it was worth a warning, anyhow.

Which FTP uploading software you are using? There is an option with Filezilla in the menu Server->Force showing hidden files.

I’m using CuteFTP 8.1 Professional from GlobalSCAPE.

I just have the following in the site manager:

General FTP Sites
GlobalSCAPE Download Site

I think, here I need to have my site also. What to do?:confused:

When I log in to an online file manager, there is usually an option to “show hidden files”. Otherwise, files like .htaccess aren’t shown. See if you can find that option. How are you accessing the server? “FTP access” is a bit vague to me. Are you accessing the site vie something like CPanel?

Yes I have done it correctly. But cannot see the file.

Is it possible for a site to have its URLs rewritten without having .htaccess file?

Actually our site has many servers and I have been given access to one of them. Could that be a reason?

As long as the purpose is to overwrite the original. If that’s not the aim, this could cause trouble.

Anyway, it can be hard to create a .htaccess locally. The way I have to do it is create a file called something like htaccess.txt, add in the required content, then rename it .htacess and then upload.

Step 1: Go to Sitemanager.
Step 2: Choose the connection and click edit.
Step 3: Make sure filters is checked.
Step 4: Press the filter button towards the bottom.
Step 5: Check [Enable remote filters (Server applied filter)]
Step 6: In the box below add -al
Step 7: Hit apply, now log in with that connection.

There might be not yet be an .htaccess file

Did you do the following step correctly?
Step 6: In the box below add -al

‘-al’ should be typed in the text box below the check box.

If still it does not work then there is no .htaccess file there in your folder. I can see the file here in my case.

Okay, I have got my site in the site manager.

And I have rt.clicked connection, chose actions tab,clicked on Filter, checked ‘Enable server side filtering’, entered -a in the textbox below, clicked on OK, clicked on Connect.

I have reconnected many times, but still could not find the .htaccess file.

Note: After clicking on the filter button in the actions tab, I get the ‘Filter Properties’ tab where I changed the Server side filtering part. The part above this has four options out of which, only the first one, that is, ‘Enable Filtering’ is checked. The rest of the three are however unchecked.

.htaccess should be in the root directory, but it will only be there if it actually exists.

Have you confirmed that the file already exists? Create a .htaccess file locally and try to upload it.

I have got access to a subdomain. And its the subdomain where URL rewriting has been done. Is it possible that the .htaccess file is placed outside the subdomain folder?

Note: as far as I know .htaccess file should be in the same directory.