<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8">
    <title>Can this function be organized better? - #155 by asasass - JavaScript - SitePoint Forums | Web Development &amp; Design Community</title>
    <meta name="description" content="How can this function be organized better? 
https://jsfiddle.net/3p5vadjy/5/ 
Code 1 adds a delay to the fadeout 
   setTimeout(function() {
      const fadeout = document.querySelector(&amp;quot;.fadeout&amp;quot;);
      fadeout.classLi&amp;hellip;">
    <meta name="generator" content="Discourse 2.8.0.beta7 - https://github.com/discourse/discourse version 436edbb51a15c634e65c0d7cdccdb4ce9aecd8f1">
<link rel="icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/0/6/06fa311765b08c4cdf3963f8b19b2e6792559176_2_32x32.ico">
<link rel="apple-touch-icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/2/5/251fedb1e929595050b23e6f0ce837f0d59d7be1_2_180x180.png">
<meta name="theme-color" content="#3a3a3a">
<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, user-scalable=yes, viewport-fit=cover">
<meta name="discourse-base-uri" content="/community">
<link rel="canonical" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087?page=7" />
<script type="application/ld+json">{"@context":"http://schema.org","@type":"WebSite","url":"https://www.sitepoint.com/community","potentialAction":{"@type":"SearchAction","target":"https://www.sitepoint.com/community/search?q={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="search" type="application/opensearchdescription+xml" href="https://www.sitepoint.com/community/opensearch.xml" title="SitePoint Forums | Web Development &amp; Design Community Search">

      <link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_10f06dc840797f18edcd3b88dc89fa3558a711df.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop"  />
      <link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_521_4d612aefedac29c8ae227ba6f5d9ee812e27f1df.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="521" data-theme-name="nav links component"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_515_56e05d69d10c5a8e8833b7bbb7391f341cb252c6.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="515" data-theme-name="header"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_518_73b67dba50be6693c2128dec1c87f1566165976c.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="518" data-theme-name="hide buttons on review page"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_514_dba31a5d66faf1c7ac3259c1c14020555798a40f.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="514" data-theme-name="signup"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_516_12d49da649c8d1c766a63e9580c77e3382832f7f.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="516" data-theme-name="signup - onboard"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_517_59573d6859cc0dccd63976406eb4eed9c0bd2dee.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="517" data-theme-name="signup - set password"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_513_a8cef3b6dc4a27804d9a2ed767e38c534ff20382.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="513" data-theme-name="sp ads"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_519_bee9c19d58840416d1a648904ded43ae441b8ac0.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="519" data-theme-name="staff name colors"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_512_ca57a4893f4d95551c737ac2d97c58f72cfbef82.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="512" data-theme-name="topic post"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_522_e5a87cfb667c5998de021639064218ed31a18efa.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="522" data-theme-name="underline links in posts"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_511_ef2aa6ec46d60c529035b925f4498d1cf312efc8.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="511" data-theme-name="sitepoint"/>
    <!-- Proper Ad Script -->
<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/6ef07837143d5fffd5fe4a7ddece907ed3758b1b.js?__ws=www.sitepoint.com"></script>
<div id="sp-modal-signup" class="sp-modal hidden" style="display: none;">
  <div class="sp-modal__overlay"></div>
  <div class="sp-modal__content">
    <h3 class="title"></h3>
    <div class="content-body">
      <div>
        <ul class="description"></ul>
        <label class="label-login"></label>
      </div>
      <form name="signup-form" id="signup-form" action="">
        <label class="error"></label>
        <input type="hidden" name="origin" value="community">
        <input type="text" name="username" placeholder="Username" required="">
        <input type="email" name="email" placeholder="Email" required="">
        <button class=" btn" type="submit"></button></form>
      
    </div>
    <div class="content-footer">
      <label class="label-social"></label>
      <div class="login-social"></div>
    </div>
    <button title="close" class="sp-close-modal"></button>
  </div>

  
</div><script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/84c383874314c29a12824432b578dc9ec26ebfd2.js?__ws=www.sitepoint.com"></script>
<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/12e8f1330bb2863428049315a91dd1bffef56849.js?__ws=www.sitepoint.com"></script>
<div id="sp-modal-onboard" class="sp-modal hidden" style="display: none;">
  <div class="sp-modal__overlay"></div>
  <div class="sp-modal__content">
    <div>
      <h3></h3>
      <p></p>
    </div>
    <div class="sp-modal__cover-container">
      <img class="sp-modal__cover" src="">
    </div>
    <button title="close" class="sp-close-modal"></button>
  </div>

  
</div><script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/572fe22f3412926aca181dadbfa2d886f41f2ac0.js?__ws=www.sitepoint.com"></script>
<div id="sp-modal-set-password" class="sp-modal hidden" style="display: none;">
  <div class="sp-modal__overlay"></div>
  <div class="sp-modal__content">
    <h3></h3>
    <div>
      <p></p>
      <form name="set-password-form" id="set-password-form" action="" method="POST">
        <label class="error"></label>
        <input type="password" name="password" placeholder="Password" required="" minlength="10" pattern="(?=.*\d)(?=.*[a-z])(?=.*[A-Z]).*">
        <label class="requirements"></label>
        <button class="btn" type="submit"></button></form>
      
    </div>
    <button title="close" class="sp-close-modal"></button>
  </div>

  
</div><script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/00c03d9db1444f140c4a7e1847872155e4ec327d.js?__ws=www.sitepoint.com"></script>
<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/bf19ff40fa9b3dffffada79ed67e9dd75d410132.js?__ws=www.sitepoint.com"></script>

<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/6962ee34197c5bcbce2f55a7e37b7f5bfbebf4b6.js?__ws=www.sitepoint.com"></script>
    <meta id="data-ga-universal-analytics" data-tracking-code="UA-30131-1" data-json="{&quot;cookieDomain&quot;:&quot;auto&quot;}" data-auto-link-domains="">

  <link rel="preload" href="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-v3-706f1d28f0a97f67a47515c96189277240ec4940d968955042066d7873fd1fe8.gz.js" as="script">
<script src="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-v3-706f1d28f0a97f67a47515c96189277240ec4940d968955042066d7873fd1fe8.gz.js"></script>


        <link rel="alternate" type="application/rss+xml" title="RSS feed of &#39;Can this function be organized better?&#39;" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087.rss" />
    <meta property="og:site_name" content="SitePoint Forums | Web Development &amp; Design Community" />
<meta property="og:type" content="website" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:url" content="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087/155" />
<meta name="twitter:url" content="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087/155" />
<meta property="og:title" content="Can this function be organized better?" />
<meta name="twitter:title" content="Can this function be organized better?" />
<meta property="og:description" content="I did this: https://jsfiddle.net/matgch9d/   You will get an console error saying: “Uncaught ReferenceError: body is not defined”     function init() {     const exitButtons = document.querySelectorAll(&quot;.exit&quot;);     addClickToExit(exitButtons);     body.addEventListener(&quot;animationend&quot;, onAnimationEnd);   }   That is when you place a copy of the body variable in the init function.   That would mean this:  const body = document.body;  Gets added to here? https://jsfiddle.net/pwnf70tr/  function in..." />
<meta name="twitter:description" content="I did this: https://jsfiddle.net/matgch9d/   You will get an console error saying: “Uncaught ReferenceError: body is not defined”     function init() {     const exitButtons = document.querySelectorAll(&quot;.exit&quot;);     addClickToExit(exitButtons);     body.addEventListener(&quot;animationend&quot;, onAnimationEnd);   }   That is when you place a copy of the body variable in the init function.   That would mean this:  const body = document.body;  Gets added to here? https://jsfiddle.net/pwnf70tr/  function in..." />
<meta property="article:published_time" content="2021-11-06T02:30:08+00:00" />
<meta property="og:ignore_canonical" content="true" />

        <link rel="prev" href="/community/t/can-this-function-be-organized-better/371087?page=6">

    
  </head>
  <body class="crawler">
    
<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/fc4409811f1414056992ba3c59c61c7a42675242.js?__ws=www.sitepoint.com"></script>
<link href="https://fonts.googleapis.com/css?family=Roboto&amp;display=swap" rel="stylesheet">


<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/375663796349b60db60a837aa565d4b10840bbdd.js?__ws=www.sitepoint.com"></script>
    <header>
      <a href="/community/">
          <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg" alt="SitePoint Forums | Web Development &amp; Design Community" id="site-logo" style="max-width: 150px;">
      </a>
    </header>
    <div id="main-outlet" class="wrap">
        <div id="topic-title">
    <h1>
      <a href="/community/t/can-this-function-be-organized-better/371087">Can this function be organized better?</a>
    </h1>

      <div class="topic-category" itemscope itemtype="http://schema.org/BreadcrumbList">
          <span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
            <a href="https://www.sitepoint.com/community/community/c/javascript/33" class="badge-wrapper bullet" itemprop="item">
              <span class='badge-category-bg' style='background-color: #d3a604'></span>
              <span class='badge-category clear-badge'>
                <span class='category-name' itemprop='name'>JavaScript</span>
              </span>
            </a>
            <meta itemprop="position" content="1" />
          </span>
      </div>

  </div>

  


      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-03T21:32:26Z' class='post-time'>
                November 3, 2021,  9:32pm
              </time>
              <meta itemprop='dateModified' content='2021-11-03T21:40:10Z'>
          <span itemprop='position'>#131</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><strong>This is the original working code:</strong> <a href="https://jsfiddle.net/gqf35tys/" rel="noopener nofollow ugc">https://jsfiddle.net/gqf35tys/</a></p>
<p>Where the only change that was made here was <strong>document</strong> changed to <strong>body</strong>.<br>
And where <strong>fadeResetHandler</strong> was given as the function name.</p>
<pre><code class="lang-auto">function resetPage() {

    const body = document.body;
    body.classList.add("fadingOut");

    const onAnimationEnd = function fadeResetHandler() {

      body.classList.remove("fadingOut");
      resetBackground("body");
      resetCurtains(".with-curtain");
      showAllButtons(".container.hide");
      resetButtons(".outer");
      body.removeEventListener("animationend", onAnimationEnd);
      console.log("remove");
    }
    body.addEventListener("animationend", onAnimationEnd);
  }
</code></pre>
<p>This is what I consider to be the fadeResetHandler function:</p>
<pre><code class="lang-auto">const onAnimationEnd = function fadeResetHandler() {

}
</code></pre>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>
          <meta itemprop='keywords' content=''>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">

            <link itemprop="image" href="https://aws1.discourse-cdn.com/sitepoint/original/3X/f/2/f29a5a198e086570cd393929c4707d72ec40d8a3.png">

          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-03T22:03:58Z' class='post-time'>
                November 3, 2021, 10:03pm
              </time>
              <meta itemprop='dateModified' content='2021-11-03T22:03:58Z'>
          <span itemprop='position'>#132</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="asasass" data-post="131" data-topic="371087">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://avatars.discourse-cdn.com/v4/letter/a/ee59a6/40.png" class="avatar"> asasass:</div>
<blockquote>
<p>This is what I consider to be the fadeResetHandler function:</p>
<pre><code class="lang-auto">const onAnimationEnd = function fadeResetHandler() {

}
</code></pre>
</blockquote>
</aside>
<p>That’s not correct, and I am assuming that you also intend that the content inside of the function is also included.</p>
<p>I think that we have narrowed down to find one of your misunderstandings.</p>
<p>The fadeResetHandler function only starts at the keyword <code>function</code>, and it ends at the closing curly brace.</p>
<p>When you are instructed to move the fadeResetHandler somewhere, it is only the text from the word <code>function</code> through to the closing curly brace that gets moved. Everything else remains the same.</p>
<p>Here is the fadeResetHandler function, shaded to help demonstrate more clearly.</p>
<p><img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/f/2/f29a5a198e086570cd393929c4707d72ec40d8a3.png" alt="function" data-base62-sha1="yCafdfj18xIkcBWosRaCJTDZKBd" width="501" height="227"></p>
<p>When you are instructed to move the fadeResetHandler function somewhere, it is only the shaded part of the text that gets moved. Nothing else.</p>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-03T22:12:20Z' class='post-time'>
                November 3, 2021, 10:12pm
              </time>
              <meta itemprop='dateModified' content='2021-11-03T22:18:07Z'>
          <span itemprop='position'>#133</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>What do I do after I do this? <a href="https://jsfiddle.net/t19y4d5m/" rel="noopener nofollow ugc">https://jsfiddle.net/t19y4d5m/</a></p>
<pre><code class="lang-auto"> function resetPage() {

    const body = document.body;
    body.classList.add("fadingOut");

    function fadeResetHandler() {

      body.classList.remove("fadingOut");
      resetBackground("body");
      resetCurtains(".with-curtain");
      showAllButtons(".container.hide");
      resetButtons(".outer");
      body.removeEventListener("animationend", onAnimationEnd);
      console.log("remove");
    }
    
    const onAnimationEnd = fadeResetHandler;

    body.addEventListener("animationend", onAnimationEnd);
  }
</code></pre>
<p><strong>If you want me to next:</strong> delete this line: <code>body.removeEventListener("animationend", onAnimationEnd);</code></p>
<p>This issue occurs<br>
<strong>Issue:</strong></p>
<p><strong>Page changes back on its own</strong></p>
<p><strong>To reproduce</strong> , click on 1 svg play button, then click the <strong>Exit button</strong> .</p>
<p>Click on a 2nd svg play button and then don’t touch anything.</p>
<p>You will notice that the page goes back to the svg play buttons on its own without touching anything.</p>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-03T23:24:57Z' class='post-time'>
                November 3, 2021, 11:24pm
              </time>
              <meta itemprop='dateModified' content='2021-11-03T23:24:57Z'>
          <span itemprop='position'>#134</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="asasass" data-post="133" data-topic="371087">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://avatars.discourse-cdn.com/v4/letter/a/ee59a6/40.png" class="avatar"> asasass:</div>
<blockquote>
<p>What do I do after I do this? <a href="https://jsfiddle.net/t19y4d5m/">https://jsfiddle.net/t19y4d5m/</a></p>
</blockquote>
</aside>
<p>I want you to carry on with the instructions from <a href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087/100">post #100</a>, which is to move that fadeResetHandler out of the resetPage function, to a location that’s just above the resetPage function.</p>
<p>That location outside of the resetPage function is needed for later plans, so that the fadeResetHandler function can be accessed from elsewhere in the code.</p>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-03T23:37:17Z' class='post-time'>
                November 3, 2021, 11:37pm
              </time>
              <meta itemprop='dateModified' content='2021-11-04T02:27:55Z'>
          <span itemprop='position'>#135</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>There are 2 things named <strong>fadeResetHandler</strong></p>
<p>You didn’t say function, so I moved this: <code>const onAnimationEnd = fadeResetHandler;</code></p>
<p><strong>Above:</strong> <code>function resetPage() {</code></p>
<p>Is this what you wanted me to do? <a href="https://jsfiddle.net/otLpqa1x/" rel="noopener nofollow ugc">https://jsfiddle.net/otLpqa1x/</a></p>
<p>Where I then receive the error:</p>
<blockquote>
<p>fadeResetHandler is not defined</p>
</blockquote>
<pre><code class="lang-auto">const onAnimationEnd = fadeResetHandler;

  function resetPage() {

    const body = document.body;
    body.classList.add("fadingOut");

    function fadeResetHandler() {

      body.classList.remove("fadingOut");
      resetBackground("body");
      resetCurtains(".with-curtain");
      showAllButtons(".container.hide");
      resetButtons(".outer");
      body.removeEventListener("animationend", onAnimationEnd);
      console.log("remove");
    }

    body.addEventListener("animationend", onAnimationEnd);
  }
</code></pre>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/windbeneathmywings'><span itemprop='name'>windbeneathmywings</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-04T01:52:15Z' class='post-time'>
                November 4, 2021,  1:52am
              </time>
              <meta itemprop='dateModified' content='2021-11-04T01:55:29Z'>
          <span itemprop='position'>#136</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Do you really find this to be an effective way to learn JavaScript? This entire thread is basically back and forth copy and pasting a provided answer little by little with no real problem solving on the others part. The only thing I can ascertain from this thread is the need for someone to step back and learn some basic JavaScript and programming concepts. After coming back to this and perhaps learning something rather than asking and waiting for step by step answers like a machine. Just copying and pasting step by step instructions like this isn’t programming neither is it going to be very effective teaching much.</p>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="5" />
           <span class='post-likes'>5 Likes</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-04T04:10:32Z' class='post-time'>
                November 4, 2021,  4:10am
              </time>
              <meta itemprop='dateModified' content='2021-11-04T04:10:32Z'>
          <span itemprop='position'>#137</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="asasass" data-post="135" data-topic="371087">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://avatars.discourse-cdn.com/v4/letter/a/ee59a6/40.png" class="avatar"> asasass:</div>
<blockquote>
<p>There are 2 things named <strong>fadeResetHandler</strong></p>
<p>You didn’t say function, so I moved this: <code>const onAnimationEnd = fadeResetHandler;</code></p>
</blockquote>
</aside>
<p>Sorry, I can’t think of everything. It is the <strong>fadeResetHandler function</strong> that you are to move.</p>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-04T04:24:41Z' class='post-time'>
                November 4, 2021,  4:24am
              </time>
              <meta itemprop='dateModified' content='2021-11-04T04:51:03Z'>
          <span itemprop='position'>#138</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>This? <a href="https://jsfiddle.net/r427dymv/" rel="noopener nofollow ugc">https://jsfiddle.net/r427dymv/</a></p>
<p>What do I do next?</p>
<pre><code class="lang-auto"> function fadeResetHandler() {

    function resetPage() {

      const body = document.body;
      body.classList.add("fadingOut");

      body.classList.remove("fadingOut");
      resetBackground("body");
      resetCurtains(".with-curtain");
      showAllButtons(".container.hide");
      resetButtons(".outer");
      body.removeEventListener("animationend", onAnimationEnd);
      console.log("remove");
    }

    const onAnimationEnd = fadeResetHandler;

    body.addEventListener("animationend", onAnimationEnd);
  }
</code></pre>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-04T07:43:00Z' class='post-time'>
                November 4, 2021,  7:43am
              </time>
              <meta itemprop='dateModified' content='2021-11-04T07:43:00Z'>
          <span itemprop='position'>#139</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>It is the whole fadeResetHandler function that you need to move, not only the top line of the function.</p>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-04T12:57:12Z' class='post-time'>
                November 4, 2021, 12:57pm
              </time>
              <meta itemprop='dateModified' content='2021-11-04T12:57:12Z'>
          <span itemprop='position'>#140</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>The code stops working after the function is taken out. <a href="https://jsfiddle.net/cxsgj7tm/" rel="noopener nofollow ugc">https://jsfiddle.net/cxsgj7tm/</a></p>
<pre><code class="lang-auto">function fadeResetHandler() {

    body.classList.remove("fadingOut");
    resetBackground("body");
    resetCurtains(".with-curtain");
    showAllButtons(".container.hide");
    resetButtons(".outer");
    body.removeEventListener("animationend", onAnimationEnd);
    console.log("remove");
  }

  function resetPage() {
    const body = document.body;
    body.classList.add("fadingOut");

    /*body.classList.remove("fadingOut");
    resetBackground("body");
    resetCurtains(".with-curtain");
    showAllButtons(".container.hide");
    resetButtons(".outer");
    body.removeEventListener("animationend", onAnimationEnd);
    console.log("remove");
  }*/

    const onAnimationEnd = fadeResetHandler;

    body.addEventListener("animationend", onAnimationEnd);
  }
</code></pre>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-04T18:48:57Z' class='post-time'>
                November 4, 2021,  6:48pm
              </time>
              <meta itemprop='dateModified' content='2021-11-04T18:48:57Z'>
          <span itemprop='position'>#141</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Yes, the code stops working here for a good reason. The function is in the correct place where it needs to be, and we just need to make a few adjustments to the function to get it working again.</p>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-04T23:27:36Z' class='post-time'>
                November 4, 2021, 11:27pm
              </time>
              <meta itemprop='dateModified' content='2021-11-04T23:27:36Z'>
          <span itemprop='position'>#142</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>What are the adjustments that need to be made in the code?</p>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-05T04:51:37Z' class='post-time'>
                November 5, 2021,  4:51am
              </time>
              <meta itemprop='dateModified' content='2021-11-05T04:51:37Z'>
          <span itemprop='position'>#145</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>It was a simple thing that was done to cause the problem, that simple thing being to move the fadeResetHandler function out of the resetPage function. So it should be a simple thing to fix the problem.</p>
<p>What causes the problem is that fadeResetHandler uses the body variable. That was defined in the resetPage function. The simple solution is to give fadeResetHandler access to the body element.</p>
<p>The fadeResetHandler function is an event handler, so it can easily access the event object through the first parameter in its parameter list. To reword slightly, the simple solution is to let the event handler access the event object. We don’t have a first parameter specified yet for the fadeResetHandler so that should be done first. Normally it’s a parameter of <code>evt</code> that is used to give event handlers access to the event object.</p>
<p>Because the event is happening on the body element:</p>
<pre><code class="lang-javascript">    body.addEventListener("animationend", onAnimationEnd);
</code></pre>
<p>the event object contains a reference to that body element in a property called target, which we can assign to a variable called <code>body</code>. That is the simple stuff that needs to be done to fix the problem.</p>
<p>Alternatively we could instead just use document.body instead of body in the function, but that is a bad design because it guarantees that the function will break whenever the animationend event is changed to be on a different element. We don’t want code to break, we don’t want brittle code at all, which is why the event object is so beneficial when it comes to dealing with event handlers.</p>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-05T05:54:51Z' class='post-time'>
                November 5, 2021,  5:54am
              </time>
              <meta itemprop='dateModified' content='2021-11-05T05:54:51Z'>
          <span itemprop='position'>#146</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>The code is working now, what is the next thing I should do?</p>
<p><a href="https://jsfiddle.net/4my8kxot/" rel="noopener nofollow ugc">https://jsfiddle.net/4my8kxot/</a></p>
<pre><code class="lang-auto">function fadeResetHandler() {
    const body = document.body;
    body.classList.remove("fadingOut");
    resetBackground("body");
    resetCurtains(".with-curtain");
    showAllButtons(".container.hide");
    resetButtons(".outer");

    const onAnimationEnd = fadeResetHandler;
    body.removeEventListener("animationend", onAnimationEnd);
    console.log("remove");
  }

  function resetPage() {
    const body = document.body;
    body.classList.add("fadingOut");

    const onAnimationEnd = fadeResetHandler;
    body.addEventListener("animationend", onAnimationEnd);
  }
</code></pre>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-05T06:18:32Z' class='post-time'>
                November 5, 2021,  6:18am
              </time>
              <meta itemprop='dateModified' content='2021-11-05T06:18:32Z'>
          <span itemprop='position'>#147</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>The code might be working, but it’s not being done in a correct and proper way.</p>
<p>The fadeResetHandler needs a function parameter called evt, so that document.body in the fadeResetHandler function can be replaced with evt.target</p>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-05T06:27:25Z' class='post-time'>
                November 5, 2021,  6:27am
              </time>
              <meta itemprop='dateModified' content='2021-11-05T06:27:25Z'>
          <span itemprop='position'>#148</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Like this? <a href="https://jsfiddle.net/ma8pck75/" rel="noopener nofollow ugc">https://jsfiddle.net/ma8pck75/</a></p>
<p>What do I do after this?</p>
<pre><code class="lang-auto">function fadeResetHandler(evt) {
    const body = evt.target;
    body.classList.remove("fadingOut");
    resetBackground("body");
    resetCurtains(".with-curtain");
    showAllButtons(".container.hide");
    resetButtons(".outer");

    const onAnimationEnd = fadeResetHandler;
    body.removeEventListener("animationend", onAnimationEnd);
    console.log("remove");
  }

  function resetPage() {
    const body = document.body;
    body.classList.add("fadingOut");

    const onAnimationEnd = fadeResetHandler;
    body.addEventListener("animationend", onAnimationEnd);
  }
</code></pre>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-05T07:58:15Z' class='post-time'>
                November 5, 2021,  7:58am
              </time>
              <meta itemprop='dateModified' content='2021-11-05T07:58:15Z'>
          <span itemprop='position'>#149</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="asasass" data-post="148" data-topic="371087">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://avatars.discourse-cdn.com/v4/letter/a/ee59a6/40.png" class="avatar"> asasass:</div>
<blockquote>
<p>Like this? <a href="https://jsfiddle.net/ma8pck75/">https://jsfiddle.net/ma8pck75/</a></p>
<p>What do I do after this?</p>
</blockquote>
</aside>
<p>Moving the fadeResetHandler function above the resetPage function is now successful. The more common way to say that is that you have extracted the fadeResetHandler function.</p>
<p>The next thing to do from there is to carry on with the instructions from <a href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087/100">post #100</a></p>
<p>As a reminder, the instructions are:</p>
<aside class="quote group-Advisors" data-username="Paul_Wilkins" data-post="100" data-topic="371087">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sea2.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/paul_wilkins/40/9167_2.png" class="avatar"> Paul_Wilkins:</div>
<blockquote>
<p>Instead of adding and removing the event listener, it’s best to add the event listener only once, usually from an init function, and don’t fiddle with it afterwards. To achieve that the fadeResetHandler function cannot be inside of the resetPage function. That fadeResetHandler function needs to be moved out of that function, possibly just above the resetPage function. That way the addEventListener can be moved to the init function, and the fadeResetHandler function can still be accessed from there. That way the removeEventHandler statement can be removed, helping to make your code more reliable across different web browsers.</p>
</blockquote>
</aside>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-05T08:26:03Z' class='post-time'>
                November 5, 2021,  8:26am
              </time>
              <meta itemprop='dateModified' content='2021-11-05T08:26:03Z'>
          <span itemprop='position'>#150</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Next is:</p>
<blockquote>
<p>the addEventListener can be moved to the init function,</p>
</blockquote>
<p>This was my attempt:<a href="https://jsfiddle.net/dcg5zfha/" rel="noopener nofollow ugc">https://jsfiddle.net/dcg5zfha/</a></p>
<p>What am I doing wrong, and should be doing instead?</p>
<pre><code class="lang-auto">function fadeResetHandler(evt) {
    const body = evt.target;
    body.classList.remove("fadingOut");
    resetBackground("body");
    resetCurtains(".with-curtain");
    showAllButtons(".container.hide");
    resetButtons(".outer");

    const onAnimationEnd = fadeResetHandler;
    body.removeEventListener("animationend", onAnimationEnd);
    console.log("remove");
  }

  function resetPage() {
    const body = document.body;
    body.classList.add("fadingOut");

    /*const onAnimationEnd = fadeResetHandler;    
      body.addEventListener("animationend", onAnimationEnd);*/
  }

  function init(evt) {
    const body = evt.target;
    const exitButtons = document.querySelectorAll(".exit");
    addClickToExit(exitButtons);
    const onAnimationEnd = fadeResetHandler;
    body.addEventListener("animationend", onAnimationEnd);
  }
</code></pre>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-05T20:28:25Z' class='post-time'>
                November 5, 2021,  8:28pm
              </time>
              <meta itemprop='dateModified' content='2021-11-05T21:45:28Z'>
          <span itemprop='position'>#151</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Sorry no, you’ve done far too much and most of it is wrong.</p>
<p>Can you please just do the simple small thing that has been asked of you, which is to move the addEventListener to the init function. Nothing more.</p>
<p>You will get an console error saying: “Uncaught ReferenceError: body is not defined”<br>
That is when you place a copy of the body variable in the init function.</p>
<p>There are a few other good ways to deal with that.</p>
<p>One way is to add a body variable to the init function. That does though result in us having a body variable in two places, one in resetPage, and one in init. That doesn’t become a problem until we have three such duplicates in the one module. If that occurs we can then move one of them up to a higher level, such as to the top of the module, and use that single body variable from all other places instead.</p>
<p>Another way to solve that is to use a technique called “inline the variable” where the body variable is removed and we instead use what it refers to instead in the code, that being document.body.</p>
<p>However, none of that needs to be solved right now. It’s perfectly good and okay to have two body variables in different places, especially when there’s no good way for one of them to refer to the other. It’s when three-such examples occur though that concern is merited.</p>
<p>After doing that we get a new error message: “Uncaught ReferenceError: onAnimationEnd is not defined”</p>
<p>The onAnimationEnd variable isn’t doing anything useful. We already know that it’s for the animationend event, and it’s just acting as an indirect pass-through to the fadeResetHandler function. Here we get rid of that indirection, and just use fadeResetHandler instead of onAnimationEnd.</p>
<p>The init function is now happy, and there is some cleaning up to do, but the bulk of the work is done.</p>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/can-this-function-be-organized-better/371087">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-11-06T02:30:08Z' class='post-time'>
                November 6, 2021,  2:30am
              </time>
              <meta itemprop='dateModified' content='2021-11-06T03:42:31Z'>
          <span itemprop='position'>#155</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>I did this: <a href="https://jsfiddle.net/matgch9d/" rel="noopener nofollow ugc">https://jsfiddle.net/matgch9d/</a></p>
<blockquote>
<p>You will get an console error saying: “Uncaught ReferenceError: body is not defined”</p>
</blockquote>
<pre><code class="lang-auto">  function init() {
    const exitButtons = document.querySelectorAll(".exit");
    addClickToExit(exitButtons);
    body.addEventListener("animationend", onAnimationEnd);
  }
</code></pre>
<blockquote>
<p>That is when you place a copy of the body variable in the init function.</p>
</blockquote>
<p>That would mean this:  <code>const body = document.body;</code></p>
<p>Gets added to here? <a href="https://jsfiddle.net/pwnf70tr/" rel="noopener nofollow ugc">https://jsfiddle.net/pwnf70tr/</a></p>
<pre><code class="lang-auto">function init() {
    const exitButtons = document.querySelectorAll(".exit");
    addClickToExit(exitButtons);
    const body = document.body;
    body.addEventListener("animationend", onAnimationEnd);
  }
</code></pre>
<blockquote>
<p>After doing that we get a new error message: “Uncaught ReferenceError: onAnimationEnd is not defined”</p>
</blockquote>
<blockquote>
<p>Here we get rid of that indirection, and just use fadeResetHandler instead of onAnimationEnd.</p>
</blockquote>
<p><strong>I did that here:</strong> <a href="https://jsfiddle.net/u3kgxdrm/" rel="noopener nofollow ugc">https://jsfiddle.net/u3kgxdrm/</a></p>
<p>The code is now broken and not functioning properly.</p>
<pre><code class="lang-auto"> function init() {
    const exitButtons = document.querySelectorAll(".exit");
    addClickToExit(exitButtons);
    const body = document.body;
    body.addEventListener("animationend", fadeResetHandler );
  }
</code></pre>
<p>I am not able to click on all the play svg buttons without it breaking.</p>
<blockquote>
<p>The init function is now happy, and there is some cleaning up to do, but the bulk of the work is done.</p>
</blockquote>
<p>But the code is not functioning properly, how is that good?</p>
        </div>

        <meta itemprop='headline' content='Can this function be organized better?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>

    <div role='navigation' itemscope itemtype='http://schema.org/SiteNavigationElement' class="topic-body crawler-post">
        <span itemprop='name'><a rel="prev" itemprop="url" href="/community/t/can-this-function-be-organized-better/371087?page=6">← previous page</a></span>
    </div>





    </div>
    <footer class="container wrap">
      <nav class='crawler-nav'>
        <ul>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/' itemprop="url">Home </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/categories' itemprop="url">Categories </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/guidelines' itemprop="url">FAQ/Guidelines </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/tos' itemprop="url">Terms of Service </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/privacy' itemprop="url">Privacy Policy </a>
          </span>
        </li>
        </ul>
      </nav>
      <p class='powered-by-link'>Powered by <a href="https://www.discourse.org">Discourse</a>, best viewed with JavaScript enabled</p>
    </footer>
    
    <div id="footer-ad-spacer"></div>
<div id="footer-ad" class="proper-ad-unit ad-sticky">

    
     <div id="proper-ad-sitepoint_left_sticky">  </div>
     
</div><script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/be63710d6fb6a95a92f8c7ea8836704b560e4661.js?__ws=www.sitepoint.com"></script>
  </body>
  
</html>
