Can not delete folder in XP

This is bizarre to me. I have a folder on my HD that I can not delete for the life of me. It gives me the “access denied” error when I try to delete. The file is not in use as far as I can see, and it is not write protected. I have rebooted and tried to delete it, and it just wont go. Any ideas?

Try renaming it. That has worked for me.

If its really bothering you try booting in safe mode.

Has the folder got images in it? Change view thumbnails to view list and delete the thumbs.db

Try again.

If a program is using it you can’t delete it or rename it. End the program using it, and if you don’t know which program is using the file, boot up in safe mode like jojoyohan said.

In '98 (I know), it’s right-click, -> Properties. Then if any Attributes are checked, uncheck them.

moveonboot can take care of this.

Renaming did not work

Safe mode did not work

I am just wondering what the heck program could be using these folders, they are nothing folders that were unzipped from a non valid archive that errored out. So the folders are the only things that showed up on the HD with nothing in them.

When I really have to remove a folder like this - I do it in pure DOS mode starting from floppy disc. It will work if the first letters of the folder name are unique - deleting random XXXXXX~1 folder wouldn’t be a good idea for sure.

This did not work either.

If you think this because you looked at them using “explorer” you may be wrong. You should look at them from either MS-DOS or from “Find”
After I unzip a file with “stuffit” a folder named “My Archives” is created. Using explorer it’s empty. If I use find, choose the folder, and “Find Now” all files, it contains a file named index.dat
I was wondering, you couldn’t uncheck the folder’s properties (archive, read-only, system) with XP?

That’s a first…did you mark it for deletion with moveonboot, then reboot?
Sorry if I’m asking the obvious, never had it fail before.

On another thought, it could be that it worked, but the folder was replaced by whatever crapware you’re infected with. (When I have to resort to moveonboot, it has always been in an effort to clean up after some nasty software)

Run hijackthis and get rid of the offending software first, then use moveonboot to clean up.

No safemode if its running will still not allow ou to delete. DOS is only way. The one in XP will do it even while xp is running. ITs simple permision issues and dos wont ask (diff from locked files however). Go to your start>programs>accerios>command prompt. Navigate to that file and type del (filename)

thats it.

I tried in dos, and the file doesnt show there.

It shows in the folder after i unhide system folders. It says “Cannot delete Thumbs.db: Access denied.” All deleting efforts fail; renaming is not allowed.

I think this file is corrupted. Can I erase it somehow?

I dunno what your problem is. I delete Thumbs.db all the time. You must have administrative privileges to do so though.

Another thought, I think there is an option somewhere (don’t have time to find it now) to not create Thumbs.db. Don’t know whether changing that setting after the fact would delete it though.

Can you see/delete the folder with freeCommander ?

In My Computer (or any folder) > Click Tools in the menu bar > Folder Options > View tab > Check ‘Do not cache thumbnails’

No more Thumbs.db problems. Sorry, don’t know how to delete it. I’m sure a reformat would work. :wink:

I’d many problems like that, but I slove it at once … many solutions here…

  • Do you have more than one operation system? enter the other OS and delete the file/folder.

  • You can use a boot disc, enter DOS, use delete command for:
    Delete File:
    del filename.extension

Delete folder
deltree foldername

I’m sure I’ve wrote something already written in this thread, sorry I didn’t read all posts :slight_smile:

If you didn’t delete it, try kill box software:
It works well here…

I know that I’m responding to a VERY old thread, but in case anyone else happens to ask this question, I figured I’d answer it.

The thumbs.db file is a hidden, archived system file that is generated when explorer creates a thumbnail image for your screen to display.

This file is set as a ‘system’ file, and can be a pain if you are trying to remove/delete a directory.
It can also cause the dreaded ‘Program must be shut down’ error when viewing your explorer window if the file should become corrupted.

Fixing the problem is not as hard as it may look.

If you just want to delete the entire directory:
First, open a DOS prompt and navigate to the directory that is giving you the problems.

Then, type in this: attrib -a -h -r -s . and hit enter.

This has the effect of removing the ‘archived’ , ‘hidden’, ‘read only’ and ‘system’ attributes for every file in the directory.

The next thing to do is type this: del . and hit enter.

That will delete every file in the directory.

If, however, you only need to delete the thumbs.db file (which you wont be able to see if it is hidden), you would do it this way:

Using the DOS prompt, navigate to the directory giving you problems.
Type in this: attrib -h -s -r -a thumbs.db and hit enter

This will remove the attributes that are hiding the thumbs.db file, so you can delete it.

To delete it in that same DOS window, just type DEL Thumbs.db and hit enter.

That should solve your thumbs.db problems :slight_smile: