<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8">
    <title>Bottom and right border with no border padding - #18 by ladans37 - HTML &amp; CSS - SitePoint Forums | Web Development &amp; Design Community</title>
    <meta name="description" content="I am trying to replicate something as shown in the above image. Live URL 
Could not succeed. some Pseudo or Knack is needed?">
    <meta name="generator" content="Discourse 2.7.0.beta3 - https://github.com/discourse/discourse version ce904dc765ee4d615b3abc1442c6f42d68cac8ba">
<link rel="icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/0/6/06fa311765b08c4cdf3963f8b19b2e6792559176_2_32x32.ico">
<link rel="apple-touch-icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/2/5/251fedb1e929595050b23e6f0ce837f0d59d7be1_2_180x180.png">
<meta name="theme-color" content="#3a3a3a">
<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, user-scalable=yes, viewport-fit=cover">
<meta name="discourse-base-uri" content="/community">
<link rel="canonical" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717" />
<script type="application/ld+json">{"@context":"http://schema.org","@type":"WebSite","url":"https://www.sitepoint.com/community","potentialAction":{"@type":"SearchAction","target":"https://www.sitepoint.com/community/search?q={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="search" type="application/opensearchdescription+xml" href="https://www.sitepoint.com/community/opensearch.xml" title="SitePoint Forums | Web Development &amp; Design Community Search">

      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_3_4b80b0a445fb38c1dc1186a9c754142121752550.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop" data-theme-id="495"/>
      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_495_0bbd4e0e0cc80068f078cf02553dc75ad0a458e2.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="495"/>
    <!-- Proper Ad Script -->
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/6ef07837143d5fffd5fe4a7ddece907ed3758b1b.js?__ws=www.sitepoint.com"></script>
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/8e09b370c6600f8a72ea3a60c148004f34767967.js?__ws=www.sitepoint.com"></script>
    <meta id="data-ga-universal-analytics" data-tracking-code="UA-30131-1" data-json="{&quot;cookieDomain&quot;:&quot;auto&quot;}" data-auto-link-domains="">

  <link rel="preload" href="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-v3-706f1d28f0a97f67a47515c96189277240ec4940d968955042066d7873fd1fe8.gz.js" as="script">
<script src="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-v3-706f1d28f0a97f67a47515c96189277240ec4940d968955042066d7873fd1fe8.gz.js"></script>


        <link rel="alternate" type="application/rss+xml" title="RSS feed of &#39;Bottom and right border with no border padding&#39;" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717.rss" />
    <meta property="og:site_name" content="SitePoint Forums | Web Development &amp; Design Community" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:image" content="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/6/e/6e4fe664b448076873da2ca06bb3fbdaf7ebdd4f_2_1024x79.png" />
<meta property="og:image" content="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/6/e/6e4fe664b448076873da2ca06bb3fbdaf7ebdd4f_2_1024x79.png" />
<meta property="og:url" content="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717/18" />
<meta name="twitter:url" content="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717/18" />
<meta property="og:title" content="Bottom and right border with no border padding" />
<meta name="twitter:title" content="Bottom and right border with no border padding" />
<meta property="og:description" content="Whatever that additional method is, I’m sure there’s a CSS way to that too 🙂" />
<meta name="twitter:description" content="Whatever that additional method is, I’m sure there’s a CSS way to that too 🙂" />
<meta property="article:published_time" content="2021-02-05T22:58:49+00:00" />
<meta property="og:ignore_canonical" content="true" />



    
  </head>
  <body class="crawler">
    <!--
<script type="text/discourse-plugin" version="0.8">
    api.modifyClass('component:topic-list', {
        didInsertElement: function() {
            this._super();
            loadBsaTopicList();
        }
    });
    
    function loadBsaTopicList() {
        var topicList = document.querySelector('.topic-list');
        var totalTopicItems = topicList.querySelectorAll('.topic-list .topic-list-item').length;
        var rowIndex = totalTopicItems >= 5 ? 6 : totalTopicItems + 1; // Header row is included in total row count
        var row = topicList.insertRow(rowIndex);
        row.className = 'hide';
        row.id = 'bsa-topic-row'
        var cell = row.insertCell(0);
        cell.colSpan = 6;
        cell.innerHTML = '<div id="bsa-topic-list-outlet"></div>';
        if(typeof _bsa !== 'undefined' && _bsa) {
            var zoneKey = 'CVADE5Q7';
            var adScript = document.querySelector('script[id^="_bsa_srv-' + zoneKey + '"]');
            if(adScript) {
                adScript.parentNode.removeChild(adScript);
            }
            _bsa.init('default', zoneKey, '', {
                target: '#bsa-topic-list-outlet',
                id: 'bsa-topic-list',
                // forwardedip value is for testing only - src: http://customads.bsademo.com/reference/server-side.html
                path: 'https://srv.buysellads.com/ads/' + zoneKey + '.json?forcenads=1'
            });
            _bsa.callback = function(bsaAd) {
                var ad = bsaAd.ads[0];
                if (bsaAd.key === zoneKey) {
                    document.querySelector('#bsa-topic-row').classList.remove('hide');
                    var bsaWrapper = document.querySelector('#bsa-topic-list');
                    var adLinkWrapper = bsaWrapper.querySelector('a._default_');
                    var titleEl = adLinkWrapper.querySelector('.default-title');
                    var descEl = adLinkWrapper.querySelector('.default-description');
    
                    var wrapper = document.createElement('div');
                    var cta = document.createElement('span');

                    wrapper.className = 'default-content';
                    cta.className = 'default-cta';
                    cta.innerText = ad.callToAction;
                    cta.style.backgroundColor = ad.ctaBackgroundColor;
                    cta.style.color = ad.ctaTextColor;
    
                    adLinkWrapper.appendChild(wrapper);
                    adLinkWrapper.appendChild(cta);
                    wrapper.appendChild(titleEl);
                    wrapper.appendChild(descEl);
                }
            };
        }
    }
</script>
-->
<noscript>
  <a class="header-link u-button" target="_blank" href="/themes?utm_source=community&amp;utm_medium=top-nav" tabindex="2">Themes</a>
  <a class="header-link" href="/versioning-show?utm_source=community&amp;utm_medium=top-nav" tabindex="3">Podcast</a>
  <a class="header-link" href="/?utm_source=community&amp;utm_medium=top-nav" tabindex="5">Articles</a>
  <a class="header-link u-button" target="_blank" href="/premium/topics/all?utm_source=community&amp;utm_medium=top-nav" tabindex="6">Premium</a>
</noscript>

<!-- Start Alexa Certify Javascript -->

<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=3/2Rk1ao6C526C" style="display:none" height="1" width="1" alt=""></noscript>
<!-- End Alexa Certify Javascript -->


<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/3fbd52dd096af8d08246936f8fda7dfdc40c94e5.js?__ws=www.sitepoint.com"></script>
    <header>
      <a href="/community/">
          <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg" alt="SitePoint Forums | Web Development &amp; Design Community" id="site-logo" style="max-width: 150px;">
      </a>
    </header>
    <div id="main-outlet" class="wrap">
        <div id="topic-title">
    <h1>
      <a href="/community/t/bottom-and-right-border-with-no-border-padding/363717">Bottom and right border with no border padding</a>
    </h1>

      <div class="topic-category" itemscope itemtype="http://schema.org/BreadcrumbList">
          <span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
            <a href="https://www.sitepoint.com/community/community/c/html-css/25" class="badge-wrapper bullet" itemprop="item">
              <span class='badge-category-bg' style='background-color: #ba5401'></span>
              <span class='badge-category clear-badge'>
                <span class='category-name' itemprop='name'>HTML &amp; CSS</span>
              </span>
            </a>
            <meta itemprop="position" content="1" />
          </span>
      </div>

  </div>

  


      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/codeispoetry'><span itemprop='name'>codeispoetry</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">

            <link itemprop="image" href="https://www.sitepoint.com/community//discourse-cloud-file-uploads.s3.dualstack.us-west-2.amazonaws.com/sitepoint/original/3X/6/e/6e4fe664b448076873da2ca06bb3fbdaf7ebdd4f.png">

          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-02-05T03:05:14Z'>
              <time itemprop='dateModified' datetime='2021-02-05T03:12:22Z' class='post-time'>
                February 5, 2021,  3:12am
              </time>
          <span itemprop='position'>#1</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><div class="lightbox-wrapper"><a class="lightbox" href="https://aws1.discourse-cdn.com/sitepoint/original/3X/6/e/6e4fe664b448076873da2ca06bb3fbdaf7ebdd4f.png" data-download-href="/community/uploads/short-url/fJRHOnxKQQjUy05PENMAFZvu9zh.png?dl=1" title="image" rel="noopener nofollow ugc"><img src="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/6/e/6e4fe664b448076873da2ca06bb3fbdaf7ebdd4f_2_690x53.png" alt="image" data-base62-sha1="fJRHOnxKQQjUy05PENMAFZvu9zh" width="690" height="53" srcset="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/6/e/6e4fe664b448076873da2ca06bb3fbdaf7ebdd4f_2_690x53.png, https://aws1.discourse-cdn.com/sitepoint/optimized/3X/6/e/6e4fe664b448076873da2ca06bb3fbdaf7ebdd4f_2_1035x79.png 1.5x, https://aws1.discourse-cdn.com/sitepoint/original/3X/6/e/6e4fe664b448076873da2ca06bb3fbdaf7ebdd4f.png 2x" data-small-upload="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/6/e/6e4fe664b448076873da2ca06bb3fbdaf7ebdd4f_2_10x10.png"><div class="meta"><svg class="fa d-icon d-icon-far-image svg-icon" aria-hidden="true"><use xlink:href="#far-image"></use></svg><span class="filename">image</span><span class="informations">1114×86 3.08 KB</span><svg class="fa d-icon d-icon-discourse-expand svg-icon" aria-hidden="true"><use xlink:href="#discourse-expand"></use></svg></div></a></div></p>
<p>I am trying to replicate something as shown in the above image. <a href="http://practice.trafficopedia.com/blog/simple03/" rel="noopener nofollow ugc">Live URL</a></p>
<p>Could not succeed. some Pseudo or Knack is needed?</p>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>
          <meta itemprop='keywords' content=''>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-02-05T03:18:56Z' class='post-time'>
                February 5, 2021,  3:18am
              </time>
              <meta itemprop='dateModified' content='2021-02-05T03:18:56Z'>
          <span itemprop='position'>#2</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Are you trying to make this :</p>
<pre><code class="lang-auto">border-right: 1px solid #ccc;
border-bottom: 1px solid #ccc;
padding:none;
</code></pre>
<p>For the padding, you don’t even have to write it out. If you don’t write out the padding, it would still be the same, which is the default 0px.</p>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/codeispoetry'><span itemprop='name'>codeispoetry</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-02-05T04:18:18Z'>
              <time itemprop='dateModified' datetime='2021-02-05T05:14:59Z' class='post-time'>
                February 5, 2021,  5:14am
              </time>
          <span itemprop='position'>#3</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>I was able to fix it by changing the HTML structure to→</p>
<pre><code class="lang-auto">&lt;div class="navlist"&gt;&lt;div class="navspan"&gt;HOME&lt;/div&gt;&lt;/div&gt;
&lt;div class="navlist"&gt;&lt;div class="navspan"&gt;WHATS THAT&lt;/div&gt;&lt;/div&gt;
&lt;div class="navlist"&gt;&lt;div class="navspan"&gt;TOPICS&lt;/div&gt;&lt;/div&gt;
&lt;div class="navlist"&gt;&lt;div class="navspan"&gt;PRICING&lt;/div&gt;&lt;/div&gt;
&lt;div class="navlist"&gt;&lt;div class="navspan"&gt;TICKETS&lt;/div&gt;&lt;/div&gt;
</code></pre>
<p>From →</p>
<pre><code class="lang-auto">&lt;div class="navlist"&gt;HOME&lt;/div&gt;
&lt;div class="navlist"&gt;WHATS THAT&lt;/div&gt;
&lt;div class="navlist"&gt;TOPICS&lt;/div&gt;
&lt;div class="navlist"&gt;PRICING&lt;/div&gt;
&lt;div class="navlist"&gt;TICKETS&lt;/div&gt;
</code></pre>
<p>Yet could not align text in center + could not distribute available width of nav with certain uniformity.</p>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Gandalf'><span itemprop='name'>Gandalf</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-02-05T10:44:09Z' class='post-time'>
                February 5, 2021, 10:44am
              </time>
              <meta itemprop='dateModified' content='2021-02-05T10:44:09Z'>
          <span itemprop='position'>#4</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Slightly off-topic, you shouldn’t use ALLCAPS for your menu items, some screen readers read out each letter as though they are initials. Use CSS to transform to capitals.</p>
<pre><code class="lang-auto">text-transform: uppercase;
</code></pre>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="4" />
           <span class='post-likes'>4 Likes</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-02-05T12:23:06Z' class='post-time'>
                February 5, 2021, 12:23pm
              </time>
              <meta itemprop='dateModified' content='2021-02-05T12:23:06Z'>
          <span itemprop='position'>#5</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><a class="mention" href="/community/u/gandalf">@Gandalf</a> good point, but I have seen some menu items in all caps too.</p>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/TechnoBear'><span itemprop='name'>TechnoBear</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">

            <link itemprop="image" href="https://www.sitepoint.com/community//discourse-cloud-file-uploads.s3.dualstack.us-west-2.amazonaws.com/sitepoint/original/1X/aaf177f8fbf611e82c2e691ec62e6293ed426273.gif">

          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-02-05T13:31:46Z' class='post-time'>
                February 5, 2021,  1:31pm
              </time>
              <meta itemprop='dateModified' content='2021-02-05T13:31:46Z'>
          <span itemprop='position'>#6</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="ladans37" data-post="5" data-topic="363717">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/ladans37/40/89361_2.png" class="avatar"> ladans37:</div>
<blockquote>
<p>I have seen some menu items in all caps too.</p>
</blockquote>
</aside>
<p>Sadly, just because you see something on a website, that doesn’t make it good practice.  <img src="https://aws1.discourse-cdn.com/sitepoint/original/1X/aaf177f8fbf611e82c2e691ec62e6293ed426273.gif" alt="wink" data-base62-sha1="ooevSqdIJDwmzubylbCmgRpsEbp" width="15" height="15"> There is an awful lot of bad code about, and far too many inaccessible websites.</p>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="4" />
           <span class='post-likes'>4 Likes</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/codeispoetry'><span itemprop='name'>codeispoetry</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-02-05T14:01:33Z' class='post-time'>
                February 5, 2021,  2:01pm
              </time>
              <meta itemprop='dateModified' content='2021-02-05T14:01:33Z'>
          <span itemprop='position'>#7</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote group-Advisors" data-username="Gandalf" data-post="4" data-topic="363717">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/gandalf/40/89241_2.png" class="avatar"> Gandalf:</div>
<blockquote>
<p>Slightly off-topic, you shouldn’t use ALLCAPS for your menu items, some screen readers read out each letter as though they are initials. Use CSS to transform to capitals.</p>
<pre><code class="lang-auto">
</code></pre>
</blockquote>
</aside>
<p>This was not off-topic, but some remarkable takeaway of the day. Thanks!</p>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="2" />
           <span class='post-likes'>2 Likes</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Gandalf'><span itemprop='name'>Gandalf</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-02-05T14:13:22Z' class='post-time'>
                February 5, 2021,  2:13pm
              </time>
              <meta itemprop='dateModified' content='2021-02-05T14:13:22Z'>
          <span itemprop='position'>#9</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Shouldn’t you be applying the hover effect to <code>section a</code>?</p>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/codeispoetry'><span itemprop='name'>codeispoetry</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-02-05T14:20:13Z' class='post-time'>
                February 5, 2021,  2:20pm
              </time>
              <meta itemprop='dateModified' content='2021-02-05T14:20:13Z'>
          <span itemprop='position'>#10</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote group-Advisors" data-username="Gandalf" data-post="9" data-topic="363717" data-full="true">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/gandalf/40/89241_2.png" class="avatar"> Gandalf:</div>
<blockquote>
<p>Shouldn’t you be applying the hover effect to <code>section a</code> ?</p>
</blockquote>
</aside>
<p>I have done it but that doesnt gives anticipated result.</p>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/PaulOB'><span itemprop='name'>PaulOB</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-02-05T17:13:07Z' class='post-time'>
                February 5, 2021,  5:13pm
              </time>
              <meta itemprop='dateModified' content='2021-02-05T17:13:07Z'>
          <span itemprop='position'>#11</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Did you mean something like this?</p>
<p><iframe id="cp_embed_ExNPrLN" src="https://codepen.io/paulobrien/embed/preview/ExNPrLN?height=300&amp;slug-hash=ExNPrLN&amp;default-tabs=css,result&amp;host=https://codepen.io" title="menu" scrolling="no" frameborder="0" height="260" class="cp_embed_iframe" width="695" seamless="seamless" sandbox="allow-same-origin allow-scripts allow-forms allow-popups allow-popups-to-escape-sandbox allow-presentation"></iframe></p>
<p>I think I must have misunderstood because thats more or less how it comes out of the box <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/slight_smile.png?v=9" title=":slight_smile:" class="emoji" alt=":slight_smile:"></p>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="2" />
           <span class='post-likes'>2 Likes</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/codeispoetry'><span itemprop='name'>codeispoetry</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-02-05T18:03:40Z' class='post-time'>
                February 5, 2021,  6:03pm
              </time>
              <meta itemprop='dateModified' content='2021-02-05T18:03:40Z'>
          <span itemprop='position'>#12</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>You did it in master stroke with immense simplicity.</p>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/codeispoetry'><span itemprop='name'>codeispoetry</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">

            <link itemprop="image" href="https://www.sitepoint.com/community//discourse-cloud-file-uploads.s3.dualstack.us-west-2.amazonaws.com/sitepoint/original/3X/6/4/640f004d471d30430b25ffc45c5c79ee476e438c.png">

          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-02-05T18:43:42Z'>
              <time itemprop='dateModified' datetime='2021-02-05T18:53:33Z' class='post-time'>
                February 5, 2021,  6:53pm
              </time>
          <span itemprop='position'>#13</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Hi there, You have given the solution in a very crisp way, but i was in the middle of trying something with JQuery. Like this →</p>
<pre><code class="lang-auto">$(".navlist").hover(function() {
  $(".navspan a").css("color","white");
});
</code></pre>
<p>I think there are propagation and delegation issue because after unhovering it the initial state is not stored + It is impacting all →</p>
<p><div class="lightbox-wrapper"><a class="lightbox" href="https://aws1.discourse-cdn.com/sitepoint/original/3X/6/4/640f004d471d30430b25ffc45c5c79ee476e438c.png" data-download-href="/community/uploads/short-url/eh9SZkAQdVYjO4lPiowGEYlRtNi.png?dl=1" title="image" rel="noopener nofollow ugc"><img src="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/6/4/640f004d471d30430b25ffc45c5c79ee476e438c_2_690x248.png" alt="image" data-base62-sha1="eh9SZkAQdVYjO4lPiowGEYlRtNi" width="690" height="248" srcset="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/6/4/640f004d471d30430b25ffc45c5c79ee476e438c_2_690x248.png, https://aws1.discourse-cdn.com/sitepoint/optimized/3X/6/4/640f004d471d30430b25ffc45c5c79ee476e438c_2_1035x372.png 1.5x, https://aws1.discourse-cdn.com/sitepoint/original/3X/6/4/640f004d471d30430b25ffc45c5c79ee476e438c.png 2x" data-small-upload="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/6/4/640f004d471d30430b25ffc45c5c79ee476e438c_2_10x10.png"><div class="meta"><svg class="fa d-icon d-icon-far-image svg-icon" aria-hidden="true"><use xlink:href="#far-image"></use></svg><span class="filename">image</span><span class="informations">1124×405 26.7 KB</span><svg class="fa d-icon d-icon-discourse-expand svg-icon" aria-hidden="true"><use xlink:href="#discourse-expand"></use></svg></div></a></div></p>
<p>What will be the course correction to eliminate undesired result.</p>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Gandalf'><span itemprop='name'>Gandalf</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-02-05T19:02:00Z'>
              <time itemprop='dateModified' datetime='2021-02-05T19:05:55Z' class='post-time'>
                February 5, 2021,  7:05pm
              </time>
          <span itemprop='position'>#14</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Why use jQuery for something that can be done in CSS. In fact, all you’re doing is using jQuery to add CSS rules. It doesn’t make much sense to me.</p>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="3" />
           <span class='post-likes'>3 Likes</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-02-05T19:11:07Z' class='post-time'>
                February 5, 2021,  7:11pm
              </time>
              <meta itemprop='dateModified' content='2021-02-05T19:11:07Z'>
          <span itemprop='position'>#15</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Every language, be it CSS, jQuery, JS…etc has its own set of rules. My feeling is, that you should only use one if another doesn’t suffice your needs. Else if it does, then why make things harder for yourself? When there’s an easier route, take it. <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/slight_smile.png?v=9" title=":slight_smile:" class="emoji" alt=":slight_smile:"></p>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/PaulOB'><span itemprop='name'>PaulOB</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-02-05T20:03:48Z'>
              <time itemprop='dateModified' datetime='2021-02-05T20:08:33Z' class='post-time'>
                February 5, 2021,  8:08pm
              </time>
          <span itemprop='position'>#16</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="codeispoetry" data-post="13" data-topic="363717">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/codeispoetry/40/69169_2.png" class="avatar"> codeispoetry:</div>
<blockquote>
<p>I think there are propagation and delegation issue because after unhovering it the initial state is not stored + It is impacting all →</p>
</blockquote>
</aside>
<p>You add a style on hover but you don’t remove anything when you are not hovering. You need the hover in and hover out handler method. You also need to find the element inside the element that triggered the hover event and you can do that with $(this) and .find(). You were getting the whole row of anchors in your example.</p>
<pre><code class="lang-auto">$(".navlist").hover(
  function () {//hover in
    $(this).find("a").css("color", "white");
  },
  function () {// hover out
    $(this).find("a").css("color", "inherit");
  }
);
</code></pre>
<p>Of course you shouldn’t really change styles with JS but rather add and remove classes instead and avoid specificity issues later down the line.</p>
<p>However you don’t need any of that rubbish as you can do it all in css anyway.<img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/slight_smile.png?v=9" title=":slight_smile:" class="emoji" alt=":slight_smile:"></p>
<p><code>.navlist:hover a{color:#fff;}</code></p>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="2" />
           <span class='post-likes'>2 Likes</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/codeispoetry'><span itemprop='name'>codeispoetry</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-02-05T22:50:40Z' class='post-time'>
                February 5, 2021, 10:50pm
              </time>
              <meta itemprop='dateModified' content='2021-02-05T22:50:40Z'>
          <span itemprop='position'>#17</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote group-Advisors" data-username="Gandalf" data-post="14" data-topic="363717" data-full="true">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/gandalf/40/89241_2.png" class="avatar"> Gandalf:</div>
<blockquote>
<p>Why use jQuery for something that can be done in CSS. In fact, all you’re doing is using jQuery to add CSS rules. It doesn’t make much sense to me.</p>
</blockquote>
</aside>
<p>These are not commercial projects. Practicing, and learning. I also wanted to do it through JQuery just for knowing one more additional method.</p>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/bottom-and-right-border-with-no-border-padding/363717">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-02-05T22:58:49Z' class='post-time'>
                February 5, 2021, 10:58pm
              </time>
              <meta itemprop='dateModified' content='2021-02-05T22:58:49Z'>
          <span itemprop='position'>#18</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Whatever that additional method is, I’m sure there’s a CSS way to that too <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/slight_smile.png?v=9" title=":slight_smile:" class="emoji" alt=":slight_smile:"></p>
        </div>

        <meta itemprop='headline' content='Bottom and right border with no border padding'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>






    </div>
    <footer class="container wrap">
      <nav class='crawler-nav'>
        <ul>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/' itemprop="url">Home </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/categories' itemprop="url">Categories </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/guidelines' itemprop="url">FAQ/Guidelines </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/tos' itemprop="url">Terms of Service </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/privacy' itemprop="url">Privacy Policy </a>
          </span>
        </li>
        </ul>
      </nav>
      <p class='powered-by-link'>Powered by <a href="https://www.discourse.org">Discourse</a>, best viewed with JavaScript enabled</p>
    </footer>
    
    <!-- BSA Ad Script -->
<!--
<script>
    (function(){
        var bsaScript = document.createElement('script');
        bsaScript.type = 'text/javascript';
        bsaScript.async = true;
        bsaScript.src =  "https://cdn-s2s.buysellads.net/pub/sitepoint.js?" + (new Date() - (new Date() % 600000));
        document.getElementsByTagName('head')[0].appendChild(bsaScript);
    })();
</script>
-->
<!-- Proper -->
<!--
<div id="footer-ad-spacer"></div>
<div id="footer-ad" class="proper-ad-unit ad-sticky">
    <div id="proper-ad-sitepoint_main_1">
        <script> 
            propertag && propertag.cmd.push(function() { proper_display('sitepoint_main_1'); });
        </script>
    </div>
</div>
-->
<div id="footer-ad-spacer"></div>
<div id="footer-ad" class="proper-ad-unit ad-sticky">

    
     <div id="proper-ad-sitepoint_left_sticky">  </div>
     
</div><script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/be63710d6fb6a95a92f8c7ea8836704b560e4661.js?__ws=www.sitepoint.com"></script>
  </body>
  
</html>
