Block links from sitepoint?

I am noticing that several of the links from sitepoint are ranking higher than some of my actual websites. Is there a way to block these links or get them removed or something?

If not, what’s the best way to post a link to your site w/o getting a back link? I’ve tried adding the URL like mydomaindotcom but forum users get kind of mad be/c it’s extra work.

Thanks much!

IMHO the best thing would be for the forum to have all external links be Google redirects. Changes to the SitePoint forums are on the way, so hopefully that will be one of them.

Not putting links in your post means more work for forum members.

If you utilize your Profile’s Homepage and/or Signature, then those that find your post could click on those.

So I guess it means making others copy/paste/type into their address bar or others need an extra click.

Yeah, that would be great if they make that change.

Okay, thanks for the permission to use mydomaindotcom format.

You don’t need to go that far – if you apply any formatting to a character in the “www.” part of the URL then vB4 won’t hyperlink it (or you can un-tick the “Automatically parse links in text” box below). For example:

[noparse]www.example.com[/noparse]
comes out as
www.example.com

Or you can put it in [code] tags. Or just leave out the http and www, because it won’t be automagically hyperlinked without either of them. If you just type mydomain.com with no trickery, it appears in plain text.

That way, people will at least be able to copy and paste the URL intact, rather than having to mess around changing it.

Although, to be honest, I’m still not quite sure what you mean by “I am noticing that several of the links from sitepoint are ranking higher than some of my actual websites” or why it’s a problem. If it’s particular pages that you don’t want Google to index, you can always use the <meta robots=“noindex”> tag on those particular pages.

Thanks. I’m not sure what’s not clear. I don’t want sitepoint pages listing the help I’ve posted for my site to be listed before the actual site. I don’t want them listed at all and don’t want the backlinks to show in Google Analytics.

Okay, I am trying this: www.mydomain.com

and this mydomain.com

Awesome. That worked. Now I’m trying the Automatically parse links in text:

So did that. Cool. Thank you so much!

Trying this too:

www.mydomain.com

No, it’s the sitepoint pages I don’t want Google to index for my site URL.

Fair point. But how many people are searching for your URL? If they are, that’s great, because it means you’ve got a really well established brand name. But it’s much more likely that they’ll be searching for key words and phrases within the site (unless your logs show otherwise, but on my main website, the domain name shows up in less than 0.1% of search referrals). If your asking for help on SPF is causing the SPF pages to rank above your site for searches on your keywords, then I wonder if it’s because you’re allowing vB4 to “Automatically retrieve titles from external links” – in other words, to use your page’s <title> as the link text. If that’s happening, you can un-tick the relevant box below the message and the links will just show the URL and not the <title> text, which should stop it ranking on those words.

Yeah, I’m actually pretty well versed in SEO. Guess what? I was actually Googling one of the main keywords and sitepoint was on the first page. I do not want that. And no, the result is using the sitepoint title.

I don’t want to debate the issue. My desire is for sitepoint not to show up for the main URL or for the keywords.

Thanks for your tips.

If you’re searching for words that you’ve typed into Sitepoint, and Sitepoint comes up at the top, I guess the solution is for you not to type those words in here. If those words are here on the forum, I’m not sure that having an outbound link from the forum will make any different as to where the forum will rank. Sorry if I’m still being obtuse (it isn’t deliberate!), but I’m just trying to figure out if it’s the links that are actually causing the problem.

Ye dogs, I hope not. It’s frustrating enough when Google uses Google redirects (especially as when you first hover over it, it looks like a regular link, and only morphs into a redirect when you click on it (including right-click). So if you’re trying to share a link with other people, you can’t just right-click and copy link address, because then it gives you a mile of googlegarbage rather than a link to the page. And that irritates the heck out of me. A link should be a link, no messing around with obfuscation.

(That’s not to take away from Sculley’s point when you don’t actually want it to be a link, but TBH I reckon obfuscating it is more of a pain in the wossnames than having plain text. Especially in the context of a web dev forum, where a fair chunk of the time I’m copying a link so I can paste it into a different browser)

Gotcha. I’m actually searching for keywords in Google not sitepoint and sitepoint comes up. I think it’s b/c in several replies the post included the text that included the keyword but the text was surrounded by code tags. Guess for that I’d have to request everyone to not post the actual text and that would be kind of insane.

Hey Stevie, I tried the bold method and to “un-tick the ‘Automatically parse links in text’” but my URL is still linking on this page: http://www.sitepoint.com/forums/css-53/dropping-next-line-767319.html.

What did I do wrong?

Thanks much!

Trying to do anything with the URL is not going to solve your problem. Just wasting your time. SitePoint will be at the top of the results, because Google gives it more weight then your little site.

You’ve made the whole URL bold – try making only the dot between the ‘www’ and the rest of the URL bold.

The reason that this works is because the forum software tries to recognise URLs by anything that starts with www., and if you put any formatting in there, it disrupts the pattern recognition. When you make the whole lot bold, the www dot URL is still there intact, and so it is still automagically linked.

Okay, I’ll try that for next post. Unchecking “Automatically parse links in text” should have handled it though yes?

It should do, yes. What might have happened is that if you typed the message in the ‘Quick reply’ and then clicked ‘Go advanced’, or if you’ve submitted it without unticking the box and then gone back in to edit it, it’s already put the [url]...[/url] tags on. You can manually remove these, and as long as you’ve unticked the box, it won’t put them back on.

It was actually on my original post so couldn’t have been a “quick reply”. I am positive I unticked the parsing option before I hit Submit too b/c I didn’t want it to link back. Oh well, I’ll keep trying…

Thanks much for your help!!