Bizzare problem - failure to access site via FTP

I cannot access my sites with FileZilla or SmartFTP anymore. I’ve got a fresh Windows 7 install. This is very odd. Odd why? Well because:

  1. I can access them from a friend’s Windows 7 machine at their house.

  2. I can access anonymous FTP servers like ftp.funet.fi from this machine.

So there is some specific problem with this machine and the specific host it seems. Or this router and that host.

I’ve contacted tech support and they can see no problem. They can access my sites from non-internal/non-back end connections.

The error is always a timeout. Even if I put the wrong password or username I just get a timeout.

Status:	Connection established, waiting for welcome message...
Response:	220 ATLAS/WebFusion FTP server
Command:	USER ****@****.com
Response:	331 Please specify the password.
Command:	PASS **********
Error:	Connection timed out
Error:	Could not connect to server

What is going on?

You might need to ask your ISP if they have port 21 opened on your service

Cheers

Can you access your site via a webbased ftp client?
Can you add a sftp login to port 22 and try that?

I cannot access the site via any ftp method from this connection, be it on this machine or another.

I can access it from other connections using the same laptop that fails on this connection, and from other machines on other connections.

I’ve contacted my ISP who are looking into it.

Sounds like a definite ISP issue!
Unless of course you have the port/s blocked on your router, which could well be the problem too!