Bizare flash player behaviour

I have a very simple flash music player integrated, but when I try to open the page I get the following message! Content on this page requires a newer version of Adobe Flash Player. I download and run the new player, restart the computer and try it again. But I get the excact same message. Does anyone know how this is possible?

Thank you in advance

Url?