Application not working in my Cpanel

page isn’t working AND is currently unable to handle this request. HTTP 500 error through in my Application

Locally that application working fine.

i put .htaccess file also in my cpanel and i check folder permission i can’t able to find the issue anybody know

That’s not much to go on. I would probably try a simple .html file first, to see if that worked. Then work from there. What’s in the .htaccess file? They can nobble your site if not configured properly.

1 Like

@rkrajeshkannanmca: is this the same issue you posted about here?

Magento site not working

500 error usually means you screwed up on your Apache configuration and the only Apache file you are currently using is .htaccess. So that basically means that your host doesn’t allow certain syntax to be used, you’ll have to remove each individual line to check which ones didn’t work.

1 Like

Think @ralphm has a good point @spaceshiptrooper, it’s unclear what the problem is so perhaps the guy can troubleshoot with no .htaccess file to start off, if he is still generating a 500 error then it could be something server related or with the host…

I create one html file test page it’s working issue

you tried renaming your .htaccess file to .htacessold or something? depending on what you are using, a new .htaccess file will either be created or not be required at first… @rkrajeshkannanmca, you may need to remove the html file you created if it’s index.html as that will load before PHP files sorry…

Already i create index.html file it’s working fine.

Ok, so the problem is resolved now? it’s still a good idea to have a .htaccess file to keep your website more secure but as @ralphm says, it’s easy to break your website if the configuration is not correct…

this is an excellent article which explains all about the .htaccess file and it’s uses @rkrajeshkannanmca

Most of the time we use the .htaccess file on a per website basis so we do not have to make changes to the server itself…

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.