Apostrophe showing as ’

Hi everyone! I’m new to the forum, and of course building web pages. I have just started using the book ‘Build your own website, the right way’.

My question may have already been answered but i couldn’t seem to find anything i understood in search.

When i open my webpage in safari (i use a mac) all my apostrophes (') show as ’. any ideas why and how i can fix this? very simple answers please as i have no idea what I’m doing lol.

Thanks, Steph

What editor are you using? Depends on your charset probably. Is it UTF-8?

Hi mate, thanks for the response. I’ve just changed everything to UTF-8, browser, text editor and all that. it seems to be working now :smile:

Glad it worked. I would check all your other pages as well. I think you’d have to go in and change it to UTF-8 as well for those pages.

Either way, you’re welcome.

Yes, you want to use a “plain textt” editor. I find UTF-8 - without the BOM - works the best.

When I first started I didn’t understand that Word was primarily for print documents where “fancy quotes” look fine and had a devil of a time getting pages to work. Once I switched to Notepad I was on my way. I have sinced moved to Notepad++, not as feature rich as some editors but as I was used to Notepad it meets my needs ATM

I’m using Text Editor on my mac. I changed it to plain text too now :slight_smile: thanks guys

I went through the same struggles as you Mitt. Debugging those nasty quotes took so long since the pages basically were working…

I told my current job that I solely worked in Notepad and they laughed. Switched to Notepad++ though recently basically for the code indentation. Such a nice feature.

In the code you can use & #39; to show my apostrophes. Of course, the & and the # would not have a space between, but if I post it altogether here it actually shows the apostrophe, hence '.

Not if you enclose in backticks (inline pre)


I’ll give it a go then guys, thanks very much for that :slight_smile: