Anyone up for a good mystery? (SSI issue)


One of my websites is I’m in the process of trying to put on a navigation bar which uses Server Side Includes. The site’s hosted by Earthlink. They’ve assured me they support it, but when I put it up there, and navigation bar doesn’t show. I even had one of their tech support people on the phone trying to fix it over there, but to no avail. Ironically the .shtml page and the .ssi page work by themselves, but when I add them to the index page it’s no go.

Can someone be kind enough to view source it and tell me what I’m doing wrong? The index page at

I’ve done the same thing with at least one other site I host at GoDaddy, and the code works fine. The exact same code I’m trying on Earthlink.

Big thanks in advance!


No, worries like I said in post #3 “…does that have the correct .shtml extension?” which it does now. It is one of the most common mistakes a beginner makes. :wink:

Sorry guys, here goes:

On, I tried:

<!--#include virtual="MyNavbar.shtm"-->

And ironically if you just type in the navigation works by itself

On, I tried:

<!--#include virtual="myNavbar.ssi"-->

And again if you just type in the navigation works by itself

Hope this helps explain things. Thanks for looking!

Thanks for the last suggestion! I saved the main index as a shtml file, uploaded it, and deleted the previous indexes, and now it works!

Happy Ending!

Thanks for replying! I’m quite new at this (and more than a bit lost here)

I’d just uploaded the .ssi page, linked index.html to point to it, and uploaded. When that didn’t work I created an shtml page, re-coded the index page to point to it and uploaded that. That worked on GoDaddy’s severs with another site of mine with no problem, but this one’s hosted by Earthlink, and they support SSI.

Hope this makes sense, and thanks again!

What is the path to the included nav page? It appears that myNavbar.shtm doesn’t seem to exist.

Like Paul said it appears you haven’t got you path correctly defined or there isn’t a file of that name, also what is the name of you “index” page does that have the correct .shtml extension?

not only does the include appear to not exist (shtm, should be shtml)

You appear to be serving index.html – so it’s the wrong extension to tell apache to use SHTML. – resolves – 404

see a problem here? The file using the include should be shtml as well.
Also, did you enable “Options +Includes” in your htaccess and set up the shtml extension using addType/addHandler?