Another beginner with a question

Hi, I’m Erna. Just started working through 'Build Your Own Web Site The Right Way Using HTML $ CSS.

Great book by the way!

Only issue so far, is when I test my markup in chapter 1 - setting up shop - in the Internet Explorer browser, it displays fine, but in the Firefox browser, it displays with some strange symbols right at the top of the page.

These are the symbols: 

Any way I can get rid of that in Firefox?

Thanks :slight_smile:

Great, glad that helped! Now I’ll know what to say next time, as this comes up quite a bit.

Thanks ralph.m, I just downloaded and installed Notepad++, and if you go to ‘Encoding’ in the top menu, it has an option for ‘Encode in UTF-8 without BOM’ and ‘Encode in UTF-8’. I used ‘without BOM’ and it worked. :slight_smile:

Thank you so much for your help!

It’s like Notepad on steroids, and it’s free, so probably worth checking out. I don’t use either (as I’m on a Mac) but I tested Notepad today and couldn’t see how specifically to avoid inserting a BOM, but saving as utf-8 and All Files seemed not to create any problem.

You certainly can use utf-8 without the bom, and utf-8 is the best encoding. Are you using just simple notepad or notepad++?

Thanks for the welcome :slight_smile:

Well, I guess my next question would be: is there a way to get rid of it whilst staying with UTF-8? If not, what should I change to, ANSI, ASCII (DOS), EBCDIC or Unicode?

I really would like to stick with UTF-8, since UTF-8 includes the characters needed for web pages in just about any written language (so my new book tells me :cool:), and my eventual site will be bilingual, with some unusual characters for the non-English language which I’ll have.

Yes, UTF-8. I ‘am’ using Notepad. I don’t see any settings in notepad for ‘turning off’ the BOM/Signature when saving. Does notepad have such a setting, if yes, can you tell me where to locate it?

Hi Erna, welcome to the forums,

That sounds like a BOM (Byte Order Mark). I’m guessing you’re saving the files as UTF-8? When you edit and save your files save them as plain text (eg. Notepad NOT Word) without a BOM/Signature.

Maybe this SitePoint article will help?
The Definitive Guide to Web Character Encoding

Hi Erna, welcome to SitePoint! :slight_smile:

Those characters are a strangle little thing called the ‘byte order mark’ (BOM). It can be removed by changing the settings on your code editor. Here is another forum thread that discusses the issue in detail:

Hope that helps!

I am using the Notepad that came with my computer, and I just got my new computer, so I would assume it’s the latest Notepad, but just the simple one. Should I be using Notepad++? Never heard of it, can I download or purchase it somewhere?