Anchor problems with Opera and Chrome

I few days ago I found that the anchors in my Barcelona and Sydney pages (urls at the bottom), the section in the left sidebar “Major Attractions”, did not work properly, in both Opera and Chome. They worked perfectly in IE9, Firefox, and Safari.
I posted in the Opera forum and one reply suggested that there was bug in Opera24 which would be sorted out in Opera25, about to be launched. Sure enough, the next day Opera25 installed itself and the problem disappeared.

However, on a closer check I found a related problem in my Santo Domingo page: all anchors in the same section worked except the penultimate. I tested this by adding two further empty anchors to the

    list, and it confirmed that it was always the penultimate item that refused to open and instead it jumped to the end of the page.

    As I was about to post this message I looked again at the Barcelona and Sydney pages only to discover that they had gone back to their earlier stage and the anchors after the second item jumped to the end of the page, even though I was till on Opera25.

    In my other two pages (Jakarta and Bali) the problem is with the last anchor that does NOT go to the end of the page…

    All these pages work well in the other browsers. I understand that Opera and Chrome share the same rendering engine and it sounds as if it is a bug in the browsers. However, it is strange that the results in my pages differ from one to another. It is a fact that Barcelona and Sydney use infoBigger.css while the other three use infoBig.css. Also, the ones that use infoBig.css have a .php extension, while the others have .html.

    I wonder if someone could throw some light into what is going on.

    Many thanks.

    PS Please note that I have had help from another country that confirmed the problem if tested online, but could not reproduce it locally

Since posting, Chrome started behaving itself in both Barcelona and Sydney, biut still missing Parque Mirador in Santo Domingo. In Opera the problem remains throughout!

…a little later: Chrome seems to be behaving in Barcelona, but in Sydney it misses some anchors, although here if I keep pressing the link to the anchor it eventually opens up in the right place.

Everything seems to work fine in Chrome (Mac) for me.

Hi ralphm

As I posted earlier, Chrome, suddenly got its house together…but if you look at Santo Domingo (online, NOT locally) I and several others are getting the same problem. In the left sidebar “Parque Mirador” junps to the last attraction and therefore something is preventing Chrome (and Opera) from obeying the code. I would be grateful if you could look at that and let me know,

In Opera the mess is total and across all main pages!


Hm, all seems to work fine in Opera 24 for Mac.


Are you testing online or locally in your computer? Are you using Opera 25? Maybe it’s a different version for Mac. My comouter and those I have checked with run on Windows

Can you clarify the problem again for me please?

I tried clicking the parque mirador link on theSto Domingo page in chrome and opera and both open at the correct item. However they open in a javascript controlled new window which isn’t mentioned anywhere above that I can see.

Is the problem in the new window or am I looking at the wrong item?

Hi PaulOB

When I click on “Parque Mirador” straight away I usually do not have a problem in Chrome. But if I click on each of the anchors in Major Attractions it opens all of them in succession but when it gets to Parque Mirador it jumps to the next and last.

I have Windows7 and 5 browsers to test the pages. Opera is not rendering/opening the page at the right places according to the anchors. I had someone abroad test it himself and he could not replicate the problem locally (after downloading the appropriate files to his system nor after auploading those files to his own server). however, he saw the problem, exactly like I did if he viewed the pages online.

I learnt from the Opera forum that this was a bug that would be resolved with Opera 25 (I had ver 24 at the time) The next day ver 25 was installed and the problem diappeared. But now it is back.

The javascript to open in a new window applies to all the links in the sidebars, and opens html pages (not normal popups, despite the size). The "Major attractions is a single page that is opened by that script, but the various items in it are controlled through anchors: they are all in the same page (html)

From earlier comments it looks as if the problem does not exist in Mac (probably a different Opera version).

The problem in Chrome,is probably related. TheSnto Domigo page does not open the “Parque Mirador” anchor, after opening others in the same page…


PS - These pages have been online for over a year without problems, and nothing was changed recently that could cause it.

You could see earlier thread in the Opera forum here


I’ve tested repeatedly in opera25 and Chrome in Windows 7 and I can’t reproduce the problem either or see a reason why it would not work. Usually things like this are signs of a corrupted cache/temporary files / or extension or plugin problem at your end but if you have had someone else confirm the problem then the issue must be somewhere else or they have the same extension installed.

Until you can reproduce the problem consistently it will be hard to get help unless we can also have the same problem. It could be down to an extension or plugin that you are using so I would disable all those first and then re-test. (As an aside I had a problem recently in Chrome where new windows would freeze chrome completely and it took me a week to track the problem down which turned out to be the Trusteer rapport extension" causing the crash although I had disabled all extensions but this program does not list itself in the extensions list so I missed it.)

Sorry I can’t shed any light on it.

They are still popups as they are a new window which I would prefer to open myself and not be dumped there by you :smile:

Thanks PaulOB

In fact, I have someone far away who confirms my experience, and as you may hav eread in the Opera forum, someone there also confirmed it.
I have emptied the caches about a million times a day…
The fact that I was told that Opera had a bug that would be reolved in ver 25 (and was, even though it came back) leads me to think it is down to Opera. As for the Chrome “Parque Mirador” which happens in both browsers, may be related. Afterr all, both browsers were producing the same probelms at one time a couple of days ago.

Paul, which ver of Opera and Chrome do you use?




I used an old version of opera first time around (version 12 I think) then I installed 25 to test and got same results in both. My chrome is latest 38 version.

Yes which seems to suggest its not a browser issue as such. As you are linking to sections using a fragment identifier in a new window it may be that there is some server interaction perhaps and the url is re-written and corrupts the fragment identifier. I know there are issues linking to things like /index.php#testid where the php extension is hidden/re-written serverside and you need to leave out the php from the fragment identifier but this doesn’t seem to be the case in your example.

I’ll keep testing and see if I can get an error :smile:


I’ve just tested in my daughter’s small laptop after updating to the latest Chrome version and get the same results.
: once it gets to Parque Mirador it jumps ahead, same with Opera (although here it is general in every page) and no problem at all in other browsers.

Maybe if we can get to the bottom of the “small” Chrome problem, we know where to go for the big one with Opera.

I’ve reported the issue to Opera and Chrome. Maybe they will do something about it.

Can we have a screenshot of that please :smile:. It may shed some light on it or at least I can see what you are seeing.

Hi Paul

I don’t think it’ll help much but here they are:

When I pressed Clumbus Lighthouse I got to the right position on the page in accordance with the anchor (capture1)
When I pressed, next, “Parque Mirador” I ended up not in Parque Mirador, but in the next and last section Los Tres Ojos (capture2)

many thanks again

Ps how do I attach the files?

There’s a cheat-sheet here that should help (assuming you have reached trust level 1 by now). It’s the ‘up arrow’ in the composer toolbar above the post window (5th from the right).

Nothing works with me…

I press “Upload” but nothing happens! Maybe I am not level1…

No you are level 1. Click your name (above my post) and you’ll see Trust Level 1.

1 Like

Sometimes it can be a bit slow, especially with a larger file, and it’s not obvious anything is happening. You should see a progress report below the “preview” window.

No, nothing

Ni progress report and unable to drag and drop. Possibly because I am not allowed not being level1. How can I change that?

You ARE level one. Did you even read my post?