Amazon Mechanical Turk API Only Returning AWS.notAuthorized Error


Been a while since I’ve been around. I’m working on a project that implements Amazon Mechanical Turk, and I’m trying to get the API working.

I started out trying to use their command line tools since I didn’t want to have to debug errors before seeing if the service worked anyway. However, not even the command line tools are working, and I’m not sure why.

My access keys are inserted correctly and double and triple checked, I’m signed up with AWS obviously, I’m signed up as a MTurk requester, I’m signed up for the MTurk service in AWS, I have a valid credit card on file, etc. I can’t think of any possible reason it shouldn’t be working, yet it is not.

BTW, I’m able to manually create HITs on MTurk through the interface, just not through the command line tools.

I run:


And I get:

An error occurred while fetching your balance: Error #1 for RequestId: 875ddb54-e97a-42eb-8292-fab465e11457 - AWS.NotAuthorized: The identity contained in the request is not authorized to use this AWSAccessKeyId (1309235254753)

That’s all I get. No idea why, and their forums aren’t helping, either. Been dealing with this since Friday so I’m getting frustrated.

Any idea what it could be? I’ve gone through my account several times looking for anything that needs enabled, activated, setup, etc, but can find nothing.

Thanks a lot. :slight_smile:


Nevermind. I figured it out. I was being really stupid.

But, does anyone know how to generate the security signature in PHP? That’s my next challenge I’ve been having trouble with.