Admin login re-directing to same page

Host is GoDaddy, domain is instantmoviesearch.com on a shared host.

Installation is done, looks great when i visit URL untill I change the permalink structure at wordpress admin for “instantmoviesearch”; The output result gives an error

Server Error
500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed.

And URL doesn’t work at all untill reinstalling wordpress. from another forums i recieved few directions.

I have been doing every crazy things possible on earth -

  Deactivated plugins
  Switch back to default themes
  Renaming .htaccess files
  Updated WP version 

BUT nothing resolves the issue :frowning: However I see a file web.config where i have installed WP (in a folder in the root) and when i break or rename it, error message doesn’t appear and I get the option to login. But when I try to login it redirects to the same login page. :frowning:

Here is the code from web.config file


<?xml version="1.0" encoding="UTF-8"?>
<configuration>
  <system.webServer>
    <rewrite>
      <rules>
                <rule name="wordpress" patternSyntax="Wildcard">
                    <match url="*"/>
                        <conditions>
                            <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true"/>
                            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true"/>
                        </conditions>
                    <action type="Rewrite" url="index.php"/>
                </rule></rules>
    </rewrite>
  </system.webServer>
</configuration>

What do i do so that i can login into admin? I have set a index.html file for time being and appears at url http://instantmoviesearch.com

Thanks for your help