Adding New Subdomain Takes A While?

Hey everyone,
I am hosted with HostGator shared and am trying to add a subdomain to my account. I create the subdomain in cPanel and go to my URL, however it says “Server not found” from my browser. When I view it from my iPhone (connected to WiFi) it shows the site fine. I have tried clearing my desktop’s browser cache, tried a different desktop browser, as well as tried a DNS flush in OSX Mountain Lion…

Terminal: dscacheutil -flushcache

And none of these seem to resolve the problem. I am still faced with the “Server not found” message from the browser.
Any idea what is happening here and how it can be resolved? Odd that the WiFi will work for my phone (same IP from the ISP I would think?) but it won’t work from my ethernet connection on the desktop?

It has been an issue that has been bugging me for a while.
Thanks very much!


I’ve never experienced ANY delay in the access to a subdomain (created via cPanel) so I’m at a loss. Your browser shouldn’t have to clear cache for a first-time connection to any host but your wifi has access? That would suggest that your subdomain’s subdirectory contains an .htaccess which is prohibiting access (unless via cellphone) but that would not account for the “Server not found” response.

Troubleshooting, I’d first check the configuration of the subdomain’s creation, it’s pointer (DocumentRoot is normally a subdomain-named subdirectory of the main domain) and any configuration within the .htaccess of the subdomain. If that’s not the problem, then a ticket to HostGator seems to be in order.



What happens if you try a different browser on your machine?


What happens if you run a PING or NSLOOKUP (in your command line). Do you get a response when using the ping? If not, try


. If you don’t get a result then it is quite possible that you have a hosts file on your computer that is getting in the way.

The other-thing is your desktop connected to a firewall that caches? This could also be Squid. If a firewall caches a low-level domain then when your browser searches for the domain the firewall might answer “I found the main domain, so serve back that the sub-domain is not here”, this would not query an outside DNS so it would fail there. Normally the browser will give you some feedback as to no connection or the server answered but the requested resource does not exist. Pay close attention to the message you get on your browser if it tells you what server answered this.