Active desktop recovery, desktop.htt problem


I’ve suddenly started having a problem with Active Desktop Recovery being shown every time I start my (Win XP Pro) machine. When I click “Restore my Active Desktop” I get the following error:

"An error has occured in a script on this page:

Line 65

Char 1


I’ve googled this and the only solution I can come up with is to delete the Desktop.htt file. I looked for this in the location above but the file isn’t there!? I’ve made sure hidden files are shown. I did a system search for this file, and it drew a blank.

I thought it might be a problem with my recent installation of IE7, but I’ve reinstalled this and it still doesn’t make a difference.

Has anyone got any ideas how to solve this?


I’ve got the same problem here, on a domain with 70 users!

I’m currently talking with Microsoft tech support about this problem. It appears to a problem somewhere in the local profile in Documents and Settings which is not compatible with IE7. I have found two ways to fix the problem so far -

  1. Uninstall IE7
  2. Login as an administrator and delete the users profile, when the user logs back in a new profile is created, but obviously you lose all the program settings - not the best way but it works


have now sorted a fix for this problem

run regedit

find this entry - HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components

change the key value - DeskHtmlVersion REG_DWORD 0x00000110(272) to decimal zero

Close regedit log off and log back on.

This has worked for all our XP clients

Heres a basic script to change the above registry setting

strComputer = “.”
Set objReg = GetObject(“winmgmts:\\” & strComputer & “\root\default:StdRegProv”)
strKeyPath = “Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components”
strValue = “0”
ValueName = “DeskHtmlVersion”
objReg.SetDWORDValue HKEY_CURRENT_USER, strKeyPath, ValueName, strValue

copy this to notepad and save as activedesktop.vbs, then run the file, logoff then log back in again

hope this helps

Sorry to bump this mega-old thread, but it happened to me again, and I was confused with editing the registry (sounds a bit serious for someone who knows nothing about that stuff). So I continued Googling and found a much simpler solution. Just right click desktop, select settings and change your screen resolution. Click okay and problem is solved (obviously you can then change your resolution back).


Thank you for this thread.

I just had exactly the same problem.

I had started down the path of taking stuff off my desktop gradually and eliminating the wallpaper changing program to see if that wouldn’t fix the problem. I had also done the delete desktop.htt fix and so far nothing had worked.

Changing the screen resolution back and forth worked instantly, thanks.

Does anybody understand why this thing happened? In my case, my computer, which is normally very stable had crashed just before I had the problem.

Small rant: One of the things which I find annoying about Microsoft software is that when bad stuff happens there is often very little information provided in the error messages that would allow the problem to be fixed. Perhaps this is another example where this criticism is justified.

I am searching the solution of this problem in google, and come back here. lol~~

There is a simple solution… just select the file .BMP extension for desktop background or wall paper (whatever you say) and restart your computer… it will solve your problem…

Thanks a Lot Middo:

YouR Update,

have now sorted this problem

"I ran regedit \ HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components
changed the key value - DeskHtmlVersion REG_DWORD 0x00000110(0)

when logged back in, it is working fine. i have not faced any issue ever since.

you are a life saver man, keep it up


I tried that in Vista but doesn’t work for me, I am still having this problem,

Anyone have a solution for vista?

My problem is that though I dont get that Active Desktop Recovery screen anymore by doing the HKEY thing, I do get a white screen which is partial covers my desktop. I have an XP.

Any help would be appreciate.

thanx a lot middo…
problem solved :agree:

"I ran regedit \ HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components
changed the key value - DeskHtmlVersion REG_DWORD 0x00000110(0)

This fix seems to work for about 2 days and then, the value is back to 272. So I have to keep changing it. Is there a perm way to resolve this issue??

I know this post is a bit late. I had this issue on one of my computers for over a year. But this certainly worked. Thanks for this!

I ran regedit \ HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode, but when i got to safemode, there was no folder inside of it named “components”. The only folder in side safemode is “general”. Can someone please help???

My desktop completely hanged after using regedit.

I reinstall windows Xp, problem solved.


Just a kwik msg to say thanks to danwednesday for your post, which I also found, whilst ‘googling’ for a solution, to above issue.

Thank u once again.




this solution worked like charm thanks for the solution…

Agreed - I got this with my VirtualBox IE7 install and also started down this path, but just changing the desktop size worked perfectly without doing any regediting…

middo - the script worked for me on xp thanks