A very bizarre problem

I built an e-commerce WP site for a client which has been live for a few months now. I am in the process of developing an added feature that involves custom PHP/database work uploading and manipulating an image. At this stage, it works fine on my local machine, and works fine when I set up a test site behind my portfolio site. So I tried uploading the three new files, and the edited functions.php file to the client’s server to test. This is what happened:

  1. When I am logged in, the website displays properly.
  2. When I am logged out, I get a white screen with the error message “Parse error: syntax error, unexpected ‘)’ in /home/picapoc2014/public_html/wp-content/themes/picapoc/functions.php on line 1”

I had error_reporting turned off in my wp-config.php file.

I went through my functions.php file with a fine-tooth comb (same file that was used in my test sites) and found no error such as a missing ‘;’, etc.

The file had been minified (hence, I thought, the line 1 indication), but when I unminified the file, I still got the same ‘line 1’ error.

The only other change I made was to add a table to the WP database.

What could be wrong? Does anybody have any idea of what I could do to solve this, that I haven’t already tried?

Can you post a copy of lines 1 & 2 of the script.

Actually, I had fixed it sometime last night, but unbeknownst to me, the caching plugin had been activated on my client’s site and it was displaying the instance when the error was still affecting things. I just discovered this tonight when I went in to check all the plugins to see if they were causing the problem.

Because of the caching, I have no idea which action I took in my panic actually solved the problem. :blush: