<!DOCTYPE html>
<!--[if IE 8]><html class="sp🚧  no-js lt-ie9" lang="en" ><![endif]-->
<!--[if gt IE 8]><!--><html class="sp🚧  no-js" lang="en" ><!--<![endif]-->
  <head>
    <link rel="manifest" href="/manifest.json">
    <link href="//dab1nmslvvntp.cloudfront.net" ref="dns-prefetch">
    <link href="//d2sis3lil8ndrq.cloudfront.net" ref="dns-prefetch">
    <link href="//sitepoint.com" ref="dns-prefetch">
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
        <meta property="og:image" content="https://www.sitepoint.com/wp-content/themes/sitepoint/assets/images/icon.web.png">
        
    <link rel="shortcut icon" href="https://dab1nmslvvntp.cloudfront.net/favicon.ico" />

    <link rel="apple-touch-icon-precomposed" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-57x57-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-72x72-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-114x114-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-144x144-precomposed.png" />

    <!-- Sitepoint's new font from Google Fonts -->
    <link href='https://fonts.googleapis.com/css?family=Roboto:900,900italic,700,700italic,400,400italic,300,300italic' rel='stylesheet' type='text/css'>

    <link rel="stylesheet" href="https://pro.fontawesome.com/releases/v5.2.0/css/all.css" >

    <link rel="alternate" type="application/rss+xml" title="RSS Feed for SitePoint.com" href="https://www.sitepoint.com/feed/" />

        <link href="https://plus.google.com/+sitepoint" rel="publisher" />
        <meta property="twitter:account_id" content="15743570" />
    <meta http-equiv="X-UA-Compatible" content="IE=Edge">

    <meta name="google-site-verification" content="hcQq0cWX73AYby8aMMzNHx8bZrTDI75GWeljGdPmNf8"  />
<meta name="google-site-verification" content="I0jyQlTvZaveab8RtDOjUxSPZXbdSgFrcKdAwaCCfvA"  />


<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KL8PMMW');</script>

    <script class="SP_stripMobile" type="text/javascript">
      var propertag = propertag || {};
      propertag.cmd = propertag.cmd || [];
      (function() {
      var pm = document.createElement('script');
      pm.async = true; pm.type = 'text/javascript';
      var is_ssl = 'https:' == document.location.protocol;
      pm.src = (is_ssl ? 'https:' : 'http:') + '//global.proper.io/sitepoint.min.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(pm, node);
      })();
    </script>
    <script class="SP_stripMobile" type="text/javascript">
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
      var gads = document.createElement('script');
      gads.async = true;
      gads.type = 'text/javascript';
      var useSSL = 'https:' == document.location.protocol;
      gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(gads, node);
      })();
    </script>
    <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
    <script>
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "65189cfb-a985-4bd7-a41b-c2666081e811",
      safari_web_id: 'web.onesignal.auto.49d2239d-a04e-422a-89e0-14dbda97fb4d',
      autoRegister: true,
      persistNotification: true,
      welcomeNotification: {
        disable: true
      },
    }]);
  </script>
    
<!-- This site is optimized with the Yoast SEO plugin v7.5.3 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Announcing the Alibaba Cloud Competition Winners &mdash; SitePoint</title>
<meta name="description" content="Find out who the winners of the Alibaba Cloud competition are."/>
<link rel="canonical" href="https://www.sitepoint.com/announcing-the-alibaba-cloud-competition-winners/" />
<link rel="publisher" href="https://plus.google.com/+sitepoint/"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Announcing the Alibaba Cloud Competition Winners &mdash; SitePoint" />
<meta property="og:description" content="Find out who the winners of the Alibaba Cloud competition are." />
<meta property="og:url" content="https://www.sitepoint.com/announcing-the-alibaba-cloud-competition-winners/" />
<meta property="og:site_name" content="SitePoint" />
<meta property="article:publisher" content="https://www.facebook.com/sitepoint" />
<meta property="article:tag" content="alibabacloud" />
<meta property="article:tag" content="joelf" />
<meta property="article:tag" content="sponsored" />
<meta property="article:section" content="Web" />
<meta property="article:published_time" content="2018-10-15T09:00:20-07:00" />
<meta property="article:modified_time" content="2018-10-14T22:01:09-07:00" />
<meta property="og:updated_time" content="2018-10-14T22:01:09-07:00" />
<meta property="og:image" content="https://d1nlfd9mjn1pae.cloudfront.net/wp-content/uploads/2018/10/1539579495mark-solarski-209233-unsplash.jpg" />
<meta property="og:image:secure_url" content="https://d1nlfd9mjn1pae.cloudfront.net/wp-content/uploads/2018/10/1539579495mark-solarski-209233-unsplash.jpg" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="666" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Find out who the winners of the Alibaba Cloud competition are." />
<meta name="twitter:title" content="Announcing the Alibaba Cloud Competition Winners &mdash; SitePoint" />
<meta name="twitter:site" content="@sitepointdotcom" />
<meta name="twitter:image" content="https://d1nlfd9mjn1pae.cloudfront.net/wp-content/uploads/2018/10/1539579495mark-solarski-209233-unsplash.jpg" />
<meta name="twitter:creator" content="@sitepointdotcom" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SitePoint &raquo; Announcing the Alibaba Cloud Competition Winners Comments Feed" href="https://www.sitepoint.com/announcing-the-alibaba-cloud-competition-winners/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sitepoint.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-parsely-style-css'  href='https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-parsely/wp-parsely.css?ver=1539319469' type='text/css' media='all' />
<link rel='stylesheet' id='wp-postratings-css'  href='https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-postratings/css/postratings-css.css?ver=1.85' type='text/css' media='all' />
<link rel='stylesheet' id='sitepoint-styles-css'  href='//www.sitepoint.com/wp-content/themes/sitepoint/assets/stylesheets/styles-63620ced6374adfdc078b1a126c2f666.css?ver=4.9.6' type='text/css' media='all' />
<link rel="stylesheet" id="sitepoint-styles-janus-css" href="/dist/css/compiled.14fecbd88f6d96c6b253.css" type="text/css" media="all"><link rel="stylesheet" id="sitepoint-styles-janus-article-css" href="/dist/css/compiledArticle.14fecbd88f6d96c6b253.css" type="text/css" media="all">
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-head-302ae967a92241deb24be6e2a54eeefd.js?ver=4.9.6'></script>
<link rel='https://api.w.org/' href='https://www.sitepoint.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sitepoint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sitepoint.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.6" />
<link rel='shortlink' href='https://www.sitepoint.com/?p=169488' />
<link rel="alternate" type="application/json+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fannouncing-the-alibaba-cloud-competition-winners%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fannouncing-the-alibaba-cloud-competition-winners%2F&#038;format=xml" />

<!-- BEGIN wp-parsely Plugin Version 1.13.0 -->
<meta name="wp-parsely_version" id="wp-parsely_version" content="1.13.0"/>
	<script type="application/ld+json">
	{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.sitepoint.com\/announcing-the-alibaba-cloud-competition-winners\/"},"headline":"Announcing the Alibaba Cloud Competition Winners","url":"http:\/\/www.sitepoint.com\/announcing-the-alibaba-cloud-competition-winners\/","thumbnailUrl":"https:\/\/d1nlfd9mjn1pae.cloudfront.net\/wp-content\/uploads\/2018\/10\/1539579495mark-solarski-209233-unsplash-150x150.jpg","image":{"@type":"ImageObject","url":"https:\/\/d1nlfd9mjn1pae.cloudfront.net\/wp-content\/uploads\/2018\/10\/1539579495mark-solarski-209233-unsplash-150x150.jpg"},"dateCreated":"2018-10-15T16:00:20Z","datePublished":"2018-10-15T16:00:20Z","dateModified":"2018-10-15T16:00:20Z","articleSection":"Web","author":[{"@type":"Person","name":"Tonino Jankov"}],"creator":["Tonino Jankov"],"keywords":["alibabacloud","joelf","sponsored"],"publisher":{"@type":"Organization","name":"SitePoint","logo":{"@type":"ImageObject","url":""}}}
	</script>

	<!-- END wp-parsely Plugin Version 1.13.0 -->
    <script type="text/javascript">
      googletag.cmd.push(function() {
        purchs2s.cmd.push(function() {
          		googletag.pubads().setTargeting("channel", "web");
		googletag.pubads().setTargeting("post_id", "169488");
		googletag.pubads().setTargeting("AOL",["true", "false"]);
		googletag.pubads().setTargeting("OpenX",["true", "false"]);
		googletag.pubads().setTargeting("Tribal",["true", "false"]);
		googletag.pubads().enableSingleRequest();
                    googletag.pubads().collapseEmptyDivs();
          googletag.pubads().disableInitialLoad();
          googletag.enableServices();
          purchs2s.setup();
        });
      });
      SP_GPT_Slots = [];
    </script>
    <!--[if lt IE 9]>
      <script src="/wp-content/themes/sitepoint/assets/javascripts/vendor/respond.custom.min.js"></script>
    <![endif]-->
    <style>
  .t-color { color: #1C94C6 }
  a.t-color:hover,
  button.t-color:hover { color: #1779A2 }

  .t-bg { background-color: #1C94C6 }
  a.t-bg:hover,
  button.t-bg:hover { background-color: #1779A2}

  .t-border { border-color: #1C94C6 }
  a.t-border:hover,
  button.t-border:hover { border-color: #1779A2 }

  .t-bg-dark { background-color: #1779A2 }

  .t-list li:before { background-color: #1C94C6; }

  .t-p-pop-bg { background-color: #1a9b9e }
  a.t-p-pop-bg:hover,
  button.t-p-pop-bg:hover { background-color: #018285}
</style>
  </head>
  <body>
  <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KL8PMMW"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
        <header class="main-header u-isSingle" role="banner">
      <nav id="navigation-bar" class="l-p-fix l-d-f l-w-100 t-bg-grey-500 navigation-bar">
        <div class="l-d-f l-w-100 l-w-3col--3col l-w-4col--4col l-jc-sb l-mh-auto l-ph2">
          <section class="l-d-f l-ai-str l-jc-sta">
            <a tabIndex="0" class="l-d-f l-ai-cen l-pa3 f-c-white t-t NavBar_item" onClick="sitepoint.SidebarNav_toggle(event)" onKeyUp="sitepoint.SidebarNav_toggle(event)">
              <i class="f-minor l-mb0 fas f-medium fa-bars"></i>
            </a>
            
<div id="SidebarNav" class="SidebarNav" onKeyUp="sitepoint.SidebarNav_toggle(event)">
  <header class="m-border-b SidebarNav_header">
    <a href="#" onClick="sitepoint.SidebarNav_toggle(event)" class="l-pt0 f-light">
      <span class="SidebarNav_icon">&times;</span>
    </a>
    <div class="l-d-n l-d-b--3col SidebarNav_search">
      <form method="get" action="https://www.sitepoint.com/">
        <input aria-label="search" autocomplete="off" id="sidebar-search-box" name="s" placeholder="Search" type="text">
        <button><i class="fas fa-search"></i></button>
      </form>
    </div>
  </header>

  <section class="m-border-b">
    <ul>
      <li class="SidebarNav_link f-minor l-mb0 u-premium/l/join ">
            <i class="SidebarNav_icon fas fa-user u-premium/l/join"></i>
            
            <a class="f-light" href="/premium/l/join?ref_source=sitepoint&ref_medium=drawer" onclick="">Sign Up</a>
          </li>      <li class="SidebarNav_link f-minor l-mb0 u-premium/sign-in ">
            <i class="SidebarNav_icon fas fa-sign-in u-premium/sign-in"></i>
            
            <a class="f-light" href="/premium/sign-in/?ref_source=sitepoint&ref_medium=drawer" onclick="">Login</a>
          </li>                </ul>
  </section>

  <section class="m-border-b">
    <ul>
        <li class="SidebarNav_link f-minor l-mb0 u-# no-link">
            <i class="SidebarNav_icon fab fa-html5 u-#"></i>
            
            <a class="f-light" href="#" onclick="return false;">HTML and CSS</a>
          </li>        <li class="SidebarNav_link f-minor l-mb0 u-learn/bootstrap l-pl5">
            <i class="SidebarNav_icon fas fa-bold u-learn/bootstrap"></i>
            
            <a class="f-light" href="/learn/bootstrap/?ref_source=sitepoint&ref_medium=drawer" onclick="">Learn Bootstrap</a>
          </li>        <li class="SidebarNav_link f-minor l-mb0 u-# no-link">
            <i class="SidebarNav_icon fab fa-js u-#"></i>
            
            <a class="f-light" href="#" onclick="return false;">Javascript</a>
          </li>        <li class="SidebarNav_link f-minor l-mb0 u-learn/javascript l-pl5">
            <i class="SidebarNav_icon fab fa-js u-learn/javascript"></i>
            
            <a class="f-light" href="/learn/javascript/?ref_source=sitepoint&ref_medium=drawer" onclick="">Learn Javascript</a>
          </li>        <li class="SidebarNav_link f-minor l-mb0 u-learn/react l-pl5">
            <i class="SidebarNav_icon fab fa-react u-learn/react"></i>
            
            <a class="f-light" href="/learn/react/?ref_source=sitepoint&ref_medium=drawer" onclick="">Learn React</a>
          </li>        <li class="SidebarNav_link f-minor l-mb0 u-learn/angular l-pl5">
            <i class="SidebarNav_icon fab fa-angular u-learn/angular"></i>
            
            <a class="f-light" href="/learn/angular/?ref_source=sitepoint&ref_medium=drawer" onclick="">Learn Angular</a>
          </li>        <li class="SidebarNav_link f-minor l-mb0 u-learn/nodejs l-pl5">
            <i class="SidebarNav_icon fab fa-node-js u-learn/nodejs"></i>
            
            <a class="f-light" href="/learn/nodejs/?ref_source=sitepoint&ref_medium=drawer" onclick="">Learn Node.js</a>
          </li>        <li class="SidebarNav_link f-minor l-mb0 u-# no-link">
            <i class="SidebarNav_icon fab fa-bitcoin u-#"></i>
            
            <a class="f-light" href="#" onclick="return false;">Blockchain</a>
          </li>        <li class="SidebarNav_link f-minor l-mb0 u-learn/blockchain l-pl5">
            <i class="SidebarNav_icon fab fa-ethereum u-learn/blockchain"></i>
            
            <a class="f-light" href="/learn/blockchain/?ref_source=sitepoint&ref_medium=drawer" onclick="">Learn Blockchain</a>
          </li>        <li class="SidebarNav_link f-minor l-mb0 u-# no-link">
            <i class="SidebarNav_icon fas fa-microscope u-#"></i>
            
            <a class="f-light" href="#" onclick="return false;">UX</a>
          </li>        <li class="SidebarNav_link f-minor l-mb0 u-learn/ux-analytics l-pl5">
            <i class="SidebarNav_icon fal fa-hand-pointer u-learn/ux-analytics"></i>
            
            <a class="f-light" href="/learn/ux-analytics/?ref_source=sitepoint&ref_medium=drawer" onclick="">Learn UX Analytics</a>
          </li>    </ul>
  </section>

  <section class="m-border-b SidebarNav_products">
    <ul>
      <li class="SidebarNav_link f-minor l-mb0 u-premium/deals/?ref_source=sitepoint&ref_medium=drawer ">
            <i class="SidebarNav_icon far fa-gem u-premium/deals/?ref_source=sitepoint&ref_medium=drawer"></i>
            
            <a class="f-light" href="/premium/deals/?ref_source=sitepoint&ref_medium=drawer?ref_source=sitepoint&ref_medium=drawer" onclick="">Deals</a>
          </li>      <li class="SidebarNav_link f-minor l-mb0 u-premium/books ">
            <i class="SidebarNav_icon fas fa-book u-premium/books"></i>
            
            <a class="f-light" href="/premium/books/?ref_source=sitepoint&ref_medium=drawer" onclick="">Books</a>
          </li>      <li class="SidebarNav_link f-minor l-mb0 u-premium/courses ">
            <i class="SidebarNav_icon fas fa-play-circle u-premium/courses"></i>
            
            <a class="f-light" href="/premium/courses/?ref_source=sitepoint&ref_medium=drawer" onclick="">Courses</a>
          </li>    </ul>
  </section>

  <section class="m-border-b SidebarNav_topics">
    <ul>
      <li class="SidebarNav_link SidebarNav_channelLink f-minor l-mb0 u-html-css">
            <i class="SidebarNav_icon fas fa-circle fa-xs u-html-css"></i>
            <a class="f-light" href="https://www.sitepoint.com/html-css/?ref_source=sitepoint&ref_medium=drawer" data-channel="html-css">HTML &amp; CSS</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink f-minor l-mb0 u-javascript">
            <i class="SidebarNav_icon fas fa-circle fa-xs u-javascript"></i>
            <a class="f-light" href="https://www.sitepoint.com/javascript/?ref_source=sitepoint&ref_medium=drawer" data-channel="javascript">JavaScript</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink f-minor l-mb0 u-php">
            <i class="SidebarNav_icon fas fa-circle fa-xs u-php"></i>
            <a class="f-light" href="https://www.sitepoint.com/php/?ref_source=sitepoint&ref_medium=drawer" data-channel="php">PHP</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink f-minor l-mb0 u-design-ux">
            <i class="SidebarNav_icon fas fa-circle fa-xs u-design-ux"></i>
            <a class="f-light" href="https://www.sitepoint.com/design-ux/?ref_source=sitepoint&ref_medium=drawer" data-channel="design-ux">Design &amp; UX</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink f-minor l-mb0 u-web u-active">
            <i class="SidebarNav_icon fas fa-circle fa-xs u-web"></i>
            <a class="f-light" href="https://www.sitepoint.com/web/?ref_source=sitepoint&ref_medium=drawer" data-channel="web">Web</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink f-minor l-mb0 u-wordpress">
            <i class="SidebarNav_icon fas fa-circle fa-xs u-wordpress"></i>
            <a class="f-light" href="https://www.sitepoint.com/wordpress/?ref_source=sitepoint&ref_medium=drawer" data-channel="wordpress">WordPress</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink f-minor l-mb0 u-developer-center">
            <i class="SidebarNav_icon fas fa-circle fa-xs u-developer-center"></i>
            <a class="f-light" href="https://www.sitepoint.com/developer-center/?ref_source=sitepoint&ref_medium=drawer" data-channel="developer-center">Microsoft Tech</a>
          </li>    </ul>
  </section>

  <section class="m-border-b">
    <ul>
      <li class="SidebarNav_link f-minor l-mb0 u-community ">
            <i class="SidebarNav_icon fas fa-comments u-community"></i>
            
            <a class="f-light" href="/community/?ref_source=sitepoint&ref_medium=drawer" onclick="">Community</a>
          </li>      <li class="SidebarNav_link f-minor l-mb0 u-versioning ">
            
            <i class="SidebarNav_icon"><?xml version="1.0" encoding="UTF-8" standalone="no"?>
<svg viewBox="0 0 463 533">
    <g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g id="Misc-Icons" transform="translate(-224.000000, -209.000000)" fill="#A2A2A2">
            <g id="Adam" transform="translate(224.000000, 209.000000)">
                <path d="M205.23914,223.989305 C205.23914,239.058221 193.018305,251.270053 177.938282,251.270053 C162.858259,251.270053 150.637425,239.064975 150.637425,223.989305 C150.637425,208.927144 162.858259,196.708557 177.938282,196.708557 C193.018305,196.708557 205.23914,208.927144 205.23914,223.989305" id="Shape"></path>
                <path d="M319.240023,223.989305 C319.240023,239.058221 307.019188,251.270053 291.939165,251.270053 C276.859142,251.270053 264.638308,239.064975 264.638308,223.989305 C264.638308,208.927144 276.859142,196.708557 291.939165,196.708557 C307.019188,196.708557 319.240023,208.927144 319.240023,223.989305" id="Shape-Copy"></path>
                <path d="M45.9192714,105.68948 C47.1603233,105.013767 48.4156135,104.338834 49.6814591,103.66477 C49.285517,101.268011 49.079511,98.8067359 49.079511,96.2970985 C49.079511,71.6393315 68.9663337,51.6502619 93.4979726,51.6502619 C104.828598,51.6502619 115.168338,55.9145566 123.11028,62.1553999 C123.11028,37.497633 142.997103,17.5085634 167.528742,17.5085634 C177.872808,17.5085634 187.39103,21.0626011 194.940698,27.0220906 C201.994758,11.1002236 217.874616,0 236.33381,0 C255.201408,0 271.374274,11.5968357 278.182101,28.0859033 C285.813075,16.4403992 298.937725,8.75428168 313.84838,8.75428168 C335.217866,8.75428168 352.918943,24.5413571 356.037389,45.1451696 C359.093922,44.2508863 362.326213,43.7714084 365.669919,43.7714084 C384.669913,43.7714084 400.072453,59.2531388 400.072453,78.3508211 C400.072453,84.451539 398.500668,90.1832596 395.741931,95.1591734 C420.545,106.093308 441.166028,118.313655 447.484806,130.438797 C462.05792,158.40324 448.921531,194.216875 441.795446,209.76377 C445.786047,226.227441 447.901492,243.429264 447.901492,261.127716 C447.901492,277.569319 446.075834,293.582324 442.617163,308.973095 C454.31826,313.102542 462.707645,324.30529 462.707645,337.477559 C462.707645,352.446546 451.87352,364.872078 437.657056,367.264056 C442.403415,372.604775 445.288641,379.652197 445.288641,387.376964 C445.288641,404.057219 431.83579,417.579236 415.240858,417.579236 C414.739425,417.579236 414.24086,417.56689 413.745449,417.542485 C416.086983,421.841984 417.418234,426.776628 417.418234,432.023801 C417.418234,448.704055 403.965383,462.226073 387.370451,462.226073 C385.766225,462.226073 384.191363,462.099709 382.655177,461.856345 C383.175775,464.083267 383.451175,466.405199 383.451175,468.791784 C383.451175,485.472038 369.998324,498.994056 353.403392,498.994056 C348.884389,498.994056 344.598385,497.991345 340.753583,496.195199 C340.156973,512.346957 326.941829,525.256901 310.726831,525.256901 C300.435078,525.256901 291.351821,520.056112 285.93648,512.126599 C281.811241,523.856499 270.681444,532.260326 257.598867,532.260326 C247.286985,532.260326 238.188331,527.039174 232.776786,519.083469 C227.365238,527.039175 218.266585,532.260326 207.954704,532.260326 C194.872127,532.260326 183.74233,523.856499 179.617091,512.126599 C174.20175,520.056112 165.118493,525.256901 154.82674,525.256901 C138.611742,525.256901 125.396598,512.346957 124.799988,496.195199 C120.955186,497.991345 116.669182,498.994056 112.150179,498.994056 C95.5552468,498.994056 82.1023962,485.472038 82.1023962,468.791784 C82.1023962,466.405199 82.3777956,464.083267 82.8983938,461.856345 C81.3622084,462.099709 79.7873457,462.226073 78.1831202,462.226073 C61.588188,462.226073 48.1353374,448.704055 48.1353374,432.023801 C48.1353374,426.776628 49.4665878,421.841984 51.8081225,417.542485 C51.312711,417.56689 50.8141464,417.579236 50.312713,417.579236 C33.7177807,417.579236 20.2649301,404.057219 20.2649301,387.376964 C20.2649301,379.652197 23.1501561,372.604775 27.8965152,367.264056 C13.6800506,364.872078 2.84592558,352.446546 2.84592558,337.477559 C2.84592558,324.30529 11.2353108,313.102542 22.9364075,308.973095 C19.4777374,293.582324 17.6520794,277.569319 17.6520794,261.127716 C17.6520794,244.483155 19.5230884,228.277837 23.0652378,212.71266 C23.0461555,212.67345 23.0269954,212.633634 23.0077587,212.593218 C8.40744355,199.915919 -22.2912349,139.477462 27.9975916,114.351569 C34.9803921,110.862741 40.9027514,108.009708 45.9192714,105.68948 L45.9192714,105.68948 Z M321.182928,338.855264 C312.257241,380.392075 275.494697,411.515802 231.5,411.515802 C187.505303,411.515802 150.742759,380.392075 141.817072,338.855264 L321.182928,338.855264 L321.182928,338.855264 L321.182928,338.855264 Z M323.401809,93.513343 C382.119911,125.539939 421.986958,188.049902 421.986958,259.919187 C421.986958,269.181179 421.324839,278.287729 420.045582,287.193626 L420.045582,287.193626 C414.531038,280.687855 406.320283,276.561781 397.150761,276.561781 C382.005642,276.561781 369.476084,287.817909 367.390774,302.461227 C361.921787,296.754612 354.241111,293.204376 345.735474,293.204376 C336.696537,293.204376 328.589254,297.213765 323.07789,303.559722 L323.07789,303.559722 C317.566526,297.213765 309.459243,293.204376 300.420306,293.204376 C291.140116,293.204376 282.841976,297.430646 277.326999,304.072813 C271.812023,297.430646 263.513882,293.204376 254.233693,293.204376 C245.884947,293.204376 238.331009,296.624848 232.883277,302.147652 L232.883277,302.147652 C227.435545,296.624848 219.881607,293.204376 211.532861,293.204376 C202.252672,293.204376 193.954531,297.430646 188.439555,304.072813 C182.924578,297.430646 174.626438,293.204376 165.346248,293.204376 C156.307311,293.204376 148.200028,297.213765 142.688664,303.559722 L142.688664,303.559722 C137.1773,297.213765 129.070017,293.204376 120.03108,293.204376 C111.525443,293.204376 103.844767,296.754612 98.3757799,302.461227 C96.2904699,287.817909 83.7609125,276.561781 68.6157934,276.561781 C60.2507056,276.561781 52.6835401,279.995657 47.2334107,285.537513 C46.105173,277.159748 45.5224867,268.607864 45.5224867,259.919187 C45.5224867,222.269089 56.4635528,187.187552 75.3242153,157.711582 C101.872077,155.792935 136.061257,148.07484 172.032022,134.915239 C218.909805,117.765397 257.559595,95.4909208 277.539381,75.8645287 C278.024685,75.9807367 278.50926,76.0988336 278.993099,76.2188112 C286.713596,87.3063559 299.514894,94.5568665 314.000977,94.5568665 C317.230893,94.5568665 320.377051,94.1964131 323.401809,93.513343 L323.401809,93.513343 L323.401809,93.513343 Z" id="Path"></path>
            </g>
        </g>
    </g>
</svg>
</i>
            <a class="f-light" href="/versioning/?ref_source=sitepoint&ref_medium=drawer" onclick="">Versioning</a>
          </li>      <li class="SidebarNav_link f-minor l-mb0 u-newsletter ">
            <i class="SidebarNav_icon fas fa-envelope u-newsletter"></i>
            
            <a class="f-light" href="/newsletter/?ref_source=sitepoint&ref_medium=drawer" onclick="">Newsletters</a>
          </li>    </ul>
  </section>

  <section class="m-border-b SidebarNav_admin">
    <ul>
      <li class="SidebarNav_link f-minor l-mb0 u-advertise ">
            
            
            <a class="f-light" href="/advertise/?ref_source=sitepoint&ref_medium=drawer" onclick="">Advertise</a>
          </li>      <li class="SidebarNav_link f-minor l-mb0 u-contact-us ">
            
            
            <a class="f-light" href="/contact-us/?ref_source=sitepoint&ref_medium=drawer" onclick="">Contact Us</a>
          </li>      <zendesk />
    </ul>
  </section>

  
  <section class="SidebarNav_social">
    <ul>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="/newsletter/">
          <i class="fas fa-envelope SidebarNav_socialIcon u-newsletter"></i>
          <span class="SidebarNav_socialCount">1.2M<br />Subscribers</span>
        </a>
      </li>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="https://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
          <i class="fab fa-twitter SidebarNav_socialIcon u-twitter"></i>
          <span class="SidebarNav_socialCount">136k<br />Followers</span>
        </a>
      </li>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="https://facebook.com/sitepoint" rel="noopener" target="_blank">
          <i class="fab fa-facebook SidebarNav_socialIcon u-facebook"></i>
          <span class="SidebarNav_socialCount">100k<br />Followers</span>
        </a>
      </li>
    </ul>
  </section>
</div>

<div class="SidebarNav_lightbox" onClick="sitepoint.SidebarNav_toggle(event)"></div>
            <a class="l-d-f" href="https://www.sitepoint.com/">
              <div class="l-d-n l-d-f--3col l-as-cen">
                <svg class="sp-logo" viewBox="0 0 123 27">
  <g fill-rule="evenodd">
    <path d="M31.36,16.75 C31.56,17.07 31.82,17.31 32.14,17.50 C32.46,17.68 32.82,17.82 33.23,17.89 C33.63,17.97 34.05,18.01 34.48,18.01 C34.81,18.01 35.16,17.99 35.52,17.94 C35.89,17.89 36.22,17.81 36.53,17.68 C36.83,17.55 37.08,17.36 37.28,17.11 C37.48,16.87 37.58,16.55 37.58,16.17 C37.58,15.64 37.37,15.24 36.96,14.97 C36.55,14.69 36.03,14.47 35.41,14.31 C34.79,14.14 34.12,13.99 33.39,13.85 C32.66,13.71 31.99,13.52 31.37,13.27 C30.75,13.03 30.23,12.68 29.82,12.23 C29.41,11.78 29.20,11.16 29.20,10.36 C29.20,9.73 29.34,9.20 29.63,8.75 C29.92,8.30 30.30,7.94 30.75,7.66 C31.20,7.38 31.72,7.17 32.29,7.03 C32.86,6.90 33.42,6.83 33.99,6.83 C34.71,6.83 35.38,6.89 35.99,7.01 C36.61,7.13 37.15,7.34 37.62,7.63 C38.09,7.93 38.46,8.33 38.75,8.83 C39.03,9.34 39.19,9.96 39.24,10.72 L37.13,10.72 C37.10,10.32 36.99,9.98 36.81,9.72 C36.63,9.46 36.40,9.25 36.12,9.08 C35.84,8.92 35.53,8.81 35.19,8.74 C34.85,8.66 34.51,8.63 34.16,8.63 C33.84,8.63 33.53,8.65 33.20,8.70 C32.88,8.75 32.59,8.83 32.32,8.95 C32.06,9.07 31.84,9.23 31.68,9.43 C31.51,9.63 31.43,9.89 31.43,10.21 C31.43,10.56 31.56,10.86 31.82,11.09 C32.07,11.32 32.40,11.51 32.80,11.66 C33.19,11.82 33.64,11.95 34.13,12.05 C34.63,12.15 35.13,12.26 35.62,12.37 C36.15,12.49 36.67,12.62 37.17,12.78 C37.67,12.94 38.12,13.15 38.51,13.42 C38.90,13.68 39.21,14.01 39.45,14.41 C39.69,14.81 39.81,15.31 39.81,15.90 C39.81,16.66 39.65,17.28 39.33,17.77 C39.01,18.27 38.58,18.67 38.06,18.98 C37.54,19.28 36.96,19.49 36.30,19.61 C35.65,19.73 35.00,19.79 34.36,19.79 C33.65,19.79 32.97,19.72 32.32,19.58 C31.68,19.43 31.11,19.20 30.61,18.87 C30.12,18.54 29.72,18.11 29.42,17.57 C29.13,17.03 28.96,16.38 28.93,15.61 L31.03,15.61 C31.05,16.06 31.16,16.44 31.36,16.75" id="Fill-1"></path>
    <path d="M42.27,7.12 L44.37,7.12 L44.37,19.53 L42.27,19.53 L42.27,7.12 Z" id="Fill-2"></path>
    <path d="M53.13,7.12 L53.13,8.92 L50.57,8.92 L50.57,16.62 C50.57,16.86 50.59,17.05 50.63,17.20 C50.67,17.34 50.75,17.46 50.87,17.54 C50.99,17.62 51.15,17.67 51.35,17.69 C51.56,17.71 51.83,17.73 52.16,17.73 L53.13,17.73 L53.13,19.53 L51.51,19.53 C50.97,19.53 50.50,19.49 50.11,19.42 C49.72,19.35 49.41,19.22 49.17,19.02 C48.93,18.83 48.75,18.56 48.64,18.21 C48.52,17.86 48.46,17.39 48.46,16.81 L48.46,8.92 L46.28,8.92 L46.28,7.12 L48.46,7.12 L48.46,3.39 L50.57,3.39 L50.57,7.12 L53.13,7.12" id="Fill-3"></path>
    <path d="M64.53,18.73 C63.57,19.44 62.36,19.79 60.91,19.79 C59.89,19.79 59.00,19.63 58.25,19.31 C57.49,18.99 56.86,18.54 56.35,17.97 C55.84,17.39 55.45,16.70 55.20,15.90 C54.94,15.10 54.80,14.23 54.76,13.29 C54.76,12.34 54.91,11.48 55.21,10.69 C55.51,9.91 55.92,9.23 56.46,8.65 C57.00,8.08 57.63,7.63 58.37,7.31 C59.11,6.99 59.91,6.83 60.79,6.83 C61.93,6.83 62.87,7.05 63.63,7.51 C64.38,7.97 64.98,8.55 65.44,9.25 C65.89,9.96 66.20,10.73 66.38,11.56 C66.55,12.39 66.62,13.18 66.59,13.93 L56.99,13.93 C56.98,14.48 57.04,14.99 57.19,15.48 C57.34,15.97 57.58,16.40 57.91,16.78 C58.24,17.16 58.66,17.46 59.18,17.68 C59.69,17.90 60.29,18.01 60.98,18.01 C61.88,18.01 62.61,17.82 63.18,17.41 C63.75,17.02 64.13,16.41 64.31,15.59 L66.39,15.59 C66.11,16.98 65.49,18.03 64.53,18.73 L64.53,18.73 Z M64.02,10.76 C63.83,10.33 63.58,9.96 63.25,9.65 C62.93,9.34 62.55,9.09 62.11,8.90 C61.68,8.72 61.19,8.63 60.66,8.63 C60.12,8.63 59.62,8.72 59.19,8.90 C58.75,9.09 58.37,9.34 58.06,9.66 C57.75,9.98 57.50,10.35 57.32,10.78 C57.13,11.20 57.03,11.65 56.99,12.13 L64.36,12.13 C64.32,11.65 64.21,11.20 64.02,10.76 L64.02,10.76 Z" id="Fill-4"></path>
    <path d="M70.95,7.12 L70.95,8.80 L71.00,8.80 C71.35,8.11 71.89,7.61 72.64,7.30 C73.38,6.98 74.20,6.83 75.09,6.83 C76.09,6.83 76.95,7.00 77.68,7.36 C78.42,7.71 79.03,8.18 79.52,8.78 C80.01,9.38 80.37,10.08 80.62,10.86 C80.87,11.65 80.99,12.48 80.99,13.36 C80.99,14.24 80.87,15.07 80.63,15.85 C80.39,16.64 80.03,17.32 79.54,17.91 C79.06,18.49 78.44,18.95 77.71,19.29 C76.97,19.62 76.12,19.79 75.14,19.79 C74.83,19.79 74.48,19.76 74.09,19.70 C73.70,19.63 73.32,19.53 72.94,19.38 C72.56,19.24 72.20,19.04 71.86,18.79 C71.52,18.55 71.23,18.24 71.00,17.87 L70.95,17.87 L70.95,24.26 L68.84,24.26 L68.84,7.12 L70.95,7.12 L70.95,7.12 Z M78.53,11.52 C78.37,10.97 78.13,10.48 77.81,10.04 C77.49,9.61 77.07,9.27 76.57,9.01 C76.06,8.76 75.47,8.63 74.79,8.63 C74.08,8.63 73.48,8.76 72.98,9.04 C72.49,9.31 72.08,9.67 71.77,10.10 C71.46,10.55 71.23,11.05 71.09,11.60 C70.95,12.17 70.88,12.73 70.88,13.31 C70.88,13.92 70.95,14.51 71.10,15.07 C71.25,15.64 71.48,16.14 71.81,16.57 C72.13,17.01 72.55,17.35 73.06,17.62 C73.57,17.88 74.19,18.01 74.92,18.01 C75.65,18.01 76.25,17.88 76.74,17.61 C77.23,17.34 77.62,16.98 77.92,16.53 C78.22,16.08 78.43,15.57 78.56,14.99 C78.70,14.41 78.76,13.82 78.76,13.21 C78.76,12.64 78.68,12.07 78.53,11.52 L78.53,11.52 Z" id="Fill-5"></path>
    <path d="M83.17,10.78 C83.44,9.98 83.84,9.30 84.36,8.71 C84.89,8.13 85.55,7.67 86.33,7.33 C87.10,7.00 87.99,6.83 89.00,6.83 C90.03,6.83 90.92,7.00 91.69,7.33 C92.46,7.67 93.11,8.13 93.64,8.71 C94.17,9.30 94.56,9.98 94.83,10.78 C95.09,11.57 95.23,12.42 95.23,13.33 C95.23,14.25 95.09,15.09 94.83,15.88 C94.56,16.66 94.17,17.35 93.64,17.93 C93.11,18.52 92.46,18.97 91.69,19.30 C90.92,19.63 90.03,19.79 89.00,19.79 C87.99,19.79 87.10,19.63 86.33,19.30 C85.55,18.97 84.89,18.52 84.36,17.93 C83.84,17.35 83.44,16.66 83.17,15.88 C82.91,15.09 82.78,14.25 82.78,13.33 C82.78,12.42 82.91,11.57 83.17,10.78 L83.17,10.78 Z M85.32,15.34 C85.53,15.92 85.81,16.41 86.18,16.80 C86.54,17.19 86.96,17.49 87.45,17.70 C87.94,17.91 88.46,18.01 89.00,18.01 C89.55,18.01 90.06,17.91 90.55,17.70 C91.04,17.49 91.46,17.19 91.83,16.80 C92.19,16.41 92.48,15.92 92.68,15.34 C92.89,14.75 92.99,14.09 92.99,13.33 C92.99,12.58 92.89,11.91 92.68,11.33 C92.48,10.75 92.19,10.25 91.83,9.85 C91.46,9.45 91.04,9.15 90.55,8.94 C90.06,8.73 89.55,8.63 89.00,8.63 C88.46,8.63 87.94,8.73 87.45,8.94 C86.96,9.15 86.54,9.45 86.18,9.85 C85.81,10.25 85.53,10.75 85.32,11.33 C85.11,11.91 85.01,12.58 85.01,13.33 C85.01,14.09 85.11,14.75 85.32,15.34 L85.32,15.34 Z" id="Fill-6"></path>
    <path d="M97.83,7.12 L99.94,7.12 L99.94,19.53 L97.83,19.53 L97.83,7.12 Z" id="Fill-7"></path>
    <path d="M105.19,7.12 L105.19,9.08 L105.24,9.08 C106.12,7.58 107.51,6.83 109.41,6.83 C110.25,6.83 110.95,6.94 111.51,7.16 C112.08,7.39 112.53,7.70 112.88,8.10 C113.23,8.50 113.47,8.98 113.61,9.53 C113.75,10.08 113.82,10.69 113.82,11.36 L113.82,19.53 L111.71,19.53 L111.71,11.12 C111.71,10.36 111.48,9.75 111.02,9.30 C110.56,8.85 109.92,8.63 109.11,8.63 C108.46,8.63 107.91,8.72 107.43,8.92 C106.96,9.11 106.57,9.38 106.26,9.73 C105.94,10.08 105.71,10.50 105.55,10.97 C105.39,11.44 105.32,11.96 105.32,12.52 L105.32,19.53 L103.21,19.53 L103.21,7.12 L105.19,7.12" id="Fill-8"></path>
    <path d="M122.47,7.12 L122.47,8.92 L119.92,8.92 L119.92,16.62 C119.92,16.86 119.94,17.05 119.98,17.20 C120.02,17.34 120.10,17.46 120.22,17.54 C120.33,17.62 120.49,17.67 120.70,17.69 C120.91,17.71 121.18,17.73 121.50,17.73 L122.47,17.73 L122.47,19.53 L120.86,19.53 C120.32,19.53 119.85,19.49 119.46,19.42 C119.07,19.35 118.76,19.22 118.52,19.02 C118.28,18.83 118.10,18.56 117.99,18.21 C117.87,17.86 117.81,17.39 117.81,16.81 L117.81,8.92 L115.63,8.92 L115.63,7.12 L117.81,7.12 L117.81,3.39 L119.92,3.39 L119.92,7.12 L122.47,7.12" id="Fill-9"></path>
    <path d="M0.67,11.87 L2.62,13.76 L8.76,19.50 L11.41,16.94 C11.65,16.61 11.64,16.16 11.36,15.84 L8.94,13.72 L8.95,13.72 L6.34,11.19 C6.04,10.84 6.04,10.32 6.37,9.99 L13.38,3.21 L10.20,0.12 L0.68,9.31 C-0.05,10.02 -0.05,11.17 0.67,11.87" id="Fill-10"></path>
    <path d="M21.60,15.15 L19.66,13.27 L13.51,7.53 L10.86,10.08 C10.62,10.42 10.64,10.87 10.91,11.19 L13.33,13.31 L13.33,13.31 L15.93,15.84 C16.24,16.19 16.23,16.70 15.91,17.04 L8.89,23.82 L12.08,26.91 L19.65,19.60 L21.60,17.71 C22.33,17.01 22.33,15.86 21.60,15.15" id="Fill-11"></path>
    <path d="M44.55,4.58 C44.55,5.24 44.00,5.77 43.32,5.77 C42.64,5.77 42.09,5.24 42.09,4.58 C42.09,3.93 42.64,3.39 43.32,3.39 C44.00,3.39 44.55,3.93 44.55,4.58" id="Fill-12"></path>
    <path d="M100.11,4.58 C100.11,5.24 99.56,5.77 98.88,5.77 C98.20,5.77 97.65,5.24 97.65,4.58 C97.65,3.93 98.20,3.39 98.88,3.39 C99.56,3.39 100.11,3.93 100.11,4.58" id="Fill-13"></path>
  </g>
</svg>
              </div>
              <div class="l-d-f l-d-n--3col l-as-cen">
                <svg width="22px" height="27px" viewBox="0 0 22 27">
    <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g transform="translate(-52.00, -407.00)" fill="#FFFFFF">
            <g transform="translate(52.00, 407.00)">
                <path d="M0.54,11.75 L2.49,13.64 L8.63,19.38 L11.28,16.82 C11.52,16.49 11.51,16.04 11.23,15.72 L8.81,13.60 L8.82,13.60 L6.21,11.07 C5.91,10.72 5.91,10.20 6.24,9.87 L13.25,3.09 L10.06,0 L0.54,9.19 C-0.18,9.90 -0.18,11.05 0.54,11.75"></path>
                <path d="M20.71,14.62 L18.76,12.74 L12.62,7 L9.97,9.55 C9.73,9.89 9.74,10.34 10.02,10.65 L12.44,12.78 L12.43,12.78 L15.04,15.31 C15.34,15.66 15.33,16.17 15.01,16.51 L8,23.29 L11.18,26.38 L18.75,19.06 L20.70,17.18 C21.43,16.48 21.44,15.33 20.71,14.62"></path>
            </g>
        </g>
    </g>
</svg>
              </div>
            </a>
          </section>

          <section class="l-d-f l-w-100 l-ai-str l-jc-fe">
            <a class="navigation-bar-dropdown l-d-n l-d-f--3col l-ai-cen l-pa2 f-minor l-gs-mb0 f-light f-c-white" href="/learning-hubs">
              <i class="l-mr2 f-minor l-mb0 fas f-medium fa-map-marker-alt"></i>
              Learning Hubs
            </a>
            <a class="navigation-bar-dropdown l-d-n l-d-f--3col l-ai-cen l-ml3 l-pa2 f-minor l-mb0 f-light f-c-white"
              href="/premium/topics/all?q=&limit=400&offset=0&page1&content_types[]=Book&ref_source=sitepoint&ref_medium=topnav">
                <i class="l-mr2 f-minor l-mb0 fas f-medium fa-book"></i>
                Books
            </a>
            <a class="navigation-bar-dropdown l-d-n l-d-f--3col l-ai-cen l-ml3 l-pa2 f-minor l-mb0 f-light f-c-white"
              href="/premium/topics/all?q=&limit=400&offset=0&page1&content_types[]=Course&ref_source=sitepoint&ref_medium=topnav">
                <i class="l-mr2 f-minor l-mb0 fas f-medium fa-video"></i>
                Videos
            </a>
            <a class="navigation-bar-dropdown l-d-n l-d-f--3col l-ai-cen l-ml3 l-pa2 f-minor l-gs-mb0 f-light f-c-white" href="/email-courses">
              <i class="l-mr2 f-minor l-mb0 fas f-medium fa-envelope"></i>
              Email Courses
            </a>
                          <div class="l-d-f"><a href="/premium/sign-in" class="Button u-small u-outline u-white l-as-cen l-ml3 l-d-n l-d-b--2col" style="border-width: 1px;">Login</a><a href="/premium/l/join?ref_source=sitepoint&amp;ref_medium=topnav&amp;ref_campaign=announcing-the-alibaba-cloud-competition-winners&amp;ref_content=web" class="Button u-small l-as-cen l-ml3 l-d-n l-d-b--2col">Sign Up</a></div>
                      </section>
        </div>
      </nav>

      <div class="NavBar_offsetSpacer"></div>
      <script>
                var current_category = ['web'];
          if (localStorage.getItem('SP_categories') !== null) {
            if (localStorage.getItem('SP_categories').includes(current_category) === false ) {
              var sp_categories = JSON.parse(localStorage.getItem('SP_categories') || "[]");
              var temp = current_category.concat(sp_categories);
              var filtered_categories = Array.from(new Set(temp));
              localStorage.setItem('SP_categories', JSON.stringify(filtered_categories));
            }
          }else {
            localStorage.setItem('SP_categories', JSON.stringify('web'));
          }
            // campaign
            localStorage.setItem('SP_slug', 'announcing-the-alibaba-cloud-competition-winners');

              </script>
      <div class="widget maestro maestro-content-type-html " id="maestro-744"><sp-fixed-countdown-bar button_url="https://www.sitepoint.com/premium/l/join?ref_source=sitepoint&amp;ref_medium=noticebar&ref_campaign=memberoffer" buttonclass="u-red u-white" end="2018-01-04 22:00:00 +1000" end_message="JOIN 35,339 OTHERS LEARNING WITH SITEPOINT PREMIUM" landingpageclass="v3 l-ph3" ga_event_label="744" button_text="All our Books &amp; Courses for $9/m" banner_text="Sale ends in" sales_text="PREMIUM MEMBER OFFER" bg_color="#e62c85" font_color="#FFF" server-rendered="1"><div class="FixedCountdownBar_trigger t-t false false"><div id="fixed-countdown-bar" class="FixedCountdownBar l-w-100 l-d-f l-jc-cen l-ai-cen l-pv3 l-ph3 f-c-white f-uppercase f-bold v3 l-ph3 false" style="background-color: #e62c85; color: #FFF;"><div class="fixed-countdown-bar__content-wrapper l-d-f l-ph0--4col l-fw-w l-ai-cen l-w-100 l-w-4col--4col l-mh-auto--4col l-ph4--3col l-jc-cen l-fd-col l-fd-row--3col l-jc-sb--3col"><div class="timer__text-wrapper l-d-n l-d-b--2col f-center f-left--2col l-mb3 l-mb0--2col f-uppercase f-medium f-bold"><span class="f-medium f-larger--3col">PREMIUM MEMBER OFFER</span></div><div class="l-mb2 l-mb0--3col l-d-f"><div class="timer__text-wrapper l-w-100 f-center f-left--2col l-mb3 l-mb0--2col l-d-n"><span class="f-large">Sale ends in</span></div><div class="timer__countdown"><div class="f-center f-lh f-small">Sale ends in</div><div class="l-d-f l-mt0--2col l-mr2 f-medium l-mt0"><div class="l-d-f l-ml2 f-large"><span class="f-bold">08</span><span class="f-light">hrs</span></div><div class="l-d-f l-ml2 f-large"><span class="f-bold">55</span><span class="f-light">mins</span></div><div class="l-d-f l-ml2 f-large"><span class="f-bold">00</span><span class="f-light">secs</span></div></div></div></div><div class><a data-ga-on="click" data-ga-event-category="maestro" data-ga-event-label="FixedCountdownBar_744" data-ga-event-action="click" id="fixed-countdown-bar-button" href="https://www.sitepoint.com/premium/l/join?ref_source=sitepoint&amp;ref_medium=noticebar&amp;ref_campaign=memberoffer" class="Button l-ph4 l-pv2 f-small f-medium--3col u-red u-white" style="color: #e62c85; border-color: #FFF; background-color: #FFF;">All our Books &amp; Courses for $9/m</a></div></div><a class="f-c-white l-d-f l-ai-cen l-as-fs l-as-cen--3col l-pa2 t-t"><i class="fas fa-times"></i></a></div></div></sp-fixed-countdown-bar></div>    </header>
<div class="l-p-rel t-bg-white" role="main">
      <div class="l-p-rel l-w-100 l-mh-auto Article_overflow">
          <div class="l-w-100 t-bg">
      <div class="l-w-3col--3col l-mh3 l-mh-auto--3col">
        <div class="f-medium f-c-grey-200 l-pt3">
                    <ol itemscope itemtype='https://schema.org/BreadcrumbList' class='Article_breadcrumb l-ml0 f-minor l-mb0'>
            <li
              class='breadcrumb__item f-capitalize l-d-ib t-ls-n'
              itemprop='itemListElement'
              itemscope
              itemtype='https://schema.org/ListItem'>
              <a
                itemprop='item'
                itemscope
                itemtype='https://schema.org/Thing'
                class='f-c-white f-bold'
                href="https://www.sitepoint.com/web/">
                <span itemprop='name'>
                  web                </span>
              </a>
            </li>
            <li
              class='breadcrumb__item f-c-grey-200 l-d-ib t-ls-n'
              itemprop='itemListElement'
              itemscope
              itemtype='https://schema.org/ListItem'
            >
                              <span itemprop='name'>
                  October 15, 2018                </span>
                          </li>
            <li
              class='breadcrumb__item l-d-ib t-ls-n'
              itemprop='itemListElement'
              itemscope
              itemtype='https://schema.org/ListItem'
              class='breadcrumb_author f-c-white'>
                                                By
                  <a
                    itemprop='item'
                    itemscope
                    itemtype='https://schema.org/Thing'
                    class='f-c-grey-200'
                    href="https://www.sitepoint.com/author/tyaakow/">
                    <span itemprop='name'>
                      Tonino Jankov                    </span>
                  </a>
                                          </li>
          </ol>
        </div>
        <div class="l-d-f l-fd-col l-fd-row--3col l-jc-sb">
          <div>
            <h1 class="l-mt0 f-bold f-icon-bold l-mb4 f-c-white">
              <span class="f-c-white l-mr3">Announcing the Alibaba Cloud Competition Winners</span>
            </h1>
                      </div>
        </div>
      </div>
    </div>
                <div class="l-d-f l-jc-sb l-mt3 l-w-3col--3col l-mh-auto" data-hellobar="content">
        <div class="l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">
                        <div class="l-mb4 l-pa3 l-pt0">
    
      <div class="l-d-f l-jc-cen f-center l-mh-auto l-o-h l-mt3">
              </div>

        <div class="ArticleCopy language-">
      <div class='l-mt3 l-mh5--2col'>
      <p class="wp-special"><em>This article was created in partnership with <a href="https://www.alibabacloud.com/" rel="nofollow">Alibaba Cloud</a>. Thank you for supporting the partners who make SitePoint possible.</em></p>
<p>Judging the submissions wasn&#8217;t easy, due to a number of interesting entries. The criteria for judging submissions <a href="https://www.sitepoint.com/alibaba-competition/#tos">was outlined</a> when the competition was announced. Among the things we considered were tech expertise, potential to be helpful to readers, and how well-written and easy to follow the entry was.</p>
<p>So with all that in mind, our first prize goes to @magyarandrasistvan &#8211; <a href="https://www.sitepoint.com/community/t/deploy-a-laravel-application-to-alibaba-cloud-container-service-using-docker/307357">Deploy a Laravel application to Alibaba Cloud Container Service using Docker</a>. </p>
<p>It is a comprehensive guide that demonstrates usage of several relevant technologies — Docker, Laravel, Apache, Redis, Git, and connects <a href="https://www.alibabacloud.com/product/container-service" rel="nofollow">Alibaba Cloud Container Service</a>, <a href="https://www.alibabacloud.com/product/container-registry" rel="nofollow">Container Registry</a>, Alibaba&#8217;s <a href="https://www.alibabacloud.com/product/vpc" rel="nofollow">Virtual Private Cloud</a>,and <a href="https://www.alibabacloud.com/product/ram" rel="nofollow">Resource Access Management</a>. </p>
<p>The guide demonstrates the creation &amp; use of clusters of <a href="https://www.alibabacloud.com/product/ecs" rel="nofollow">ECS</a> instances. Then it covers setting up <a href="https://www.alibabacloud.com/product/apsaradb-for-redis" rel="nofollow">ApsaraDB for Redis</a> as a session database, and <a href="https://www.alibabacloud.com/product/apsaradb-for-rds-mysql" rel="nofollow">ApsaraDB RDS for MySQL</a>. There are many workflow gems to pick up from the tutorial even for those who use things other than Laravel. </p>
<p>Overall a very solid and straightforward tutorial to follow. The author covers all the necessary steps in-depth, while keeping to the appropriate word length. </p>
<p>The first prize is well-deserved — the guide is relevant, thorough and complete.</p>
<p>The second prize goes to @foolishneo and his article <a href="https://www.sitepoint.com/community/t/building-a-serverless-rest-api-with-function-compute-and-mongodb/307997">Building a Serverless REST API with Function Compute and MongoDB</a>. The article is a part of a series on <a href="https://www.sitepoint.com/community/t/building-a-serverless-application-using-alibaba-cloud-services/308043">serverless app architecture on Alibaba Cloud</a>, and it covers several Alibaba products.</p>
<p>While it is not as technically in-depth as @magyarandrasistvan&#8217;s tutorial, it does leverage <a href="https://www.sitepoint.com/community/t/host-a-static-website-on-alibaba-cloud-object-storage-service-oss/306090">Object Storage Service</a>, <a href="https://www.alibabacloud.com/product/function-compute" rel="nofollow">Function Compute</a>, and other Alibaba products to outline a workflow where we don&#8217;t need to worry about the server stack details, and can focus on our business logic. <a href="https://en.wikipedia.org/wiki/Serverless_computing">Serverless apps</a> are a hot topic among cloud providers, and this topic deserves more coverage. @foolishneo has written quite a good introduction to Alibaba products for serverless app architecture — and deserves credit, so much that we wish there were more awards to give.</p>
<p>And finally, third prize goes to @david369 and his guide <a href="https://www.sitepoint.com/community/t/statically-compiled-go-on-alibaba-cloud-container-service-alibaba-competition/306286">Statically compiled Go on Alibaba Cloud Container Service</a>.</p>
<p>The guide is a succinct tutorial on statically compiling a Go program, and using Docker to containerize and distribute it. This isn&#8217;t a long guide and provides more of a conceptual overview of using containers, but it is a good starting point for advanced deployment workflows. Serious Go deployment scenarios can build on this guide.</p>
<p>There were other notable guides that deserve recognition (at the very least) &#8211; <a href="https://www.sitepoint.com/community/t/create-your-own-wordpress-site-on-alibabacloud-in-few-clicks-only-comprehensive-tutorial-using-the-simple-application-server/306648">Create Your Own WordPress Site on AlibabaCloud</a> by @maljuboori91, <a href="https://www.sitepoint.com/community/t/create-your-own-forum-with-alibaba-ecs-d/307990">Create Your Own Forum with Alibaba ECS</a> by @_alan, <a href="https://www.sitepoint.com/community/t/setting-up-a-docker-based-gitlab-runner-on-alibaba-cloud-ecs/307617">Setting up a Docker-based Gitlab Runner on Alibaba Cloud ECS</a> by @idoko, <a href="https://www.sitepoint.com/community/t/configure-a-mysql-master-slave-replication-on-alibaba-ecs-instances/306500">Configure a MySQL master-slave replication on Alibaba ECS instances</a> guide by @foolishneo, <a href="https://www.sitepoint.com/community/t/install-lemp-on-alibaba-cloud-ecs/305781">Install LEMP on Alibaba Cloud ECS</a> by @igorrinkovec and others.</p>
<p>A special mention goes to user @domovik.vit for his useful submission, <a href="https://www.sitepoint.com/community/t/issues-i-had-to-solve-during-deploying-an-mean-app-in-alibaba-cloud-elastic-compute-service/307379">Issues I had to solve during deploying an MEAN app in Alibaba Cloud Elastic Compute Service</a>.</p>
      <div class="Article_authorBio l-mv4 t-bg-white m-border l-pa3">
        <div class="l-d-f l-pt3">
          <a class="l-s5 l-pa0 l-mr3 l-round l-o-h" href="https://www.sitepoint.com/author/tyaakow/">
            <img src="https://d1nlfd9mjn1pae.cloudfront.net/wp-content/uploads/2017/11/1509945572tyaakow-96x96.jpeg" width="96" height="96" alt="Tonino Jankov" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />          </a>
          <div class="f-lh-title">
            <div class="f-c-grey-300">Meet the author</div>
            <div class="f-large">
              <a class="f-bold f-c-grey-500" href="https://www.sitepoint.com/author/tyaakow/">
                Tonino Jankov              </a>
              <a class="f-c-grey-500 l-mh1" target="_blank" href="https://plus.google.com/105547747802053388040"><i class="fab fa-google-plus-g"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://www.linkedin.com/in/tonino-jankov-40793636/"><i class="fab fa-linkedin-in"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://github.com/tyaakow"><i class="fab fa-github"></i></a>            </div>
          </div>
        </div>
        <div class="f-light f-lh-copy l-mt3">Tonino is a web developer and IT consultant who's dived through open-source code for over a decade. He's also a crypto enthusiast, Linux fan, and moderate libertarian.</div>
      </div>
      
      </div>
    </div>
        </div>
            </div>
              </div>

      <div class="u-accordion-end"></div>
      <div class="l-d-f l-jc-sb l-w-3col--3col l-mh-auto">
        <div class="u-showseriesx l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">

          <div class="widget maestro maestro-content-type-html hide-for-tablet-SP hide-for-mobile-SP" id="maestro-649"><span data-sumome-listbuilder-embed-id="6cbb401075afaa88f82a6ddc686573be3368d07928cf833fe1a56254d6ff9849"></span></div>
                    <div id="commentsSection" class="l-pa3 t-bg-white">
                      </div>
        </div>
      </div>

    
    <script>
      OneSignal.push(function() {
        OneSignal.sendTags({
          web: 'web',
        });
      });
    </script>
      </div>
    </div>
        <footer role="contentinfo">
  <div class="l-w-100 l-d-f Footer-bg">
    <div class="l-d-f l-fw-w l-mh-auto">
      <div class="l-d-f l-fw-w l-mt4 l-w-100 l-pa3 l-w-3col--4col l-jc-sb l-jc-sa--4col">
        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Stuff We Do</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/premium/">Premium</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/versioning/">Versioning</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/community/">Forums</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/html-css/css/">References</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">About</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/about-us/">Our Story</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/press/">Press Room</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Contact</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/contact-us/">Contact Us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="https://sitepoint.zendesk.com/hc/en-us">FAQ</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/write-for-us/">Write for Us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/advertise/">Advertise</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Legals</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/legals/">Terms of Use</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/privacy-policy/">Privacy Policy</a>
          </li>
        </ul>
      </div>
      <div class="l-d-n l-d-b--4col l-as-cen Footer-hr" >
      </div>
      <div class="l-mt4 l-pa3 l-w-1col--4col">
        <ul class="t-ls-n l-d-f l-fw-w l-d-b--3col">
          <li>
            <div class="f-c-white f-large f-bold l-mb2 l-mr3">Connect</div>
          </li>
          <li class="f-center">
            <a class="f-c-grey-300" href="https://www.facebook.com/sitepoint" rel="noopener" target="_blank">
              <i class="fab fa-facebook-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="http://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
              <i class="fab fa-twitter-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="/versioning/">
              <i class="fas fa-envelope-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://www.sitepoint.com/feed/">
              <i class="fas fa-rss-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://plus.google.com/+sitepoint" rel="noopener" target="_blank">
              <i class="fab fa-google-plus-square l-i4"></i>
            </a>
          </li>
          <p class="f-c-grey-300 l-mh-auto l-ml3--2col l-ml0--3col l-mv3--4col f-small f-center">
            &copy; 2000 &ndash; 2018 SitePoint Pty. Ltd.
          </p>
        </ul>
      </div>
    </div>
  </div>
</footer>
    <script type="text/javascript">
  adroll_adv_id = "DJI3I3WGJBGL7PDJEDAYHV";
  adroll_pix_id = "4RKMV6N56FGA7ANPGL4FQW";
  (function () {
    var adblocked = false;
    var onAdblock = function() {
      if(adblocked) return;

      adblocked = true;

      gaEventQueue && gaEventQueue.track('CanSeeAds', 'adrollBlocked', {'nonInteraction': true});

      Array.prototype.slice.call(document.getElementsByClassName('CantSeeAds'))
        .forEach(function(el) {
          el.className = el.className.replace('CantSeeAds', '');
        });

    };
    var _onload = function(){
      if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
      if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
      var scr = document.createElement("script");
      var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
      scr.setAttribute('async', 'true');
      scr.type = "text/javascript";
      scr.src = host + "/j/roundtrip.js";
      scr.onerror = onAdblock;
      ((document.getElementsByTagName('head') || [null])[0] ||
          document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
    };
    if (window.addEventListener) {window.addEventListener('load', _onload, false);}
    else {window.attachEvent('onload', _onload)}
  }());
</script>
    <sp-cookie-warning server-rendered="1"></sp-cookie-warning>
    <script async>(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='64b8e500e3524000ecfa2000d01e2100033e83009398f000ab804c005e0e4300';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script>

<!-- START Parse.ly Include: Standard -->

<div id="parsely-root" style="display: none">
	<div id="parsely-cfg" data-parsely-site="sitepoint.com"></div>
</div>
<script data-cfasync="false">
	(function (s, p, d) {
		var h = d.location.protocol, i = p + "-" + s,
			e = d.getElementById(i), r = d.getElementById(p + "-root"),
			u = h === "https:" ? "d1z2jf7jlzjs58.cloudfront.net"
				: "static." + p + ".com";
		if (e) return;
		e = d.createElement(s);
		e.id = i;
		e.async = true;
		e.setAttribute('data-cfasync', 'false');
		e.src = h + "//" + u + "/p.js";
		r.appendChild(e);
	})("script", "parsely", document);
</script>

<!-- END Parse.ly Include: Standard -->
    <script type="text/javascript">
    (function(googletag, SP_GPT_Slots) {
      if(!SP_GPT_Slots.length) return;

      var SP_GPT_First_Slot_Rendered = false;
      googletag.cmd.push(function(){
        googletag.pubads().addEventListener("slotRenderEnded", function(e){
          if (!SP_GPT_First_Slot_Rendered) {
            gaEventQueue.track("CanSeeAds", "dfpFirstRendered", {"nonInteraction": true});
            SP_GPT_First_Slot_Rendered = true;
          }
        });
      });

    })(googletag, SP_GPT_Slots);
    </script>
<div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-746"><div id="Sticky--bottom" class="l-d-f l-p-fix l-jc-cen u-fixed l-pt3 l-w-100 l-pt3">
<div class="proper-ad-unit">
    <div id="proper-ad-sitepoint_main_1"> <script> propertag.cmd.push(function() { proper_display('sitepoint_main_1'); }); </script> </div>
</div>
<i class="fas fa-times bottom-ad-close-button l-p-a"></i>
</div></div><script type='text/javascript'>
/* <![CDATA[ */
var ratingsL10n = {"plugin_url":"https:\/\/www.sitepoint.com\/wp-content\/plugins\/wp-postratings","ajax_url":"https:\/\/www.sitepoint.com\/wp-admin\/admin-ajax.php","text_wait":"Please rate only 1 item at a time.","image":"thumbs","image_ext":"gif","max":"2","show_loading":"1","show_fading":"1","custom":"1"};
var ratings_1_mouseover_image=new Image();ratings_1_mouseover_image.src="https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-postratings/images/thumbs/rating_1_over.gif";var ratings_2_mouseover_image=new Image();ratings_2_mouseover_image.src="https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-postratings/images/thumbs/rating_2_over.gif";;
/* ]]> */
</script>
<script type='text/javascript' src='https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-postratings/js/postratings-js.js?ver=1.85'></script>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-foot-77d7df963c349e8aaeb6f2c765ce9a6e.js?ver=4.9.6'></script>
<script type="text/javascript" src="/dist/js/compiled.14fecbd88f6d96c6b253.js"></script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-includes/js/wp-embed.min.js?ver=4.9.6'></script>

  </body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 48/79 objects using memcached
Page Caching using memcached 
Content Delivery Network via Amazon Web Services: CloudFront: dab1nmslvvntp.cloudfront.net

Served from: www.sitepoint.com @ 2018-10-15 09:12:01 by W3 Total Cache
-->