SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast
    Join Date
    May 2002
    Location
    Philadelphia
    Posts
    52
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Problem with Mozilla and Safari on my site

    For some reason the image maps on my site do not work in Mozilla and Mac's Safari Browser. I can't figure out what the problem is. Do these browser's accept image mapping? If someone could help me out here I would appreciate it. Please check my source code and tell me if I am doing something wrong. I am completely stumped over this. The problem is on the main site's nav at the top. Here is the address, thanks in advance,
    http://www.deepworldwide.com

  2. #2
    gingham dress, army boots... silver trophy redux's Avatar
    Join Date
    Apr 2002
    Location
    Salford / Manchester / UK
    Posts
    4,838
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    the problem appears to be that Mozilla (and Phoenix, Safari, and others) do not like the use of id
    Code:
    <map id="deepmap">
    adding the name attribute (which should be valid in xhtml...at least the 1.0 transitional)
    Code:
    <map id="deepmap" name="deepmap">
    should solve the problem.
    Last edited by redux; Mar 3, 2003 at 08:58.
    re·dux (adj.): brought back; returned. used postpositively
    [latin : re-, re- + dux, leader; see duke.]
    WaSP Accessibility Task Force Member
    splintered.co.uk | photographia.co.uk | redux.deviantart.com

  3. #3
    SitePoint Enthusiast
    Join Date
    May 2002
    Location
    Philadelphia
    Posts
    52
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you very much. I will try this and see if it solves my problem.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •