Hello all.
followed the info here
http://codex.wordpress.org/Creating_a_Static_Front_Page
and created a home.php. but I wanted my index.php to be the static page.
however when I went to settings>reading>a static page> index.php is not listed as one of the drop down options.

how can I make my index.php my static page?
thx
D