My browser keeps telling me I need a ; after checkCardExpDate(). Doing that still doesn't work. Can anyone help me fix the problem?
PHP Code:
if(!checkCardExpDate())
{
error true;
message message+"\nYou must enter a valid year.";
}
 
function 
checkCardExpDate()
{
var 
nowDate = new Date();
var 
nowYear nowDate.getYear();
var 
nowMonth nowDate.getMonth(); //+1 taken out here
var expYear form1.year.options[form1.year.selectedIndex].value;
var 
expMonth form1.month.options[form1.month.selectedIndex].value;
// some browsers return only 99 for the year so we need
// to compensate for that
if (nowYear == 0)
{
nowYear 2000;
}
if (
nowYear 1900)
{
nowYear nowYear 1900;
}
if (
expYear <= nowYear && expMonth nowMonth)
{
return 
false;
}
else
{
return 
true;
}