jQuery v1.9 will be the last legacy IE support. I guess I will not be upgrading for awhile because IE 10 will remain around 10% usage for quite some time probably because its tied to XP.