Is there anyway to keep the latest joomla 1.5 version safe enough to not have to migrat to 2.5 or even3. I have a wesite that has a lot of info and some modules that re not compatibllw with newer versions. Specially my forum module cant be transfered to 2.5 so i would lose all those forum posts.

What is the best way to keep my joomla 1.5 site as safe from attacks as possible?