SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    Add new title here.. john's Avatar
    Join Date
    Jul 1999
    Location
    Amsterdam, The Netherlands
    Posts
    259
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)

    Trouble starting MySql on XP

    I just installed the latest version of mysql on my XP box. I used "C:\mysql\bin> mysqld-max-nt --install" to install it as a service. So far so good.

    Now when I type c:\ net start mysql

    I get this:

    The MySql service is starting.
    The MySql service could not be starte
    A system error has occurred.
    System error 1067 has occurred.
    The process terminated unexpectedly.

    When is use this command:
    c:\program files\mysql\bin\mysqladmin -u root start

    I get this:

    mysqladmin: connect to server at 'localhost' failed
    error: 'Can't connect to MySQL server on 'localhost' (10061)'
    Check that mysqld is running on localhost and that the port is 3306.
    You can check this by doing 'telnet localhost 3306'

    When I type c:\telnet localhost 3306

    I get this:

    Connecting To localhost...Could not open connection to the host, on port 3306.
    No connection could be made because the target machine actively refused it.

    Any suggestions??

  2. #2
    Making a better wheel silver trophy DR_LaRRY_PEpPeR's Avatar
    Join Date
    Jul 2001
    Location
    Missouri
    Posts
    3,428
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    you need a \WINNT\my.ini file probably. i recommend putting this in it:

    Code:
    [mysqld]
    # Uncomment these to point where you installed
    # MySQL if it's not in C:/mysql
    #basedir=C:/mysql
    #datadir=C:/mysql/data
    port=3306
    skip-innodb
    enable-named-pipe
    set-variable = max_connections=100
    set-variable = key_buffer=8M
    set-variable = join_buffer=1M
    set-variable = record_buffer=1M
    set-variable = sort_buffer=2M
    set-variable = table_cache=1024
    set-variable = thread_cache_size=4
    
    [client]
    port=3306
    # Uncomment these lines and put your username and password
    # if you don't want to enter them all the time
    #user=root
    #password=
    
    [mysqldump]
    quick
    
    [mysql] 
    no-auto-rehash
    - Matt ** Ignore old signature for now... **
    Dr.BB - Highly optimized to be 2-3x faster than the "Big 3."
    "Do not enclose numeric values in quotes -- that is very non-standard and will only work on MySQL." - MattR


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •