Hello,

my config is : windows server 2008 R2, WAMPP, PHP 5.3.0 with SOAP extension enabled.


when i use __soapCall, i obtain this error on screen : Wrong Version

this is the code (i use local copy of WSDL - service.xml) :

Code:
$header = new SoapHeader("....");
 
$file = 'http://www.mysite/service.xml';
try {
$soapclient = new SoapClient(null, array( 'location' => $file, 'uri' => "http://www.mysite/", 'trace' => 1));
$soapclient->__setSOAPHeaders(array($header));
} catch (SoapFault $e) { // error }
...
$parameters = array(...);
 
$params=array(null,                     new SoapParam($parameters, 'parameters'));
$services = $soapclient->__soapCall("myWebService", $params);
if you have a idea, do not hesitate,...

the call of __soapCall is it correct ? problem with SOAP and windows server 2008 ? problem with version of DLL ? ....

Thanks you in advance,

FM