SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Enthusiast
    Join Date
    Jul 2006
    Posts
    27
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Hover problem with Superfish.js

    Hello,

    I have a Wordpress installed in my local pc for testing. I'm using Emagazine theme from iDesignnow.

    Everything ran well, until recently I noticed that the responsive Pulldown menu not working anymore.

    If I hover on menu, the submenu doesn't show up anymore. When I checked on the demo site, it also experiences the same problem.

    You could check it here: http://emagazine.idesignow.com/
    Hovering on GAMES, MOVIE, MUSIC, etc. won't show the sub menu up.

    When I checked using Mozilla Error Console, it reported TypeError: menu is undefined
    It seems the problem originated from superfish.js


    looking forward some advice on this issue.

    Thanks.

  2. #2
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    6,043
    Mentioned
    219 Post(s)
    Tagged
    12 Thread(s)
    Hi there,

    The problem is that this theme is including jQuery version 1.9.0 which appears to have broken some things (for example the menu).

    This is the line that does it (line 27):

    HTML Code:
    <script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js?ver=3.3.1'></script>
    If you change that, to this:

    HTML Code:
    <script type='text/javascript' src='http://code.jquery.com/jquery-1.8.3.min.js'></script>
    Everything will work again.

    HTH

  3. #3
    SitePoint Enthusiast
    Join Date
    Jul 2006
    Posts
    27
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Excellent answer Dave !
    Thanks a lot for your help. It really works now

    Btw, I'm still wondering how this could happen ? I've never touched the theme files, it was working well before, and then suddenly it's just dead.

  4. #4
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    6,043
    Mentioned
    219 Post(s)
    Tagged
    12 Thread(s)
    Hi,

    It seems that the theme is just pulling in the latest jQuery from the Google CDN.
    When Google updated jQuery latest to 1.9.0, then thing s broke.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •