SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    Non-Member XX7509's Avatar
    Join Date
    Feb 2003
    Location
    Antarctica
    Posts
    568
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Talking :raising hand: Newbie Here

    Hi I just download the MySQL from www.mysql.com. I also download a Admin Panel for it, thats written in PHP. I need to run the index.php file to access the admin. When I click on the php file it says "Unknown File Type" I'm pretty sure this system is not setup for running php files.... how do I set it up... what are the requirements?

    I have:

    Windows XP Pro.
    .Net Framework Sp2
    MSDE

    all installed and will soon be having SQL Server installed.

    What do I need to do/download??

    Anyone? please.

  2. #2
    SitePoint Wizard Sillysoft's Avatar
    Join Date
    May 2002
    Location
    United States :)
    Posts
    1,691
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Do you have php installed and a webservice like IIS and apache?

    Silly

  3. #3
    Mlle. Ledoyen silver trophy seanf's Avatar
    Join Date
    Jan 2001
    Location
    UK
    Posts
    7,168
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    So you're running IIS? If so, you need to download and run the PHP 4.3.1 installer from http://www.php.net/downloads.php

    Sean
    Harry Potter

    -- You lived inside my world so softly
    -- Protected only by the kindness of your nature

  4. #4
    Non-Member XX7509's Avatar
    Join Date
    Feb 2003
    Location
    Antarctica
    Posts
    568
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ohhh, yes yes yes. I also have IIS installed

    I've got so many things running I forgot what they all are. But I don't remember ever installing anything for PHP. I'll try that link

    thanks all

  5. #5
    Non-Member XX7509's Avatar
    Join Date
    Feb 2003
    Location
    Antarctica
    Posts
    568
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ummmmmm...... ok, I extracted the files to my wwwroot folder on the C: but it still says unknown file type. I still can't use any of them??? I also installed the, php 4.3.1

  6. #6
    SitePoint Wizard Sillysoft's Avatar
    Join Date
    May 2002
    Location
    United States :)
    Posts
    1,691
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    you extracted the php files to the webroot? dont do that. Extract it to like c:\php. Then in iis you have to configure it to "associate" php extensions to the php.exe file. Which is cgi mode.

    Silly

  7. #7
    SitePoint Wizard Sillysoft's Avatar
    Join Date
    May 2002
    Location
    United States :)
    Posts
    1,691
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

  8. #8
    Non-Member XX7509's Avatar
    Join Date
    Feb 2003
    Location
    Antarctica
    Posts
    568
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    To allow IIS to know how to handle CGI scripts with the .php extension, you must add a script mapping.


    In Internet Services Manager, select your website
    Go to Properties
    Go to the Home Directory tab
    Click on the Configure button
    Select the App Mappings tab
    Insert the following: d:\path\to\php\php.exe %s %s
    [sigh]
    done that, but after I insert the following... the "ok" button is disabled, so I can't save nothing.
    [/sigh]

    and yeah. i changed d:\path\to\blah\blah\blah to the location of my php.exe file.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •