SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Member
    Join Date
    Jan 2013
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    jQuery menu playing up in ie

    Ive got a jQuery menu and slider on this homepage which all shows up fine in Mac and iPad, but on PCs there are some issues!

    The menu seems to show up here: http://ukcpd.net/
    ...but not here: http://www.ukcpd.net/

    Any idea why?

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,319
    Mentioned
    462 Post(s)
    Tagged
    8 Thread(s)
    Hi doug123. Welcome to the forums.

    Off Topic:

    Sorry I can't comment on the issue at hand (on a Mac), but it's better (at least for SEO purposes) not to have your site showing up at both URLs anyway—better to choose one and redirect the other to that.

  3. #3
    SitePoint Member
    Join Date
    Jan 2013
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ralph.m View Post
    Hi doug123. Welcome to the forums.

    Off Topic:

    Sorry I can't comment on the issue at hand (on a Mac), but it's better (at least for SEO purposes) not to have your site showing up at both URLs anyway—better to choose one and redirect the other to that.
    Thanks, how do I make sure all visits etc direct to http:// rather than http://www? Is it in .htaccess?

  4. #4
    Grüße aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    6,048
    Mentioned
    219 Post(s)
    Tagged
    12 Thread(s)
    Quote Originally Posted by doug123 View Post
    Thanks, how do I make sure all visits etc direct to http:// rather than http://www? Is it in .htaccess?
    You would do that with a .htaccess file in the root directory of your website.
    Put this code in it:

    Code:
    Options +FollowSymlinks
    RewriteEngine on
    
    RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
    RewriteRule ^(.*)$ http://%1/$1 [R=301,L]
    This will hopefully have the added benefit of solving your other problem.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •