SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Member
    Join Date
    Jan 2013
    Location
    Carlsbad, CA
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    GeoTrust SSL Certificate for Android devices

    I am currently using the GeoTrust SSL with EV on my eCommerce site. It works nicely for various browsers I have tried.

    However, when I access the site with my android phone, a warning pops up saying that the SSL certificate is from an untrusted source. Does this happen to all SSL on Android, or only to GeoTrust SSL? Should I consider switching SSL provider down the road?

  2. #2
    Community Advisor silver trophy

    Join Date
    Nov 2006
    Location
    UK
    Posts
    2,551
    Mentioned
    40 Post(s)
    Tagged
    1 Thread(s)
    It'll likely be specific to geotrust as I don't see errors on any ssl sites on my android. Their own site says its not readily compatible with android versions earlier than 2.3 http://www.geocerts.com/ssl/browsers

  3. #3
    SitePoint Member
    Join Date
    Jan 2013
    Location
    Carlsbad, CA
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you EastCoast!

    I will contact GeoTrust regarding the "cross root intermediate certificate" they specified on that page.

  4. #4
    SitePoint Zealot
    Join Date
    Jul 2012
    Location
    Scarborough, North Yorkshire, United Kingdom
    Posts
    100
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by CozyOrange View Post
    Thank you EastCoast!

    I will contact GeoTrust regarding the "cross root intermediate certificate" they specified on that page.
    Hi

    Does this support article describe what you are seeing http://support.servertastic.com/rapi...mobile-device/? It may explain why there is different behaviour on different devices.
    Richard
    Resell SSL Certificates - API / WHMCS / HostBill / ClientExec
    ServerTastic - RapidSSL, Geotrust, Thawte, Symantec, SmarterTools and more

  5. #5
    SitePoint Member
    Join Date
    Jan 2013
    Location
    Carlsbad, CA
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by RichardAskew View Post
    Hi

    Does this support article describe what you are seeing http://support.servertastic.com/rapi...mobile-device/? It may explain why there is different behaviour on different devices.
    Yes, I think this is exactly what the problem is. Thank you very much!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •