SitePoint Sponsor

User Tag List

Results 1 to 3 of 3

Hybrid View

  1. #1
    SitePoint Addict
    Join Date
    May 2006
    Location
    Amsterdam
    Posts
    206
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    npm install express warnings

    when running
    Code bash:
    sudo npm install -g express@2.5.8

    i see the following warnings. are they issues that need to be resolved?

    Code bash:
    npm WARN package.json connect@1.9.2 No README.md file found!
    npm WARN engine express@2.5.8: wanted: {"node":">= 0.4.1 < 0.7.0"} (current: {"node":"v0.8.16","npm":"1.1.69"})

  2. #2
    SitePoint Addict
    Join Date
    May 2006
    Location
    Amsterdam
    Posts
    206
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    don, any thoughts, comments, etc ... ?

  3. #3
    SitePoint Author
    Join Date
    Nov 2012
    Posts
    48
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Hi danNL, I have been away. It's nothing to worry about. express 2.5.8 expects a different version of Node.js. Once you have mastered the basics, it's relatively painless to upgrade express and the warnings will go away


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •