SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Enthusiast
    Join Date
    Nov 2012
    Location
    Cape Town, South Africa
    Posts
    40
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    rvsitebuilder and symlinks with cloudlinux securelinks

    Hi guys,

    I have rvsitebuilder and the following in my cpanel,cloudlinux,cagefs,apache config on.

    1. SymLinksIfOwnerMatch in apache configuration
    2. Cloudlinux with securelinks on

    When I created a tryout page everything seems to work fine. When published I noticed that no template thumbnail images were displayed on template sections.
    I then decided to disable (1) and (2) after getting errors in apache error log:

    mod_hostinglimits:Symlink owner mismatch, access denied due to SecureSymLink #31: /home/[domain]/public_html/tryout/www/template/pro_7-473-1_maroon_ferrisWheel_2/s_preview.jpg

    and

    Symbolic link not allowed or link target not accessible

    Any ideas on how to fix this without having to disable these security features?

    Thanks

  2. #2
    Foozle Reducer ServerStorm's Avatar
    Join Date
    Feb 2005
    Location
    Burlington, Canada
    Posts
    2,699
    Mentioned
    89 Post(s)
    Tagged
    2 Thread(s)
    Quote Originally Posted by sahostking View Post
    Hi guys,

    I have rvsitebuilder and the following in my cpanel,cloudlinux,cagefs,apache config on.

    1. SymLinksIfOwnerMatch in apache configuration
    2. Cloudlinux with securelinks on

    When I created a tryout page everything seems to work fine. When published I noticed that no template thumbnail images were displayed on template sections.
    I then decided to disable (1) and (2) after getting errors in apache error log:

    mod_hostinglimits:Symlink owner mismatch, access denied due to SecureSymLink #31: /home/[domain]/public_html/tryout/www/template/pro_7-473-1_maroon_ferrisWheel_2/s_preview.jpg

    and

    Symbolic link not allowed or link target not accessible

    Any ideas on how to fix this without having to disable these security features?

    Thanks
    Are the image files set to the same user permissions as root or as a separate Apache user?
    ictus==""


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •