Hi Don,

I wondered if anyone else has reported problems installing dnode? I have skipped the part in chap 3 covering the http module and moved on for the moment as I couldn't find a solution to this error yet. Great if you have an idea of the prob.

Sam.

Code:
gyp ERR! node -v v0.8.17-pre
gyp ERR! node-gyp -v v0.8.2
gyp ERR! not ok 
npm ERR! weak@0.2.1 install: `node-gyp rebuild`
npm ERR! `sh "-c" "node-gyp rebuild"` failed with 1
npm ERR! 
npm ERR! Failed at the weak@0.2.1 install script.
npm ERR! This is most likely a problem with the weak package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get their info via:
npm ERR!     npm owner ls weak
npm ERR! There is likely additional logging output above.