SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    SitePoint Guru Zygoma's Avatar
    Join Date
    May 2006
    Location
    York, Uk
    Posts
    916
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    List style image not working in IE 9 :-(

    Buon Giorno from zero degrees c thick fog wetherby UK :-)

    On this site http://tutorial.davidclick.com/philpotts-clone.html & illustrated here http://i216.photobucket.com/albums/c...pow-symbol.jpg the pow graphic symbol in the footer only appears in Firefox v 17 but not IE 9.

    Please could someone offer a fix with a bit of theory please.

    Grazie tanto,
    David
    I have had a perfectly wonderful
    evening, but this wasn't it-
    Julius "GROUCHO" Marx - 1890-1977
    http://www.davidclick.com

  2. #2
    . shoooo... silver trophy logic_earth's Avatar
    Join Date
    Oct 2005
    Location
    CA
    Posts
    9,013
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    You must be viewing the page under IE7 mode. Open the developer tools in IE9 (press F12) on the menu bar you have "Browser mode" and "Document mode". The images display fine in IE9, they do not display in IE7 or quirks mode.
    Logic without the fatal effects.
    All code snippets are licensed under WTFPL.


  3. #3
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,613
    Mentioned
    65 Post(s)
    Tagged
    2 Thread(s)
    I don't have IE9 available at the moment, but there are a couple of peculiarities you might want to check.

    Code:
     #orange-footer ul
     {
     background-color:#FFA500;
     width:100%;    /* inappropriate */
     padding:0;    /* you need the default padding-left */
     margin:0;
     overflow:hidden;
     list-style-image: url(pow-30.jpg);
     }
     
      #orange-footer li
      {
      margin-left:20px;    /* your choice */
      float:left;
      min-width:8em;
      }

  4. #4
    SitePoint Wizard bronze trophy chris.upjohn's Avatar
    Join Date
    Apr 2010
    Location
    Melbourne, AU
    Posts
    2,198
    Mentioned
    17 Post(s)
    Tagged
    1 Thread(s)
    Works fine for me in both IE10 and IE9

  5. #5
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,323
    Mentioned
    462 Post(s)
    Tagged
    8 Thread(s)
    Doesn't work so well in Chrome. As ronpat said, rather than have 20px left margin, you should be using left padding of at least 30 px to fit the background image inside the LIs but without it underlapping the text.

  6. #6
    SitePoint Guru Zygoma's Avatar
    Join Date
    May 2006
    Location
    York, Uk
    Posts
    916
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by logic_earth View Post
    You must be viewing the page under IE7 mode. Open the developer tools in IE9 (press F12) on the menu bar you have "Browser mode" and "Document mode". The images display fine in IE9, they do not display in IE7 or quirks mode.
    Thank you so much I had no idea about this.
    I have had a perfectly wonderful
    evening, but this wasn't it-
    Julius "GROUCHO" Marx - 1890-1977
    http://www.davidclick.com

  7. #7
    SitePoint Guru Zygoma's Avatar
    Join Date
    May 2006
    Location
    York, Uk
    Posts
    916
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Added a list-style-position:inside; that seamed to fix images disappearing :-)
    I have had a perfectly wonderful
    evening, but this wasn't it-
    Julius "GROUCHO" Marx - 1890-1977
    http://www.davidclick.com

  8. #8
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,613
    Mentioned
    65 Post(s)
    Tagged
    2 Thread(s)
    Quote Originally Posted by Zygoma View Post
    Added a list-style-position:inside; that seamed to fix images disappearing :-)
    Thanks for posting your fix.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •