SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    Drupaler bronze trophy greg.harvey's Avatar
    Join Date
    Jul 2002
    Location
    London, UK
    Posts
    3,258
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation Urgent IE6/iFrame border problem!

    Hi all,

    I'm having a 'mare with IE6. It refuses to give my iFrames a border of 0. Is this avoidable?? I can't believe it's a bug so what would the code be? I'm using this:

    Code:
    iframe {
    	border: 0px;
    	border-style: none;
    	background-color: #666666;
    
    }
    It looks fine in Mozi, but I still get a border in IE6. VERY annoying.



    G

  2. #2
    Drupaler bronze trophy greg.harvey's Avatar
    Join Date
    Jul 2002
    Location
    London, UK
    Posts
    3,258
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ok. A little more hunting around and (surprise, surprise!) it is an IE6 "ommission" (which I prefer to call bug) from it's CSS support. IE6 doesn't support the border: none CSS for iFrames. However, frameborder="0" in the HTML cures it. Messy, but effective.

    G

  3. #3
    American't awestmoreland's Avatar
    Join Date
    Sep 2002
    Location
    Grand Rapids, MI
    Posts
    1,168
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The tag attribute is actually frameborder e.g.
    Code:
    <iframe id="myframe" src="test.htm" frameborder=0></iframe>
    but I don't know how that equates when it's included in a stylesheet.

    A work-around would might be to set all the borders to be transparent if you can, but I guess that's not ideal.

    I'll keep investigating.


    Andy
    From the English nation to a US location.

  4. #4
    American't awestmoreland's Avatar
    Join Date
    Sep 2002
    Location
    Grand Rapids, MI
    Posts
    1,168
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    D'oh! Too late
    From the English nation to a US location.

  5. #5
    Drupaler bronze trophy greg.harvey's Avatar
    Join Date
    Jul 2002
    Location
    London, UK
    Posts
    3,258
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for your help anyway!

    I was hoping to do it with CSS (as works in Mozi) but it seems the old frameborder parameter is the only way to pull naughty little IE6 in to line.... oh well.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •