SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Guru Zygoma's Avatar
    Join Date
    May 2006
    Location
    York, Uk
    Posts
    916
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Background Color just not appearing in the nav :-(

    Buon giorno from minus 2 degree C Wetherby UK :-)

    On this page http://tutorial.davidclick.com/philpotts-clone.html & Illustrated here
    http://i216.photobucket.com/albums/c...r-glitch-1.jpg I cant get an orange background color to appear behing the nav.

    Any insights welcome with a sprinkling of CSS theory even better :-)

    GRazie Tanto,
    David
    I have had a perfectly wonderful
    evening, but this wasn't it-
    Julius "GROUCHO" Marx - 1890-1977
    http://www.davidclick.com

  2. #2
    SitePoint Wizard bronze trophy chris.upjohn's Avatar
    Join Date
    Apr 2010
    Location
    Melbourne, AU
    Posts
    2,183
    Mentioned
    17 Post(s)
    Tagged
    1 Thread(s)
    A simple question has a simple answer Zygoma, on your #orange-footer ul simply add overflow: hidden which will clear the floats inside the <ul> which are the <li> elements, anytime you float an element you must clear the parent by either using overflow: hidden or a clearfix method otherwise the parent will generate a height and width of 0.
    Blog/Portfolio | Evolution Xtreme | DFG Design | DFG Hosting | CSS-Tricks | Stack Overflow | Paul Irish
    Having lame problems with your code? Let us help by using a jsFiddle

  3. #3
    SitePoint Guru Zygoma's Avatar
    Join Date
    May 2006
    Location
    York, Uk
    Posts
    916
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Big thank you Chris that worked :-)
    I have had a perfectly wonderful
    evening, but this wasn't it-
    Julius "GROUCHO" Marx - 1890-1977
    http://www.davidclick.com


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •