SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Nov 2012
    0 Post(s)
    0 Thread(s)

    Cant get localhost to show “Welcome to Express.”

    Hi all -
    I cant get the local host:3000 webpage to show “Welcome to Express.” in chap 1

    I think i done everything as per the books instructions up to typing in localhost:3000 into the browser but when i do this it says it cant find jade

    Then when i reload the page i cant get anything except

    "Oops! Google Chrome could not connect to localhost:3000 "

    I have removed the current package.json file out of the authentication file and then copied and pasted the whole package.json code of the book into the file

    Then i have cd to authentication and then done the re install of npm install after and node app many times - but with no success
    I took off my firewall and still no luck - im using windows 7

    My main install is in C:\Program Files\nodejs

    and my authentication file is in my working directory C:\Users\newuser\authentication

    Im wondering if anybody got any ideas that might help me out here - Thank you

  2. #2
    Under Construction silver trophybronze trophy AussieJohn's Avatar
    Join Date
    Sep 2005
    Sydney, Australia
    11 Post(s)
    0 Thread(s)
    Have you tried copying running the code from the book. i.e. download the book's code, and head in to the chapter01/authentication folder and run `npm install` from there and then try to run `node app` - see if that works.
    var details = {
    . . web: "",
    . . photos: "",
    . . psa: ""

  3. #3
    SitePoint Author
    Join Date
    Nov 2012
    2 Post(s)
    0 Thread(s)
    Further to AussieJohn's comment, does the console produce any output that you would be able to paste?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts