SitePoint Sponsor

User Tag List

Results 1 to 3 of 3

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    Jul 2012
    Location
    Southampton, United Kingdom
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Emails being forwarded to admin address instead of a target address.

    Hello folks,

    I am having a issue I think is to do with the DNS entries in the MX records. So here is the problem scenario. I host a site (www.example.com) while the mail server is hosted at a different server and is managed by external users as well. I have another site (www.mysite.com) in the same IP and with this, the site and the mail server is hosted at my own server (using Plesk Control Panel). Now the MX entries for both are the following.

    example.co.uk. MX (10) mail.example.co.uk.
    mail.example.co.uk. A 93.131.32.61 (sample Ip)

    mysite.co.uk. MX (10) mail.example.co.uk.
    mail.mysite.co.uk. A 93.131.32.61 (sample Ip)


    Now the issue I am having is that everytime I try to send an email from user@mysite.com to user@example.com, the email is being re-routed back to my admin@mysite.com instead of going to user@example.com. And if I try to send email to user@example.com from any other emails except from @mysite.com, it is being received without any issue. So what am I doing wrong here. Any pointers would be really helpful. Thanks.


    P.S.I hope this is the right area to post this question otherwise I hope the mod will move it to the right forum.

  2. #2
    SitePoint Enthusiast PromptSpace's Avatar
    Join Date
    Jun 2012
    Posts
    96
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Could you post a screenshot of your DNS Zone Records?
    Host4Geeks | Hosting powered by geeks, enhanced with a scoop of
    love and awesomeness!!

    The goal as a company is to have customer service that's not
    just great, but legendary -Henry Ford

  3. #3
    SitePoint Member
    Join Date
    Jul 2012
    Location
    Southampton, United Kingdom
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by PromptSpace View Post
    Could you post a screenshot of your DNS Zone Records?
    aOAUs.jpg

    The above image contains the MX records of the domain the email is being sent to and whose mail server is being hosted/managed separately. The MX record for the domain from which I am trying to send the e-mail to the domain with the attached MX record differ only in the domain name. And I have multiple websites hosted in that same domain (where the website to which the email is being sent is hosted) and all of the emails from any domain to that particular domain is being redirected to the default email. But with other domain whose mail server is not hosted externally, the emails can be sent to each other without any issue.

    And I also did a MX lookup with some external website for that domain and the following image is what is returned. I was wondering if I should change the MX record in our DNS Zone Records to that in the image below?

    U7akn.png

    I hope I made that clear as I am still learning much about DNS records and might not have been able to express it clearly enough. Thank you very much for taking the time to reply.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •