SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Evangelist ktown's Avatar
    Join Date
    May 2001
    Location
    toronto
    Posts
    478
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    netscape 4 problem with floating block

    hello

    i'm trying to creat a sub-menu using CSS - so far it seems to be working in every browser but netscape 4.7 (in the book it says that NS4 "should" support these properties.


    this is my css. [its a work in progress ]
    Code:
     <STYLE TYPE="text/css">
     	<!--
    .productmenu
    {display: block;
    MARGIN: 7px;
    PADDING: 10px;
    BACKGROUND-COLOR: #E3E3C1;
    WIDTH: 170px;
    FLOAT: RIGHT;
    BORDER-STYLE: solid;}
     	-->
     </STYLE>

    this is my html

    Code:
    <SPAN class="productmenu">
      Product Overview<BR><BR> 
      Features<BR><BR>   			 		   
      Brochure<BR><BR>
      </SPAN>
    for some reason - in NS4 it ignores the border-style att., float right, and I also have a stylesheet that is external which specifies fonts etc, (it doesn't use proper fonts..)

    is it bad to have a stylesheet attached and also have some style tags inside your document? i don't really see how it would make a difference is i don't repeat any of my classes.

    anyways
    thanks in advance.~nina

  2. #2
    SitePoint Guru bronze trophy blufive's Avatar
    Join Date
    Mar 2002
    Location
    Manchester, UK
    Posts
    853
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Netscape 4.x CSS support is notoriously flaky, and even when it is reported as "supporting" a property, that support is often incomplete or buggy.

    westciv lists NN4's support for border-style and float as "partial" and "buggy", respectively. However, I reckon you're falling foul of the "partial" support for display

    I'm afraid I usually wimp out when it comes to making NN4 do anything that complex with CSS, so I can't really suggest how to do it.

  3. #3
    SitePoint Wizard Bill Posters's Avatar
    Join Date
    Dec 2001
    Location
    UK
    Posts
    1,523
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I would have thought that if you're setting a border-style, you'll also need to specify a border-width and border-color.
    Otherwise, how is it supposed to know what to use?

    It's just a guess, but I seem to recall hitting a similar problem a while back that was traced back to incomplete attribute 'sets'.
    New Plastic Arts: Visual Communication | DesignateOnline

    Mate went to NY and all he got me was this lousy signature


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •