I have a basic understanding of programming/scripting via JavaScript and I'm just beginning to study PHP. I have a subscription to lynda.com and I'm considering taking the entry-level PHP course that they offer. The only problem is that it's from 2007 and it uses PHP 5.2 and MySQL 5.0. Would it be advisable, in late 2012, to study these older versions, or has too much changed since then?

Thanks!