SitePoint Sponsor

User Tag List

Results 1 to 14 of 14
  1. #1
    SitePoint Enthusiast
    Join Date
    Apr 2011
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Jquery error in IE8

    Hi all,

    coiffurestefan.be
    I receive an error, but don't know what the problem is here...

    Any help is appreciated.

  2. #2
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,358
    Mentioned
    179 Post(s)
    Tagged
    9 Thread(s)
    Hi,

    What exactly is the error you're having?

  3. #3
    SitePoint Enthusiast
    Join Date
    Apr 2011
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It's in Dutch so I can't show you the screenshot.

    But basically it says: this web page contains errors and may not work properly.

    'effects' is empty or no object
    jquery.effects.fold.min.js
    Code:0
    Rule:5

    URI coiffurestefan/wp/wp-includes/js/jquery/ui/jquery.effects.fold.min.js?ver=3.4.2

  4. #4
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,358
    Mentioned
    179 Post(s)
    Tagged
    9 Thread(s)
    Is this on a local page you are testing?
    I've just looked at the url you provided and it looks fine.

    Edit: hang on, I've found the right url: http://coiffurestefan.be/wp/. I'll have a look now.

  5. #5
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,358
    Mentioned
    179 Post(s)
    Tagged
    9 Thread(s)
    Ok, when I visit the above link in IE8 (or below) I see a whole bunch of messages telling me that jQuery is undefined.
    I ran your page through the W3 validator and saw that there are a bunch of errors. Most notably at the bottom of your document you have this:

    HTML Code:
    </body>
    </html>
    <img src="http://coiffurestefan.be/wp/wp-content/uploads/2012/10/bg0011.jpg" id="fsb_image"/><!-- X -->	
    </body>
    </html>
    Try removing the superfluous </body> and </html> tags.
    It could be the case that other browsers are clever enough to ignore them, but they are making IE choke.

  6. #6
    SitePoint Enthusiast
    Join Date
    Apr 2011
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Pullo View Post
    Ok, when I visit the above link in IE8 (or below) I see a whole bunch of messages telling me that jQuery is undefined.
    I ran your page through the W3 validator and saw that there are a bunch of errors. Most notably at the bottom of your document you have this:

    HTML Code:
    </body>
    </html>
    <img src="http://coiffurestefan.be/wp/wp-content/uploads/2012/10/bg0011.jpg" id="fsb_image"/><!-- X -->	
    </body>
    </html>
    Try removing the superfluous </body> and </html> tags.
    It could be the case that other browsers are clever enough to ignore them, but they are making IE choke.
    Thanks! Didn't notice that.

  7. #7
    SitePoint Enthusiast
    Join Date
    Apr 2011
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The javascript error still persists. Please see attachment:
    Do you know how to solve this?

    error.jpg

  8. #8
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,358
    Mentioned
    179 Post(s)
    Tagged
    9 Thread(s)
    Hi,

    I can't see your attachment yet, as it hasn't been approved.

    The when I visit the site in IE8 and open the JavScript console I now see the error:
    Code:
    Uncaught TypeError: Cannot set property 'fold' of undefined 
    jquery.effects.fold.min.js, Zeile 5 Zeichen 16
    I don't see anything resembling the error you posted previously.
    I am looking at: http://coiffurestefan.be/wp/

    Are we talking about the same thing?

    Edit: BTW I also see this error in every other browser

  9. #9
    SitePoint Enthusiast
    Join Date
    Apr 2011
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes it's the same error.
    I don't get the error here.

  10. #10
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,358
    Mentioned
    179 Post(s)
    Tagged
    9 Thread(s)
    What do you mean, you don't get the error here (there?)
    Are you looking at the site with a console open?
    Is something not happening which should be happening?

  11. #11
    SitePoint Enthusiast
    Join Date
    Apr 2011
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi,

    Yes this is a customer website. I don't see the error, but the customer is. So I don't really see what's wrong.

  12. #12
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,358
    Mentioned
    179 Post(s)
    Tagged
    9 Thread(s)
    Hi,

    The fold effect you are referencing here:
    HTML Code:
    <script type='text/javascript' src='http://coiffurestefan.be/wp/wp-includes/js/jquery/ui/jquery.effects.fold.min.js?ver=3.4.2'></script>
    is what's causing the error.

    The reason for this is that you haven't included jQuery UI.
    If you insert this line directly after the one in which you include jQuery, the error will disappear.
    HTML Code:
    <script src="http://ajax.googleapis.com/ajax/libs/jqueryui/1.8/jquery-ui.min.js"></script>
    HTH

  13. #13
    SitePoint Enthusiast
    Join Date
    Apr 2011
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi

    can you check if the problem is solved?

  14. #14
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,358
    Mentioned
    179 Post(s)
    Tagged
    9 Thread(s)
    The error message is indeed gone, but you can check this yourself.
    In Chrome, for example, press F12, click the "Console" tab and refresh the page.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •