SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    I want my 4th arrow! garlinto's Avatar
    Join Date
    Jun 2002
    Location
    Riding the electron wave
    Posts
    372
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy Can't get my nav bar to display right

    In my efforts to be xml/xhtml compliant, I am trying to recode my page to exclude <table>'s and the related code in favor of <div> and <span> elements.

    In so doing, I cannot get my new nav bar to render the same way my table-based one does. I have put them here for you to see: the table-based one on top, the div-based one below. The top one isn't quite displaying right 'cause I tweaked some of the css for the div bar, but you can see that it displays all on one line. That's what I want.

    I've tried a number of things but I can't get the div one to work.

    Any ideas?
    Ducharme's Axiom: "If you view your problem closely
    enough, you will recognize yourself as part of the problem."


  2. #2
    killall -9 lusers
    Join Date
    Oct 2002
    Location
    Cincinnati, Ohio, USA
    Posts
    390
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Didn't look at your CSS as I'm in a hurry, but I noticed that each link is in a seperate div. Div's are block level elements, so they will stack if not told to do otherwise. A good strategy for links is to puth them in an unordered list. Check out this article for some pointers: http://www.alistapart.com/stories/taminglists/

    I actually use there last example on my personal site: http://www.goodchrist.com


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •