SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Aug 2010
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation Help with a parallax web site that is flashing and blinking when it shouldn't be.

    I have a parallax scrolling single-page site that I am working on, and for some reason, when you scroll down to the section called "services" or below (3rd and 4th sections), the page has a constant flash effect occurring. The contact section has even more pronounced "flashing".

    I have no idea what is causing the flashing effect, nor any idea what to modify to get the site to stop flashing.

    The site is under development on my local machine and can be accessed at

    http://alisamii.dyndns.org/ergonomiq...is5/index.html

    By clicking on "SERVICES" in the navbar, the page scrolls down to the specific section and then the flashing begins.

    It is a simple HTML file with jQuery and a few jQuery plugins.

    I would copy code here, but I don't even know what to copy and I don't want to bore everyone with the entire code.

    If someone can point me in the right direction as to what I should copy here, I'll add it. Otherwise, if someone has any idea what the problem is and how I can solve it, I'd really appreciate it.

    FYI, using Firebug in Firefox and Web Inspector in Chrome and Safari, I was unable to find the problem. There are no errors or conflicts that I can find. The CSS is pre-processed using LESS and compiles without errors. The CSS is not minified and has debugging comments if that helps.

    The plugins being used are:

    contact-form.js
    jquery.flexslider.js
    jquery.inview.js
    jquery.prettyPhoto.js
    jquery.sticky.js
    nbw-parallax.js
    smooth-scroll.js

    Also using 3 web fonts (extensions not included in the list for simplicity of reading):
    BEBAS
    fontawesome
    League_Gothic

    I uploaded a short screencast showing what I mean.

    https://vimeo.com/53724547

    If you pause the video and advance frame by frame, you will notice that (around the 5s mark) there is a flash and it seems that the contents of the viewport gets momentarily hidden revealing the logo and company name from the very top of the page on a white background (but since the text is white, you can't read the text).

  2. #2
    SitePoint Member
    Join Date
    Aug 2010
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I moved the site onto a remote host which should have better response times than my local machine.

    http://clients.ergonomiq.net/polarisrm/

  3. #3
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,096
    Mentioned
    448 Post(s)
    Tagged
    8 Thread(s)
    I don't get any flashing in my browsers (on a Mac). It's not clear from the video what is causing the flash. What are you doing at the point where it flashes?
    Facebook | Google+ | Twitter | Web Design Tips | Free Contact Form

    Forum Usage: Tips on posting code samples, images and more

    Forrest Gump: "IE is like a box of chocolates: you never know what you're gonna get."


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •