SitePoint Sponsor

User Tag List

Results 1 to 15 of 15
  1. #1
    SitePoint Zealot superbrava's Avatar
    Join Date
    Aug 2001
    Location
    Indianapolis, IN
    Posts
    104
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Overflow not working

    Code:
    .frame {						overflow: auto;
    							width: 577px;
    							height: 182px;
    							background: #000000 url('../images/www/content_bkgd.gif');}
    any idea why overflow wont work?
    Steve v3.2.2 running on LocalSuck port 80

  2. #2
    ********* Streaker Lister14's Avatar
    Join Date
    Jun 2002
    Location
    C:\Documents and Settings\Desktop\Recycle Bin
    Posts
    677
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    do you have a link? -there might be something else influencing it...
    roy.lu
    C:\DOS... C:\DOS\RUN... RUN\DOS\RUN...!

  3. #3
    SitePoint Zealot superbrava's Avatar
    Join Date
    Aug 2001
    Location
    Indianapolis, IN
    Posts
    104
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    no, it's on my computer at the moment. i'm using IE 6.0.26 on XP.. i dont know if this version reads this CSS element or not. i'm at a total loss.
    Steve v3.2.2 running on LocalSuck port 80

  4. #4
    ********* Streaker Lister14's Avatar
    Join Date
    Jun 2002
    Location
    C:\Documents and Settings\Desktop\Recycle Bin
    Posts
    677
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    well, i've got ie6 too, and usually it is quite good with css... it even reads dtuff other browsers wouldn't...
    roy.lu
    C:\DOS... C:\DOS\RUN... RUN\DOS\RUN...!

  5. #5
    Your Lord and Master, Foamy gold trophy Hierophant's Avatar
    Join Date
    Aug 1999
    Location
    Lancaster, Ca. USA
    Posts
    12,305
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Are you sure you have enough data to cause it to overflow?
    Wayne Luke
    ------------


  6. #6
    SitePoint Zealot superbrava's Avatar
    Join Date
    Aug 2001
    Location
    Indianapolis, IN
    Posts
    104
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    yeah, i made sure there is plenty of data to make it overflow.... it's throwing images off even. my server is down, i'll try and get the site up hopefully later on today. i've looked, and looked, and looked at my code, i dont see what is wrong with it.
    Steve v3.2.2 running on LocalSuck port 80

  7. #7
    ********* Streaker Lister14's Avatar
    Join Date
    Jun 2002
    Location
    C:\Documents and Settings\Desktop\Recycle Bin
    Posts
    677
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    just an idea...

    change the 'class' to an 'id': #frame {}

    it might not matter but it's worth a shot...
    roy.lu
    C:\DOS... C:\DOS\RUN... RUN\DOS\RUN...!

  8. #8
    SitePoint Wizard Ian Glass's Avatar
    Join Date
    Oct 2001
    Location
    Beyond yonder
    Posts
    2,384
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    There's also the possibility that on a previous rule you opened or closed it with a prenth instead of a curly bracket--it's nearly impossible to tell the difference and a mistake I make more often than I should! ;-)

    ~~Ian

  9. #9
    SitePoint Zealot superbrava's Avatar
    Join Date
    Aug 2001
    Location
    Indianapolis, IN
    Posts
    104
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    http://subkultureonline.com/FalseNoiseEmptiness/ <-- url in question... here is my stylesheet...

    Code:
    body {							margin-top: 0px;
    							margin-left: 0px;
    							margin-right: 0px;
    							margin-bottom: 0px;
    							background: #000000;
    							font-family: arial, verdana, sans-serif;
    							font-size: 9pt;
    							font-weight: normal;
    							font-style: normal;
    							color: #FFFFFF;}
    
    td {							font-family: arial, verdana, sans-serif;
    							font-size: 9pt;
    							font-weight: normal;
    							font-style: normal;
    							color: #FFFFFF;}
    
    .content {						width: 577px;
    							height: 182px;
    							overflow: auto;
    							background: #000000 url('../images/www/content_bkgd.gif');}
    i can't find an error!!! :\ grrr heh
    Steve v3.2.2 running on LocalSuck port 80

  10. #10
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,380
    Mentioned
    180 Post(s)
    Tagged
    6 Thread(s)
    Hi,

    What are you trying to achieve with overflow :auto ?

    A setting of auto should generate scroll bars only if the content in the block requires it.

    A setting of visible forces the block to expand to the full width and height of the content displayed.

    A setting of scroll generates scroll bars even when the content doesn't need it but they become active as the content exceeds the block.

    In your code the scroll bars will appear when the content is greater than the block. I have copied your css and it seems to be behaving correctly.

    Hope this helps.

    Paul

  11. #11
    SitePoint Zealot superbrava's Avatar
    Join Date
    Aug 2001
    Location
    Indianapolis, IN
    Posts
    104
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    it wont work for me... right now, there isn't enough content to scroll, but if i ad more, it just messes everything up and wont scroll.
    Steve v3.2.2 running on LocalSuck port 80

  12. #12
    Your Lord and Master, Foamy gold trophy Hierophant's Avatar
    Join Date
    Aug 1999
    Location
    Lancaster, Ca. USA
    Posts
    12,305
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    What browser are you using? Not all of them support that, the major one is Opera in all version before 7Beta1.

    I think the biggest issue is that you are applying the style to a Table Cell. Why not get rid of the interior table and assign the content class to a DIV and see what happens. It might work then.
    Last edited by Hierophant; Jan 11, 2003 at 18:44.
    Wayne Luke
    ------------


  13. #13
    SitePoint Zealot superbrava's Avatar
    Join Date
    Aug 2001
    Location
    Indianapolis, IN
    Posts
    104
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    IE 6.0.26
    Steve v3.2.2 running on LocalSuck port 80

  14. #14
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,380
    Mentioned
    180 Post(s)
    Tagged
    6 Thread(s)
    Can we see all the code or a link?

    It might make it easier to see.

    Paul

  15. #15
    SitePoint Zealot superbrava's Avatar
    Join Date
    Aug 2001
    Location
    Indianapolis, IN
    Posts
    104
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    scroll up a few replies....
    Steve v3.2.2 running on LocalSuck port 80


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •