SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Zealot
    Join Date
    Oct 2012
    Posts
    139
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    embedded YouTube videos: Work in Firefox and Chrome, but not IE : Help?

    This pair of embedded videos appear and function perfectly in both Firefox and Chrome - but just show up as a pair of thin horizontal lines in IE.

    I've looked and looked but can't figure out why. Your brain power is needed. Help?

    The site is built with Twitter Bootstrap. The code is below.
    The page is at http://easydigging.com/Garden_Tool/broadfork.html and the videos are halfway down the page, in the "Details on each Broadfork" section, then within the "UNBREAKABLE Broadfork" tab. When you click the tab you should see the two videos on the right hand side of the screen.

    <div style=text-align:center; >

    <object width="344" height="auto">
    <param name="movie" value="http://www.youtube.com/v/_uZZyNbADKo?version=3&amp;hl=en_US&amp;rel=0;end=65;controls=2;showinfo=0">
    </param>
    <param name="allowFullScreen" value="true"></param>
    <param name="allowscriptaccess" value="always"></param>
    <embed src="http://www.youtube.com/v/_uZZyNbADKo?version=3&amp;hl=en_US&amp;rel=0;end=65;controls=2;showinfo=0" type="application/x-shockwave-flash" width="344" height="auto" allowscriptaccess="always" allowfullscreen="true" alt="video of how to use a broadfork" >
    </embed>
    </object>

    <object width="344" height="auto">
    <param name="movie" value="http://www.youtube.com/v/SfbpjAn__hc?version=3&amp;hl=en_US&amp;rel=0;end=127;controls=2;showinfo=0">
    </param>
    <param name="allowFullScreen" value="true"></param>
    <param name="allowscriptaccess" value="always"></param>
    <embed src="http://www.youtube.com/v/SfbpjAn__hc?version=3&amp;hl=en_US&amp;rel=0;end=127;controls=2;showinfo=0" type="application/x-shockwave-flash" width="344" height="auto" allowscriptaccess="always" allowfullscreen="true" alt="video about why to use a broadfork" >
    </embed>
    </object>

    </div>

  2. #2
    SitePoint Zealot
    Join Date
    Oct 2012
    Posts
    139
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    I finally figured it out. IE didn't like the height set as auto. When I changed it to an actual pixel count it worked fine. Firefox and Chrome still work.

    Note that it had to be changed in TWO places for each video - both in the OBJECT and in the EMBED statements.

    Here is the repaired code:

    <div class="span5" style=text-align:center; >
    <object width="344px" height="194px">
    <param name="movie" value="http://www.youtube.com/v/_uZZyNbADKo?version=3&amp;hl=en_US&amp;rel=0;end=65;controls=2;showinfo=0">
    </param>
    <param name="allowFullScreen" value="true"></param>
    <param name="allowscriptaccess" value="always"></param>
    <embed src="http://www.youtube.com/v/_uZZyNbADKo?version=3&amp;hl=en_US&amp;rel=0;end=65;controls=2;showinfo=0" type="application/x-shockwave-flash" width="344px" height="194px" allowscriptaccess="always" allowfullscreen="true" alt="video of how to use a broadfork" >
    </embed>
    </object>

    <object width="344px" height="194px">
    <param name="movie" value="http://www.youtube.com/v/SfbpjAn__hc?version=3&amp;hl=en_US&amp;rel=0;end=127;controls=2;showinfo=0">
    </param>
    <param name="allowFullScreen" value="true"></param>
    <param name="allowscriptaccess" value="always"></param>
    <embed src="http://www.youtube.com/v/SfbpjAn__hc?version=3&amp;hl=en_US&amp;rel=0;end=127;controls=2;showinfo=0" type="application/x-shockwave-flash" width="344px" height="194px" allowscriptaccess="always" allowfullscreen="true" alt="video about why to use a broadfork" >
    </embed>
    </object>
    </div>


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •