Hi guys.

I have modified a version of opencart to include new tables and have modified the installer sql file. My queries run fine if I run them directly through the console but when I try to run the installer, it uses a PHPMyAdmin SQL dump and it fails complaining of a syntax error at "CREATE TABLE `oc_address` (
`address_id`" which is the first table below. I have racked my brains but cannot see any errors in the syntax, maybe I'm just tired! The strange thing is, the table which it seems to be complaining about is one of the ones I haven't modified.

The original software which I developed live on my hosting used MySql 5.3 but I am trying to get it onto localhost (with wampserver) which has v 5.5 installed, I don't know if this will make a difference?

Can anyone help me please?

-- phpMyAdmin SQL Dump
-- version 3.2.2
-- http://www.phpmyadmin.net
--
-- Host: localhost
-- Generation Time: Apr 06, 2010 at 10:14 PM
-- Server version: 5.5.24
-- PHP Version: 5.3.13



--
-- Database: `OpenCart`
--

-- --------------------------------------------------------

--
-- Table structure for table oc_address
--

CREATE TABLE `oc_address` (
`address_id` int(11) NOT NULL AUTO_INCREMENT,
`customer_id` int(11) NOT NULL,
`company` varchar(32) COLLATE utf8_bin NOT NULL,
`firstname` varchar(32) COLLATE utf8_bin NOT NULL DEFAULT '',
`lastname` varchar(32) COLLATE utf8_bin NOT NULL DEFAULT '',
`address_1` varchar(128) COLLATE utf8_bin NOT NULL,
`address_2` varchar(128) COLLATE utf8_bin NOT NULL,
`postcode` varchar(10) COLLATE utf8_bin NOT NULL DEFAULT '',
`city` varchar(128) COLLATE utf8_bin NOT NULL,
`country_id` int(11) NOT NULL DEFAULT '0',
`zone_id` int(11) NOT NULL DEFAULT '0',
PRIMARY KEY (`address_id`),
KEY `customer_id` (`customer_id`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin AUTO_INCREMENT=1;