SitePoint Sponsor

User Tag List

Results 1 to 5 of 5

Hybrid View

  1. #1
    SitePoint Zealot allanlud's Avatar
    Join Date
    Jul 2012
    Location
    Meath, Ireland
    Posts
    120
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Image showing up on page load for a second

    Hi all, basically having trouble in what the Thread title says. Not too sure if it's a CSS issue though. It's basically a scroll to top button, in a fixed position that appears for a second while the page loads. I'm using 2 seperate script tags for 2 types of scroll, a scroll down the page and a scroll back to top. I don't know anything about javascript/jquery so not sure if that's causing the issue...

    Here's a link - http://www.yoursoccerkit.com/test-si...ague/index.php

    Thanks for any help.
    Al.

  2. #2
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,880
    Mentioned
    208 Post(s)
    Tagged
    12 Thread(s)
    Hi,

    just looked at your page in Chrome.
    It seems fine to me. Did you get this sorted, or am I missing something?

  3. #3
    SitePoint Zealot allanlud's Avatar
    Join Date
    Jul 2012
    Location
    Meath, Ireland
    Posts
    120
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi sorry mate, I changed it a few hours ago, didn't really seem to get much help about it, here or on other forums, and I want to get the site up and running tomorrow. I just changed the code (used a different scroll to top sample I found online), seems to be working pretty good now.

    It was just annoying on the other one that it appeared for a second while the page was loading, and I don't know why.

    Thanks for looking anyway.

    Al.

  4. #4
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,656
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    What was happening in your last example most likely was the image was being hidden with javascript. It took a second for the js to load so that's why the delay. Often you can just say display none in your css. The javascript will often bring it back into view when called. If you need the opposite, meaning you want it there with js on but gone with js off then you need to implement one of these methods. http://www.visibilityinherit.com/cod...javascript.php

  5. #5
    SitePoint Mentor bronze trophy
    ronpat's Avatar
    Join Date
    Jun 2012
    Location
    NJ, USA
    Posts
    2,456
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)
    Eric,

    Thank you for following up with this poster about his question. Turns out that I've asked this same question twice in the JavaScript forum and received no response once and one over-my-head response with no clarification offered. I think the link that you posted nails it for me. Thank you very, very much.

    Ron


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •