SitePoint Sponsor

User Tag List

Results 1 to 24 of 24
  1. #1
    SitePoint Zealot
    Join Date
    Feb 2007
    Posts
    127
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    cloned xampp Wordpress site doesn't show posts

    I've made a local copy of a live WP site with XAMPP and I've noticed my post pages get routed to a XAMPP page titled, "welcome to XAMPP for Windows."
    I've looked at other posts and I don't think it's my .htaccess file permissions, as I've changed them to full permissions.
    Any help greatly appreciated.

  2. #2
    Grüße aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,312
    Mentioned
    177 Post(s)
    Tagged
    8 Thread(s)
    Where do the WordPress files live on your hard drive?
    They should be somewhere below C:/xampp/htdocs (presuming a Windows install)
    The page you are seeing is the default Xampp landing page and is reached via 'http://localhost/'
    You'll need to type 'http://localhost/path_to_the_root_folder_of_your_wordpress_install_relative_to_xamps_htdocs_folder' in to the address bar.
    For example, for me this is 'http://localhost/wordpress/' (imaginatively enough).

  3. #3
    SitePoint Zealot
    Join Date
    Feb 2007
    Posts
    127
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I don't want to have to modify the URL for every page I want to see, so how do I set the path? Do I set the root directory in httpd.conf or something? I'll look at that. So I just did that. It's around line 183. "DocumentRoot "C:/xampp/htdocs/" and I appended the subdirectory at the end of the path. But there must be something else I need to do because that didn't fix it. I cleared Chrome's cache as well. Am I on the right track?

  4. #4
    Grüße aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,312
    Mentioned
    177 Post(s)
    Tagged
    8 Thread(s)
    Let's just see if we can find WP first.
    What happens when you type in 'http://localhost/' followed by the path to your WordPress root directory, relative to the htdocs folder?

    I'm not trying to be funny, I just want to be sure that WP is running, then we can look at how you would rather have things.

  5. #5
    SitePoint Zealot
    Join Date
    Feb 2007
    Posts
    127
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I also tried changing the wp_cofig.php file where it sets the WP_HOME and WP_SITEUDRL and that didn't work either. Should I be using a trailing slash on both of them?

  6. #6
    Grüße aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,312
    Mentioned
    177 Post(s)
    Tagged
    8 Thread(s)
    Dude,
    which folder on your hard drive contains your wordpress files?

  7. #7
    SitePoint Zealot
    Join Date
    Feb 2007
    Posts
    127
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I get to the site by typing in that URL.This is one of those "one-page" sites, so I see a lot of content. But when a link goes to another page for a post, that's when I get to the default xampp page. Thanks for your help.

  8. #8
    Grüße aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,312
    Mentioned
    177 Post(s)
    Tagged
    8 Thread(s)
    Ok, one last try. I think we're getting our wires crossed.
    My wordpress install is located at C:/xampp/htdocs/wordpress.
    This means I can access it via http://localhost/wordpress/ (with trailing slash)

    Where is yours located?

  9. #9
    SitePoint Zealot
    Join Date
    Feb 2007
    Posts
    127
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    path is c:/xampp/htdocs/[folder that contains WP files]
    Sorry,I think we were responding to each other's posts at the same time.

  10. #10
    Grüße aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,312
    Mentioned
    177 Post(s)
    Tagged
    8 Thread(s)
    Ok, and what happens if you enter http://localhost/name-of-folder-that-contains-WP-files/ ?

  11. #11
    SitePoint Zealot
    Join Date
    Feb 2007
    Posts
    127
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I get to the home page of my site with seemingly all the content there. It's only when I have to go to another page (like a post) that I get the xampp screen.

  12. #12
    Grüße aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,312
    Mentioned
    177 Post(s)
    Tagged
    8 Thread(s)
    Ahh, ok, now I understand.
    Sorry.

    Can you access your WP dashboard via http://localhost/WP-folder/wp-admin/ ?

  13. #13
    SitePoint Zealot
    Join Date
    Feb 2007
    Posts
    127
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    yes.

  14. #14
    Grüße aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,312
    Mentioned
    177 Post(s)
    Tagged
    8 Thread(s)
    Cool.
    Go to Dashboard -> Settings -> General and check that the WordPress Address URL is set to http://localhost/WP-folder
    Does that help?

  15. #15
    SitePoint Zealot
    Join Date
    Feb 2007
    Posts
    127
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    yes, it's correct there, but no trailing slash. It's also grayed out so I can't edit it directly there.

  16. #16
    Grüße aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,312
    Mentioned
    177 Post(s)
    Tagged
    8 Thread(s)
    Yeah, the trailing slash isn't important, but it shouldn't be grayed out.
    What does the Site Address say?
    Which version of WP are you running?

  17. #17
    SitePoint Zealot
    Join Date
    Feb 2007
    Posts
    127
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    WP 3.4.2 is the version. site address same as WP address.

  18. #18
    Grüße aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,312
    Mentioned
    177 Post(s)
    Tagged
    8 Thread(s)
    That's weird then.
    What's the .htaccess file in your WP root folder saying?
    Could you post the contents of that file?

  19. #19
    SitePoint Zealot
    Join Date
    Feb 2007
    Posts
    127
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  20. #20
    Grüße aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,312
    Mentioned
    177 Post(s)
    Tagged
    8 Thread(s)
    Change this:
    RewriteBase /

    into:
    RewriteBase /your-wordpress-folder/

    Does that work?

  21. #21
    Grüße aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,312
    Mentioned
    177 Post(s)
    Tagged
    8 Thread(s)
    Sorry, I missed a line.
    The whole code block should be:

    Code:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /your-wordpress-folder/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /your-wordpress-folder/index.php [L]
    </IfModule>

  22. #22
    SitePoint Zealot
    Join Date
    Feb 2007
    Posts
    127
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Worked!

  23. #23
    SitePoint Zealot
    Join Date
    Feb 2007
    Posts
    127
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you, sir!

  24. #24
    Grüße aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,312
    Mentioned
    177 Post(s)
    Tagged
    8 Thread(s)
    You're welcome.
    Happy to help


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •