SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Member
    Join Date
    Jan 2009
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    phone browser replaced an image on my page with an x-rated one

    Yesterday I was alerted to a problem on one of my web pages. One of the photos I used (of storm damage) was instead a "girlie" pic! And just now, a different photo on a different page was instead showing some cocktail glasses. This appeared only on 3 different Verizon 3g and 4g phones. No other device showed the rogue photos. And the rogue photos disappeared later.

    So it seems like the phone's browser is loading substitute images. How can that be?

  2. #2
    Barefoot on the Moon! silver trophy Force Flow's Avatar
    Join Date
    Jul 2003
    Location
    Northeastern USA
    Posts
    4,617
    Mentioned
    56 Post(s)
    Tagged
    1 Thread(s)
    It's likely that your website has been hacked.

    If you use a CMS and haven't been keeping it or its plugins up-to-date, that's usually a common avenue of attack. Newer versions usually patch old vulnerabilities.

    It's usually best to restore the site using a backup from before when the symptoms appeared. Then update your CMS and plugins and change all your passwords.
    Visit The Blog | Follow On Twitter
    301tool 1.1.5 - URL redirector & shortener (PHP/MySQL)
    Can be hosted on and utilize your own domain

  3. #3
    SitePoint Member
    Join Date
    Jan 2009
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    We don't use a CMS. We can certainly change the password though. Thanks for the suggestion.



    Quote Originally Posted by Force Flow View Post
    It's likely that your website has been hacked.

    If you use a CMS and haven't been keeping it or its plugins up-to-date, that's usually a common avenue of attack. Newer versions usually patch old vulnerabilities.

    It's usually best to restore the site using a backup from before when the symptoms appeared. Then update your CMS and plugins and change all your passwords.

  4. #4
    Life is not a malfunction gold trophysilver trophybronze trophy
    TechnoBear's Avatar
    Join Date
    Jun 2011
    Location
    Argyll, Scotland
    Posts
    6,408
    Mentioned
    273 Post(s)
    Tagged
    5 Thread(s)
    I'd also advise you to double-check your site and make sure that there are no files there that shouldn't be. Likewise, check all the existing files to see if they've been modified (or delete everything and upload clean copies from your computer).

  5. #5
    Community Advisor silver trophy

    Join Date
    Nov 2006
    Location
    UK
    Posts
    2,559
    Mentioned
    40 Post(s)
    Tagged
    1 Thread(s)
    Make sure you aren't hotlinking somebody elses image


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •